New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Not receiving RT parameters t_page & t_resp #156

Closed
rzzldzzl opened this Issue Oct 22, 2017 · 4 comments

Comments

Projects
None yet
3 participants
@rzzldzzl

rzzldzzl commented Oct 22, 2017

Hi –
I am working on a simple POC of boomerang. The necessary boomerang js has been added to the default nginx index html. Much information is being sent to the beacon, however, I am not getting RT parameters t_page or t_resp. I do receive RT parameters t_done and t_other.

The webpage I am using for testing can been seen at: http://boomrtest.dyndns.org/

Here is what is recived by the beacon -
ua_raw=Mozilla%2F5.0%20(Macintosh%3B%20Intel%20Mac%20OS%20X%2010_12_6)%20AppleWebKit%2F537.36%20(KHTML%2C%20like%20Gecko)%20Chrome%2F61.0.3163.100%20Safari%2F537.36&guid=&rt.start=navigation&rt.tstart=1508690070222&rt.bstart=1508690070954&rt.end=1508690071516&t_done=1294&t_other=t_head%7C0%2Ct_body%7C1%2Ct_domloaded%7C1292%2Cboomerang%7C562%2Cboomr_fb%7C732&nt_red_cnt=0&nt_nav_type=1&nt_nav_st=1508690070222&nt_red_st=0&nt_red_end=0&nt_fet_st=1508690070228&nt_dns_st=1508690070230&nt_dns_end=1508690070383&nt_con_st=1508690070383&nt_con_end=1508690070463&nt_req_st=1508690070463&nt_res_st=1508690070552&nt_res_end=1508690070554&nt_domloading=1508690070562&nt_domint=1508690071438&nt_domcontloaded_st=1508690071439&nt_domcontloaded_end=1508690071514&nt_domcomp=1508690071515&nt_load_st=1508690071515&nt_load_end=1508690071515&nt_unload_st=1508690070556&nt_unload_end=1508690070556&nt_spdy=0&nt_cinf=http%2F1.1&nt_first_paint=0&u=http%3A%2F%2Fboomrtest.dyndns.org%2F&v=%25boomerang_version%25&vis.st=visible&ua.plt=MacIntel&ua.vnd=Google%20Inc.&pid=4qvmt5k7

What am I missing to capture t_page and t_resp parameter?

Any direction is greatly appreciated.

Thanks,
Joe

@bluesmoon

This comment has been minimized.

Show comment
Hide comment
@bluesmoon

bluesmoon Oct 23, 2017

There appears to be a bug in boomerang where cached_t_start is set after it is required, and therefore t_page and t_resp aren't getting set. As a quick-fix, you can set cached_t_start on line 47 of rt.js to 0.

bluesmoon commented Oct 23, 2017

There appears to be a bug in boomerang where cached_t_start is set after it is required, and therefore t_page and t_resp aren't getting set. As a quick-fix, you can set cached_t_start on line 47 of rt.js to 0.

@rzzldzzl

This comment has been minimized.

Show comment
Hide comment
@rzzldzzl

rzzldzzl commented Oct 23, 2017

Thank you @bluesmoon

@nicjansma

This comment has been minimized.

Show comment
Hide comment
@nicjansma

nicjansma Dec 11, 2017

We've fixed this in our SOASTA (Akamai) code, and will backport the fix here soon.

nicjansma commented Dec 11, 2017

We've fixed this in our SOASTA (Akamai) code, and will backport the fix here soon.

tmartin14 pushed a commit to derkkila/front-end that referenced this issue Feb 5, 2018

@nicjansma

This comment has been minimized.

Show comment
Hide comment
@nicjansma

nicjansma Apr 20, 2018

Please review the changes in the latest backport #188 to see fi they meet your needs

nicjansma commented Apr 20, 2018

Please review the changes in the latest backport #188 to see fi they meet your needs

@nicjansma nicjansma closed this Apr 20, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment