This repository has been archived by the owner. It is now read-only.

@nikosdion nikosdion released this Mar 28, 2018 · 5 commits to master since this release

Assets 3

Release highlights

For more information and documentation for administrators, users and developers please consult the documentation Wiki.

Joomla and PHP Compatibility

Akeeba Social Login is compatible with Joomla! 3.4, 3.5, 3.6, 3.7 and 3.8. Preliminary support for Joomla! 4.0 Alpha 2 is included in this version. See notes. It requires PHP 5.3.10 or later, the same minimum PHP version as Joomla! itself. It's also compatible with PHP 5.4, 5.5, 5.6, 7.0, 7.1 and 7.2.

We strongly recommend using the latest published Joomla! version and PHP 7.0, 7.1 or 7.2 later for optimal security of your site.

Preliminary Joomla! 4 support

Joomla! 4 is still in its very early development stages. While this version of SocialLogin has added preliminary support for Joomla! 4.0 Alpha 2 we cannot guarantee that it will work in any future release of Joomla! 4, be it development or stable. We reserve the right to remove Joomla! 4 compatibility and / or delegate this feature to a future version of our software.

Language files

Akeeba SocialLogin comes with English (Great Britain) language built-in. Installation packages for other languages are available on our language download page.

Changelog

  • Login with LinkedIn
  • Login with Microsoft Account

@nikosdion nikosdion released this Jan 29, 2018 · 17 commits to master since this release

Assets 3

Release highlights

For more information and documentation for administrators, users and developers please consult the documentation Wiki.

Joomla and PHP Compatibility

Akeeba Social Login is compatible with Joomla! 3.4, 3.5, 3.6, 3.7 and 3.8. Preliminary support for Joomla! 4.0 Alpha 2 is included in this version. See notes. It requires PHP 5.3.10 or later, the same minimum PHP version as Joomla! itself. It's also compatible with PHP 5.4, 5.5, 5.6, 7.0, 7.1 and 7.2.

We strongly recommend using the latest published Joomla! version and PHP 7.0, 7.1 or 7.2 later for optimal security of your site.

Preliminary Joomla! 4 support

Joomla! 4 is still in its very early development stages. While this version of SocialLogin has added preliminary support for Joomla! 4.0 Alpha 2 we cannot guarantee that it will work in any future release of Joomla! 4, be it development or stable. We reserve the right to remove Joomla! 4 compatibility and / or delegate this feature to a future version of our software.

Language files

Akeeba SocialLogin comes with English (Great Britain) language built-in. Installation packages for other languages are available on our language download page.

Changelog

New features

  • Login with GitHub

Bug fixes

  • Removed "Add buttons to login page" option since it doesn't do anything useful. You MUST use template overrides for the login page.
  • Missing file from the plugin manifest causes installation failure

@nikosdion nikosdion released this Dec 10, 2017 · 24 commits to master since this release

Assets 3

Release highlights

For more information and documentation for administrators, users and developers please consult the documentation Wiki.

Joomla and PHP Compatibility

Akeeba Social Login is compatible with Joomla! 3.4, 3.5, 3.6, 3.7 and 3.8. Preliminary support for Joomla! 4.0 Alpha 2 is included in this version. See notes. It requires PHP 5.3.10 or later, the same minimum PHP version as Joomla! itself. It's also compatible with PHP 5.4, 5.5, 5.6, 7.0 and 7.1.

We strongly recommend using the latest published Joomla! version and PHP 7.0 or 7.1 later for optimal security of your site.

Preliminary Joomla! 4 support

Joomla! 4 is still in its very early development stages. While this version of SocialLogin has added preliminary support for Joomla! 4.0 Alpha 2 we cannot guarantee that it will work in any future release of Joomla! 4, be it development or stable. We reserve the right to remove Joomla! 4 compatibility and / or delegate this feature to a future version of our software.

Language files

Akeeba SocialLogin comes with English (Great Britain) language built-in. Installation packages for other languages are available on our language download page.

Changelog

2.0.0

New features

  • Compatible with Joomla! 3.4 to 3.8 (inclusive) and, now, also Joomla! 4.0.

Bug fixes

  • gh-16 The buttons should not appear in the back-end of the site by default
  • gh-24 Validated user accounts still result in Joomla! email validation email being sent
  • Fatal error displaying the site's error page

@nikosdion nikosdion released this Dec 6, 2017 · 26 commits to master since this release

Assets 3

Release highlights

For more information and documentation for administrators, users and developers please consult the documentation Wiki.

Joomla and PHP Compatibility

Akeeba Social Login is compatible with Joomla! 3.4, 3.5, 3.6, 3.7 and 3.8. Preliminary support for Joomla! 4.0 Alpha 2 is included in this version. See notes. It requires PHP 5.3.10 or later, the same minimum PHP version as Joomla! itself. It's also compatible with PHP 5.4, 5.5, 5.6, 7.0 and 7.1.

We strongly recommend using the latest published Joomla! version and PHP 7.0 or 7.1 later for optimal security of your site.

Preliminary Joomla! 4 support

Joomla! 4 is still in its very early development stages. While this version of SocialLogin has added preliminary support for Joomla! 4.0 Alpha 2 we cannot guarantee that it will work in any future release of Joomla! 4, be it development or stable. We reserve the right to remove Joomla! 4 compatibility and / or delegate this feature to a future version of our software.

Language files

Akeeba SocialLogin comes with English (Great Britain) language built-in. Installation packages for other languages are available on our language download page.

Changelog

2.0.0

New features

  • Compatible with Joomla! 3.4 to 3.8 (inclusive) and, now, also Joomla! 4.0.

Bug fixes

  • gh-16 The buttons should not appear in the back-end of the site by default
  • gh-24 Validated user accounts still result in Joomla! email validation email being sent
  • Fatal error displaying the site's error page

@nikosdion nikosdion released this Sep 2, 2017 · 60 commits to master since this release

Assets 3

Release highlights

For more information and documentation for administrators, users and developers please consult the documentation Wiki.

Joomla and PHP Compatibility

Akeeba Social Login is compatible with Joomla! 3.4, 3.5, 3.6, 3.7 and 3.8. It requires PHP 5.3.10 or later, the same minimum PHP version as Joomla! itself. It's also compatible with PHP 5.4, 5.5, 5.6, 7.0 and 7.1.

We strongly recommend using the latest published Joomla! version and PHP 7.0 or 7.1 later for optimal security of your site.

Changelog

Bug fixes

  • gh-15 Twitter and Google plugins are not installed

@nikosdion nikosdion released this Aug 15, 2017 · 62 commits to master since this release

Assets 3

Release highlights

First stable release 👏! We are excited to present you Akeeba Social Login, a simple method for users to log in to your site using their social media accoutns.

For more information and documentation for administrators, users and developers please consult the documentation Wiki.

Joomla and PHP Compatibility

Akeeba Social Login is compatible with Joomla! 3.4, 3.5, 3.6 and 3.7. It requires PHP 5.3.10 or later, the same minimum PHP version as Joomla! itself. It's also compatible with PHP 5.4, 5.5, 5.6, 7.0 and 7.1.

We strongly recommend using the latest published Joomla! version and PHP 7.0 or 7.1 later for optimal security of your site.

Changelog

New features

  • Login to Joomla! using your Facebook account
  • Login to Joomla! using your Google account
  • Login to Joomla! using your Twitter account

@nikosdion nikosdion released this Aug 7, 2017 · 67 commits to master since this release

Assets 3

Release highlights

First stable release 👏! We are excited to present you Akeeba Social Login, a simple method for users to log in to your site using their social media accoutns.

For more information and documentation for administrators, users and developers please consult the documentation Wiki.

Joomla and PHP Compatibility

Akeeba Social Login is compatible with Joomla! 3.4, 3.5, 3.6 and 3.7. It requires PHP 5.3.10 or later, the same minimum PHP version as Joomla! itself. It's also compatible with PHP 5.4, 5.5, 5.6, 7.0 and 7.1.

We strongly recommend using the latest published Joomla! version and PHP 7.0 or 7.1 later for optimal security of your site.

Changelog

New features

  • Login to Joomla! using your Facebook account
  • Login to Joomla! using your Google account
  • Login to Joomla! using your Twitter account