Skip to content

Compatibility with Ruby-FFI 1.10.0 is confirmed. Thanks to @Gargron for notifying me the new version of Ruby-FFI.

Assets 2

@akihikodaki akihikodaki released this Dec 26, 2018 · 3 commits to master since this release

So it's that day of this year again! cld3-ruby supports the latest, Ruby 2.6.0. Thanks to @dreyks.

The gem is available at https://rubygems.org/gems/cld3/versions/3.2.3.
The documentation is available at http://www.rubydoc.info/gems/cld3/3.2.3.

Assets 2

@akihikodaki akihikodaki released this Dec 25, 2017 · 14 commits to master since this release

Now you can use cld3-ruby on Ruby 2.5. (thanks to @ykzts) 🎉
I hope your applications will get the latest Ruby soon.

The gem is available at https://rubygems.org/gems/cld3/versions/3.2.2.
The documentation is available at http://www.rubydoc.info/gems/cld3/3.2.2.

Assets 2

@akihikodaki akihikodaki released this Oct 15, 2017 · 18 commits to master since this release

Implemented fallback of hardlink for file systems which don't support it. This change is made with inspiration of https://github.com/yipdw/cld3-ruby.

The gem is available at https://rubygems.org/gems/cld3/versions/3.2.1.
The documentation is available at http://www.rubydoc.info/gems/cld3/3.2.1.

Assets 2

@akihikodaki akihikodaki released this Sep 16, 2017 · 21 commits to master since this release

Introduce TaskContextParams. Its constant LANGUAGE_NAMES allows to get the list of supported languages.
Note that CLD3::NNetLanguageIndetifier#language, which was used to String object, is now symbol to share identity with the values in TaskContextParams::LANGUAGE_NAMES.

The gem is available at https://rubygems.org/gems/cld3/versions/3.2.0.
The documentation is available at http://www.rubydoc.info/gems/cld3/3.2.0.

Assets 2

@akihikodaki akihikodaki released this Jun 13, 2017 · 26 commits to master since this release

Updated CLD3 to 2afbfc6f8b82cb7a5557c81862509e06f4f23ac4.

The gem is available at https://rubygems.org/gems/cld3/versions/3.1.3.
The documentation is available at http://www.rubydoc.info/gems/cld3/3.1.3.

Assets 2

@akihikodaki akihikodaki released this May 18, 2017 · 29 commits to master since this release

Now it aborts the installation if failed to locate protocol buffers.

The gem is available at https://rubygems.org/gems/cld3/versions/3.1.2.
The documentation is available at http://www.rubydoc.info/gems/cld3/3.1.2.

Assets 2

@akihikodaki akihikodaki released this May 18, 2017 · 34 commits to master since this release

Fix for macOS and minor improvements.

The gem is available at https://rubygems.org/gems/cld3/versions/3.1.1.
The documentation is available at http://www.rubydoc.info/gems/cld3/3.1.1.

Assets 2

@akihikodaki akihikodaki released this May 18, 2017 · 41 commits to master since this release

Apply minor changes.
The gem is available at https://rubygems.org/gems/cld3/versions/3.1.0.
The documentation is available at http://www.rubydoc.info/gems/cld3/3.1.0.

Assets 2

@akihikodaki akihikodaki released this May 18, 2017 · 44 commits to master since this release

Initial release.

Assets 2
You can’t perform that action at this time.