Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't open the 'Issue templates / Add' page('Page not found' occurred) #192

Closed
urimaro opened this issue Jul 26, 2018 · 7 comments
Closed

Can't open the 'Issue templates / Add' page('Page not found' occurred) #192

urimaro opened this issue Jul 26, 2018 · 7 comments
Assignees
Labels
bug
Milestone

Comments

@urimaro
Copy link

@urimaro urimaro commented Jul 26, 2018

This is a template to report bug related to redmine issue templates plugin.
You can fill in any format, free style in case report features or questions.

Summary

I can't open the 'Issue templates / Add' page by clicking the 'Add template' link of the 'Issue templates list / edit templates' page.

Description

How to reproduce.

  1. Open a project page
  2. Open the settings page of the project
  3. Open the 'Issue Templates' tab
  4. Click the 'Add template' link
    issue_template_lists_edit_templates
  5. 'Page not found' occurred

The URL of the 'Add template' link may be wrong.
I think the trailing project id must be removed.

http://13.230.243.129:13010/RM10/projects/a/issue_templates/new/a

Environment

These informations are greatly helpful to support quickly.
You can get these informations from Redmine's information page.
(E.g. http://example.com/admin/info)

  • Redmine version:
    3.4.5.stable.17346
  • Installed plugins:
    redmine_issue_templates 0.1.9
  • Ruby version:
    2.4.4-p296 (2018-03-28) [x86_64-linux]
  • OS Platform:
    CentOS Linux release 7.4.1708 (Core)
  • Database (MariaDB, MySQL, PostgreSQL) and its version
    PostgreSQL 9.2.23
  • Rails Env
    Production

Visual Proof / Screenshot

'Page not found' occurred
image

Started GET "/RM10/projects/a/issue_templates/new/a" for 118.243.57.147 at 2018-07-26 07:01:05 +0000
Processing by IssueTemplatesController#new as HTML
  Parameters: {"project_id"=>"a", "id"=>"a"}
  Current user: admin (id=1)
Completed 404 Not Found in 17ms (ActiveRecord: 3.4ms)

ActiveRecord::RecordNotFound (Couldn't find IssueTemplate with 'id'=a):
  plugins/redmine_issue_templates/app/controllers/issue_templates_controller.rb:48:in `new'
  lib/redmine/sudo_mode.rb:63:in `sudo_mode'

Workaround

If you remove the trailing project id, you can access the 'Issue templates / Add' page.
e.g.
http://localhost/projects/a/issue_templates/new/a
->
http://localhost/projects/a/issue_templates/new

@msl12

This comment has been minimized.

Copy link

@msl12 msl12 commented Sep 13, 2018

I got the same error too..

@akiko-pusu

This comment has been minimized.

Copy link
Owner

@akiko-pusu akiko-pusu commented Sep 13, 2018

Hi, thank you so much for reporting.
Issue Template v0.2.0 was released and maybe this issue was fixed.
Please try if you could, I'll also confirmed this problem is still remained or not.

@urimaro

This comment has been minimized.

Copy link
Author

@urimaro urimaro commented Oct 1, 2018

@akiko-pusu
Thank you for your reply.
I tried v0.2.0 but this error has still occurred😢
The identifier has remained at the end of the URL.

What I've done

  1. Checkout v0.2.0
    $ cd path_to_redmine_root/plugins/redmine_issue_templates
    $ git fetch -p
    $ git rebase origin/master
    $ git checkout 0.2.0
  2. Delete assets of the plugin
    $ rm -rf path_to_redmine_root/public/plugin_assets/redmine_issue_templates
  3. Migrate
    $ cd path_to_redmine_root
    $ bin/rake redmine:plugins:assets NAME=redmine_issue_templates RAILS_ENV=production
  4. Restart Redmine
  5. Access with the secret mode not to use caches
@urimaro

This comment has been minimized.

Copy link
Author

@urimaro urimaro commented Oct 1, 2018

@akiko-pusu
It seems the master branch has fixed.
< 29af738
Don't you think so?🤔

@akiko-pusu

This comment has been minimized.

Copy link
Owner

@akiko-pusu akiko-pusu commented Oct 1, 2018

@urimaro San,
Sorry that I could not reply soon, and as you commented above, fixed on commit 29af738 but not included in v0.2.0 tag's changesets....
So, please try master branch for a while if you could, and I'll soon release bugfix version.

Also, thank you so much for your issue reporting, above informations are quite useful and helpful for me.

@akiko-pusu akiko-pusu self-assigned this Oct 1, 2018
@akiko-pusu akiko-pusu added the bug label Oct 1, 2018
@akiko-pusu akiko-pusu added this to the 0.2.1 milestone Oct 1, 2018
@urimaro

This comment has been minimized.

Copy link
Author

@urimaro urimaro commented Oct 1, 2018

@akiko-pusu
That's sound good.
This is an OSS, so you can create new features and fix bugs at your pace.
I'm looking forward to hear your new announce.
Thanks.

@akiko-pusu

This comment has been minimized.

Copy link
Owner

@akiko-pusu akiko-pusu commented Nov 4, 2018

I’ve released v0.2.1. Thanks for your support!

@akiko-pusu akiko-pusu closed this Nov 4, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.