Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

alex == 3.0.1 constraint causes problems #19

Closed
luite opened this Issue · 2 comments

2 participants

@luite

if someone does cabal install alex he'll get version 3.0.2 from hackage. Language-javascript will fail to install with this. Is this intentional?

@alanz
Owner

Well, I was updating it and the compilation breaks with 3.0.2

Strictly speaking Alex is only required for development, if the lexer changes, since the output of Alex is included in the distributed source.

Perhaps I should remove the constraint and note it for development?

Alan

@luite

Ah that sounds annoying. I think 3.0.1 doesn't build with GHC 7.6, so that would require users with only that version to install another GHC. Removing it from the requirements would certainly make it easier for those people.

@alanz alanz closed this in 0b04a58
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.