Permalink
Browse files

make rails icon work again

  • Loading branch information...
alexch committed Jul 5, 2012
1 parent 7237790 commit 9196e53e54ef8be4f1418f539be116baf11e28e5
Showing with 7 additions and 10 deletions.
  1. +0 −1 README.md
  2. +6 −6 lib/rerun/system.rb
  3. +1 −3 rerun.gemspec
View
@@ -152,7 +152,6 @@ While the app is (re)running, you can make things happen by pressing keys:
* https://github.com/guard/guard/issues/59
* https://github.com/guard/guard/issues/27
* Optionally do "bundle install" before and "bundle exec" during launch
-
# Other projects that do similar things
* Restartomatic: <http://github.com/adammck/restartomatic>
View
@@ -19,7 +19,9 @@ def growl?
end
def growlcmd
- `which growlnotify`.chomp
+ growlnotify = `which growlnotify`.chomp
+ # todo: check version of growlnotify and warn if it's too old
+ growlnotify
end
def app_name
@@ -28,12 +30,10 @@ def app_name
end
def icon
- libdir = "#{File.expand_path(File.dirname(File.dirname(__FILE__)))}/lib"
- $LOAD_PATH.unshift libdir unless $LOAD_PATH.include?(libdir)
-
+ here = File.expand_path(File.dirname(__FILE__))
+ icondir = File.expand_path("#{here}/../../icons")
rails_sig_file = File.expand_path(".")+"/config/boot.rb"
- return "#{libdir}/../icons/rails_red_sml.png" if File.exists? rails_sig_file
- return nil
+ "#{icondir}/rails_red_sml.png" if File.exists? rails_sig_file
end
def growl(title, body, background = true)
View
@@ -3,7 +3,7 @@ $spec = Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.name = 'rerun'
- s.version = '0.7.0'
+ s.version = '0.7.1'
s.description = "Restarts your app when a file changes. A no-frills, command-line alternative to Guard, Shotgun, Autotest, etc."
s.summary = "Launches an app, and restarts it whenever the filesystem changes. A no-frills, command-line alternative to Guard, Shotgun, Autotest, etc."
@@ -26,8 +26,6 @@ $spec = Gem::Specification.new do |s|
s.extra_rdoc_files = %w[README.md]
s.add_dependency 'listen'
- #s.add_dependency 'rack', '>= 0.9.1'
- #s.add_dependency 'launchy', '>= 0.3.3', '< 1.0'
s.homepage = "http://github.com/alexch/rerun/"
s.require_paths = %w[lib]

0 comments on commit 9196e53

Please sign in to comment.