Browse files

Braid: Update mirror 'lib/predicated' to 'f4e6825'

  • Loading branch information...
1 parent 4493d7d commit f28915cccc06e82d8de5738c83e953ef8c7f09dc @alexch committed Aug 28, 2010
Showing with 26 additions and 26 deletions.
  1. +1 −1 .braids
  2. +21 −21 lib/predicated/lib/predicated/from/callable_object.rb
  3. +4 −4 lib/predicated/lib/predicated/to/sentence.rb
View
2 .braids
@@ -2,7 +2,7 @@
lib/predicated:
branch: master
remote: braid/lib/predicated
- revision: 696a7062f03a94619c0a85fae0e3de86584f4a11
+ revision: f4e6825c6fde74721143c1e2da8ac6c93695a2da
squashed: true
type: git
url: git://github.com/alexch/predicated
View
42 lib/predicated/lib/predicated/from/callable_object.rb
@@ -9,27 +9,27 @@
#see http://blog.zenspider.com/2009/04/parsetree-eol.html
#
#} if RUBY_VERSION =~/^1.9/
-
-raise %{
-
-You appear to be using ruby 1.8.7 and you don't have
-an INLINEDIR environment variable set to a valid directory.
-
-ParseTree (used by "from_callable_object") uses RubyInline.
-RubyInline requires that the INLINEDIR environment variable point
-to a directory. The easiest thing to do is to just go
-create a directory somewhere - let's say, ~/inlinedir,
-and point the INLINEDIR at it. In bash this would be:
-
-mkdir ~/inlinedir
-export INLINEDIR=~/inlinedir
-
-You'll probably want to put this in .bash_profile too.
-
-Sorry for the inconvenience. I hope the value you'll
-get out of "from_callable_object" makes it all worth it.
-
-} if RUBY_VERSION=="1.8.7" && !ENV["INLINEDIR"]
+#
+#raise %{
+#
+#You appear to be using ruby 1.8.7 and you don't have
+#an INLINEDIR environment variable set to a valid directory.
+#
+#ParseTree (used by "from_callable_object") uses RubyInline.
+#RubyInline requires that the INLINEDIR environment variable point
+#to a directory. The easiest thing to do is to just go
+#create a directory somewhere - let's say, ~/inlinedir,
+#and point the INLINEDIR at it. In bash this would be:
+#
+#mkdir ~/inlinedir
+#export INLINEDIR=~/inlinedir
+#
+#You'll probably want to put this in .bash_profile too.
+#
+#Sorry for the inconvenience. I hope the value you'll
+#get out of "from_callable_object" makes it all worth it.
+#
+#} if RUBY_VERSION=="1.8.7" && !ENV["INLINEDIR"]
#Procs and lambdas are "callable objects"
module Predicated
View
8 lib/predicated/lib/predicated/to/sentence.rb
@@ -3,7 +3,7 @@
module Predicated
- module ContainerSentence
+ module Conjunction
def to_sentence
left.to_sentence + joining_str + right.to_sentence
end
@@ -12,9 +12,9 @@ def to_negative_sentence
"This is not true: " + to_sentence
end
end
-
- class And; include ContainerSentence; def joining_str; " and " end; end
- class Or; include ContainerSentence; def joining_str; " or " end;end
+
+ class And; include Conjunction; def joining_str; " and " end; end
+ class Or; include Conjunction; def joining_str; " or " end;end
class Not
def to_sentence

0 comments on commit f28915c

Please sign in to comment.