Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 68 lines (52 sloc) 1.238 kb
93e46449 »
2010-08-18 Initial migration to rails rc
1 source :rubygems
b748443a »
2010-02-08 Rails 3
2
92bb5316 »
2011-09-01 Updating the bundle
3 gem 'rails', '3.1.0'
32c7c31e »
2011-08-23 Lots of changes, moving to rails 3.1 and starting to use resque
4
5 gem 'bson_ext'
6 gem 'mongoid'
7c241d5d »
2011-08-25 Use Mongoid::Slug to manage slugs
7 gem 'mongoid_slug', :require => 'mongoid/slug'
16ae657b »
2010-09-08 Mostly aesthetic improvements
8
1812a9a2 »
2010-09-16 Comment the Gemfile
9 # Authentication
9c00ba63 »
2010-10-06 Remove version specification
10 gem 'cancan'
80d76a05 »
2010-10-07 Switch to devise!
11 gem 'devise'
16ae657b »
2010-09-08 Mostly aesthetic improvements
12
1812a9a2 »
2010-09-16 Comment the Gemfile
13 # Upload/audio processing gems
32c7c31e »
2011-08-23 Lots of changes, moving to rails 3.1 and starting to use resque
14 gem 'carrierwave-mongoid', :require => 'carrierwave/mongoid'
85da9e97 »
2010-09-06 Use fargo from git
15
1812a9a2 »
2010-09-16 Comment the Gemfile
16 # Display helpers
32c7c31e »
2011-08-23 Lots of changes, moving to rails 3.1 and starting to use resque
17 gem 'kaminari'
18 gem 'redcarpet'
19
e16b254e »
2011-09-20 Use an application manifest for the fargo search page
20 gem 'rack-offline'
21
1812a9a2 »
2010-09-16 Comment the Gemfile
22 # Asset Management
ddd78191 »
2011-08-23 Searching kind of works now
23 group :assets do
24 gem 'jquery-rails'
92bb5316 »
2011-09-01 Updating the bundle
25 gem 'coffee-rails', '~> 3.1.0'
26 gem 'sass-rails', '~> 3.1.0'
ddd78191 »
2011-08-23 Searching kind of works now
27 gem 'ejs'
bdd3a1bb »
2011-09-03 Make a 'heroku' group which only pertains to heroku
28 gem 'uglifier'
ddd78191 »
2011-08-23 Searching kind of works now
29 end
93e46449 »
2010-08-18 Initial migration to rails rc
30
32c7c31e »
2011-08-23 Lots of changes, moving to rails 3.1 and starting to use resque
31 group :development, :test do
32 gem 'heroku'
33 gem 'rspec-rails'
34 end
35
36 group :test do
37 gem 'spork', '> 0.9.0.rc'
38 gem 'database_cleaner'
93e46449 »
2010-08-18 Initial migration to rails rc
39 end
b748443a »
2010-02-08 Rails 3
40
bdd3a1bb »
2011-09-03 Make a 'heroku' group which only pertains to heroku
41 group :heroku do
32c7c31e »
2011-08-23 Lots of changes, moving to rails 3.1 and starting to use resque
42 gem 'therubyracer-heroku'
43 end
44
ddd78191 »
2011-08-23 Searching kind of works now
45 group :worker, :default do
46 # WebSocket notifications
47 gem 'pusher'
48
49 # Queued processing
84547902 »
2011-09-08 Update fargo and require a higher version of resque
50 gem 'resque', '>= 1.18.0'
ddd78191 »
2011-08-23 Searching kind of works now
51 gem 'resque-status', :require => 'resque/status'
52 end
53
32c7c31e »
2011-08-23 Lots of changes, moving to rails 3.1 and starting to use resque
54 group :worker, :test do
55 gem 'ruby-mp3info', :require => 'mp3info'
56
ddd78191 »
2011-08-23 Searching kind of works now
57 gem 'em-http-request' # Required for asynchronous pusher
a8da82f5 »
2011-08-24 Switch to using a websocket to communicate with fargo.
58 gem 'libwebsocket'
8b552387 »
2011-09-03 Use git fargo now
59 gem 'fargo', :git => 'git://github.com/alexcrichton/fargo'
32c7c31e »
2011-08-23 Lots of changes, moving to rails 3.1 and starting to use resque
60 gem 'ruby-shout', :require => 'shout'
c3031537 »
2011-08-24 Require libxml correctly in the Gemfile
61 gem 'libxml-ruby', :require => 'libxml' # parsing output of last.fm
93e46449 »
2010-08-18 Initial migration to rails rc
62 end
ddd78191 »
2011-08-23 Searching kind of works now
63
64 group :useful do
65 gem 'guard-livereload'
bdd3a1bb »
2011-09-03 Make a 'heroku' group which only pertains to heroku
66 gem 'capistrano'
ddd78191 »
2011-08-23 Searching kind of works now
67 end
Something went wrong with that request. Please try again.