Go library for the VMware vSphere API
Clone or download
Pull request Compare This branch is 2 commits behind vmware:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
event
examples
find
gen
govc
guest
internal
license
list
lookup
nfc
object
ovf
pbm
performance
property
scripts
session Add LoginByToken to session KeepAliveHandler Oct 8, 2018
simulator
ssoadmin
sts
task
test
toolbox
units
vapi
vcsim
vendor/github.com
view
vim25
vmdk
vslm
.gitignore
.goreleaser.yml
.mailmap
.travis.yml
CHANGELOG.md
CONTRIBUTING.md
CONTRIBUTORS
Dockerfile
Gopkg.lock
Gopkg.toml
LICENSE.txt
Makefile
README.md
client.go
client_test.go
program.mk

README.md

Build Status Go Report Card

govmomi

A Go library for interacting with VMware vSphere APIs (ESXi and/or vCenter).

In addition to the vSphere API client, this repository includes:

  • govc - vSphere CLI

  • vcsim - vSphere API mock framework

  • toolbox - VM guest tools framework

Compatibility

This library is built for and tested against ESXi and vCenter 6.0, 6.5 and 6.7.

It may work with versions 5.5 and 5.1, but neither are officially supported.

Documentation

The APIs exposed by this library very closely follow the API described in the VMware vSphere API Reference Documentation. Refer to this document to become familiar with the upstream API.

The code in the govmomi package is a wrapper for the code that is generated from the vSphere API description. It primarily provides convenience functions for working with the vSphere API. See godoc.org for documentation.

Installation

go get -u github.com/vmware/govmomi

Discussion

Contributors and users are encouraged to collaborate using GitHub issues and/or Slack. Access to Slack requires a VMware {code} membership.

Status

Changes to the API are subject to semantic versioning.

Refer to the CHANGELOG for version to version changes.

Projects using govmomi

Related projects

License

govmomi is available under the Apache 2 license.