Spiral problems in 1.0.0RC2 & latest stable #1773

Closed
jkoljo opened this Issue Feb 12, 2014 · 6 comments

Comments

Projects
None yet
2 participants

jkoljo commented Feb 12, 2014

The spiral vase option produces bad surface quality with 1.0.0RC2 and latest stable, which I compiled just 10 minutes ago (23:22 12.2.2014 GMT+2). When I slice with 0.9.10b, everything is fine, and the surface becomes even.

I am running Slic3r on top of Windows 7 64b, and my friend is also having problems with W7 32b. There are no error messages.

You can get the test stl file, used config, and also produced gcode from here: https://drive.google.com/file/d/0B1BLAmnPOg2AOUFFb2NJNHRKb2M/edit?usp=sharing

such_problem_wow

@alexrj alexrj added this to the 1.0.0RC3 milestone Feb 12, 2014

Owner

alexrj commented Feb 12, 2014

Just one more information: have you tried printing both G-code files or are you only comparing them using Repetier-Host?

jkoljo commented Feb 12, 2014

No, I have not tried printing. But I have tested gcode.ws and it shows the same problems as repetier host.

Owner

alexrj commented Feb 12, 2014

Yes, I confirm the generated G-code has issues. I'm working on a regression test.

Owner

alexrj commented Feb 13, 2014

I wrote a regression test and started working on the fix.

Owner

alexrj commented Feb 13, 2014

I fixed this. The regression test will guard against any further issues on this. Thank you for reporting!

@alexrj alexrj closed this Feb 13, 2014

alexrj added a commit that referenced this issue Feb 13, 2014

Regression test and incomplete fix for bug affecting wrong spiral vas…
…e output. #1773

Conflicts:

	lib/Slic3r/GCode/Layer.pm

@alexrj alexrj added Fixed and removed Verified bug labels Feb 13, 2014

jkoljo commented Feb 13, 2014

Cool, thank you very much! 👍

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment