Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Spiral problems in 1.0.0RC2 & latest stable #1773

Closed
jkoljo opened this Issue · 6 comments

2 participants

@jkoljo

The spiral vase option produces bad surface quality with 1.0.0RC2 and latest stable, which I compiled just 10 minutes ago (23:22 12.2.2014 GMT+2). When I slice with 0.9.10b, everything is fine, and the surface becomes even.

I am running Slic3r on top of Windows 7 64b, and my friend is also having problems with W7 32b. There are no error messages.

You can get the test stl file, used config, and also produced gcode from here: https://drive.google.com/file/d/0B1BLAmnPOg2AOUFFb2NJNHRKb2M/edit?usp=sharing

such_problem_wow

@alexrj alexrj added this to the 1.0.0RC3 milestone
@alexrj
Owner

Just one more information: have you tried printing both G-code files or are you only comparing them using Repetier-Host?

@jkoljo

No, I have not tried printing. But I have tested gcode.ws and it shows the same problems as repetier host.

@alexrj
Owner

Yes, I confirm the generated G-code has issues. I'm working on a regression test.

@alexrj alexrj added the Verified bug label
@alexrj
Owner

I wrote a regression test and started working on the fix.

@alexrj
Owner

I fixed this. The regression test will guard against any further issues on this. Thank you for reporting!

@alexrj alexrj closed this
@alexrj alexrj referenced this issue from a commit
@alexrj Regression test and incomplete fix for bug affecting wrong spiral vas…
…e output. #1773

Conflicts:

	lib/Slic3r/GCode/Layer.pm
0060873
@alexrj alexrj added Fixed and removed Verified bug labels
@jkoljo

Cool, thank you very much! :+1:

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.