Small Perimeters Speed does not work #2365

Closed
brannan opened this Issue Nov 20, 2014 · 5 comments

Projects

None yet

3 participants

@brannan
brannan commented Nov 20, 2014

Slic3r 1.1.7
Sliced according to attached config.

Config pasted below and linked in follow-on comment.
Screenshot of gcode attached
Stl link in follow on comment
Two different radius of 5mm and under run at full speed.

slicecapture

generated by Slic3r 1.1.7 on Wed Nov 19 22:13:29 2014

avoid_crossing_perimeters = 0
bed_size = 203,250
bed_temperature = 100
bottom_solid_layers = 2
bridge_acceleration = 0
bridge_fan_speed = 100
bridge_flow_ratio = 1
bridge_speed = 30
brim_width = 0
complete_objects = 0
cooling = 0
default_acceleration = 0
disable_fan_first_layers = 1
dont_support_bridges = 1
duplicate_distance = 6
end_gcode = M104 S0 ; turn off temperature\nM140 S0 ; turn off bed temperature\nG28 X0 ; home X axis\nM84 ; disable motors
external_perimeter_speed = 55
external_perimeters_first = 0
extra_perimeters = 1
extruder_clearance_height = 20
extruder_clearance_radius = 20
extruder_offset = 0x0
extrusion_axis = E
extrusion_multiplier = 1
extrusion_width = 0
fan_always_on = 0
fan_below_layer_time = 60
filament_diameter = 2.91
fill_angle = 45
fill_density = 25%
fill_pattern = rectilinear
first_layer_acceleration = 0
first_layer_bed_temperature = 100
first_layer_extrusion_width = 0
first_layer_height = 0.3
first_layer_speed = 30
first_layer_temperature = 235
g0 = 0
gap_fill_speed = 20
gcode_arcs = 0
gcode_comments = 0
gcode_flavor = reprap
infill_acceleration = 0
infill_every_layers = 1
infill_extruder = 1
infill_extrusion_width = 0
infill_first = 0
infill_only_where_needed = 0
infill_speed = 60
interface_shells = 0
layer_gcode =
layer_height = 0.2
max_fan_speed = 100
min_fan_speed = 60
min_print_speed = 10
min_skirt_length = 0
notes =
nozzle_diameter = 0.4
only_retract_when_crossing_perimeters = 1
ooze_prevention = 0
output_filename_format = [input_filename_base].gcode
overhangs = 1
perimeter_acceleration = 0
perimeter_extruder = 1
perimeter_extrusion_width = 0
perimeter_speed = 60
perimeters = 2
post_process =
print_center = 101.5,125
raft_layers = 0
resolution = 0
retract_before_travel = 2
retract_layer_change = 1
retract_length = 1.5
retract_length_toolchange = 10
retract_lift = 0
retract_restart_extra = 0
retract_restart_extra_toolchange = 0
retract_speed = 30
seam_position = nearest
skirt_distance = 6
skirt_height = 1
skirts = 1
slowdown_below_layer_time = 20
small_perimeter_speed = 30
solid_fill_pattern = rectilinear
solid_infill_below_area = 70
solid_infill_every_layers = 0
solid_infill_extrusion_width = 0
solid_infill_speed = 60
spiral_vase = 0
standby_temperature_delta = -5
start_gcode = G28 ; home all axes\n
support_material = 0
support_material_angle = 0
support_material_enforce_layers = 0
support_material_extruder = 1
support_material_extrusion_width = 0
support_material_interface_extruder = 1
support_material_interface_layers = 3
support_material_interface_spacing = 0
support_material_interface_speed = 100%
support_material_pattern = honeycomb
support_material_spacing = 2.5
support_material_speed = 60
support_material_threshold = 0
temperature = 230
thin_walls = 1
threads = 2
toolchange_gcode =
top_infill_extrusion_width = 0
top_solid_infill_speed = 55
top_solid_layers = 2
travel_speed = 100
use_firmware_retraction = 0
use_relative_e_distances = 0
vibration_limit = 0
wipe = 0
z_offset = 0

@brannan
brannan commented Nov 22, 2014

I just verified that this behavior does not occur on Slic3r 1.0.1. So this is definitely a regression, and rather critical one at that.

@brannan brannan changed the title from Small Perimeter Speeds does not work to Small Perimeters Speed does not work Nov 22, 2014
@alexrj
Owner
alexrj commented Nov 23, 2014

Thank you for the report. I fixed this.

@alexrj alexrj closed this Nov 23, 2014
@alexrj alexrj added this to the 1.2.2 milestone Nov 23, 2014
@alexrj alexrj added the Fixed label Nov 23, 2014
@justmyopinion

Probably the same mentioned in #2329

@alexrj alexrj added a commit that referenced this issue Nov 23, 2014
@alexrj Fix error in a1193d2. #2365
God bless regression tests.
4925b05
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment