Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Extra length on restart does not work correctly for negative values. #654

Closed
capitaenz opened this Issue · 10 comments

5 participants

@capitaenz

If negative values ​​are entered, for example -0.20, then the objects are not correctly sliced.

@Zemciko

Same problem here. Negative value should reduce restart amount of material but it does not work.

@alexrj
Owner

Can you please tell what version are you using and paste your full config.ini?

@capitaenz

My Config:

generated by Slic3r 0.9.1 on Fri Sep 21 19:13:36 2012
acceleration = 0
bed_size = 200,200
bed_temperature = 0
bridge_fan_speed = 100
bridge_flow_ratio = 1
bridge_speed = 60
brim_width = 0
complete_objects = 0
cooling = 1
disable_fan_first_layers = 1
duplicate = 1
duplicate_distance = 6
duplicate_grid = 1,1
end_gcode = ; M104 S0 ; turn off temperature\n; G28 X0 ; home X axis\n; M84 ; disable motors
external_perimeter_speed = 100%
extra_perimeters = 1
extruder_clearance_height = 20
extruder_clearance_radius = 20
extruder_offset = 0x0
extrusion_axis = E
extrusion_multiplier = 1
extrusion_width = 0
fan_always_on = 0
fan_below_layer_time = 60
filament_diameter = 3.00
fill_angle = 45
fill_density = 0.4
fill_pattern = rectilinear
first_layer_bed_temperature = 0
first_layer_extrusion_width = 200%
first_layer_height = 100%
first_layer_speed = 30%
first_layer_temperature = 175
g0 = 0
gcode_arcs = 0
gcode_comments = 0
gcode_flavor = reprap
infill_acceleration = 50
infill_every_layers = 1
infill_extruder = 1
infill_extrusion_width = 0
infill_speed = 60
layer_gcode =
layer_height = 0.4
max_fan_speed = 100
min_fan_speed = 35
min_print_speed = 25
notes =
nozzle_diameter = 0.40
output_filename_format = [input_filename_base].gcode
perimeter_acceleration = 25
perimeter_extruder = 1
perimeter_extrusion_width = 0
perimeter_speed = 30
perimeters = 3
post_process =
print_center = 100,100
randomize_start = 1
retract_before_travel = 4
retract_length = 1.20
retract_lift = 0.40
retract_restart_extra = -0.20
retract_speed = 20
rotate = 0
scale = 1
skirt_distance = 6
skirt_height = 1
skirts = 1
slowdown_below_layer_time = 15
small_perimeter_speed = 30
solid_fill_pattern = rectilinear
solid_infill_speed = 60
solid_layers = 3
start_gcode = ; G28 ; home all axes
support_material = 0
support_material_angle = 0
support_material_extruder = 1
support_material_extrusion_width = 0
support_material_pattern = rectilinear
support_material_spacing = 2.5
support_material_threshold = 45
temperature = 175
threads = 2
top_solid_infill_speed = 50
travel_speed = 130
use_relative_e_distances =
z_offset = 0

Same problem with version 0.9.2

normal
-0.20

@capitaenz

similar problem with 0.9.3
The printing results look bad, like in the picture.

@alexrj
Owner

Finally fixed! I wanted to add a full test suite for retraction before fixing this.

@alexrj alexrj closed this
@tritol

I still have this issue in actual git (5c1336d), Linux Mint Debian Edition

STL: http://www.thingiverse.com/download:136816

with negative value
with 0

files: http://tritol.trilogic.cz/config_and_gcode.zip

@alexrj alexrj reopened this
@alexrj
Owner

@tritol, I just tried to open your broken.gcode file with a recent Repetier-Host and it displays like the second image, not like the first one, so it looks correct. Maybe it was just a rendering bug of old Repetier-Host versions?
Could you please check yourself and tell me whether we can close this issue? Thank you!

@mesheldrake
Collaborator

While looking at this for another thinwall test, I confirmed that @tritol's "broken" gcode looks broken in Repetier 0.84, but displays properly in Repetier 0.85c (Ubuntu).

@tritol

Can confirm latest version of Slic3r and Repetier 0.85c works just fine without this issue. Close it. Thanks

@alexrj
Owner

Thank you for your feedback!

@alexrj alexrj closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.