Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Unexpected bridge over hole #858

Closed
scottp opened this Issue · 12 comments

4 participants

@scottp

When printing the draw from here - http://www.thingiverse.com/download:102257 the GCode produced added a single layer bridged across the top.

Files attached...

@scottp

OK... what is the point of a issue system which can't attach files other than images...

@scottp

Image of top layer added - it is only a single layer, so will be easy to cut away - http://www.daddycrumbs.com/Other/Camera-Awesome-Photos/26793284_f8QJQL#!i=2267870719&k=bMPGZmJ

@mesheldrake
Collaborator

I was able to reproduce this with 0.9.8-dev, with default config. Will look into it.

@mesheldrake
Collaborator

@scottp - How is Open Draw involved? Or did you get program names mixed up?

@scottp
@scottp
@alexrj
Owner

Issue renamed.

I could reproduce this issue too using default settings. The problem is that an extra ccw contour is being detected at z = 25.00, and the NONZERO fill type is causing it to override the large hole inside (union of 2 ccw + 1 cw = 1 ccw with no holes).

I think this is linked to #357, and the solution about changing scaling I mentioned there could fix this.

@alexrj
Owner

Update: I tried slicing unscaled data but the problem still happens. I'm not applying that change as there's no advantage (processing is a bit slower too). Maybe the alignment to Z = 0 is causing the issue.

@alexrj
Owner

Okay, I isolated the problem and added a failing test case. Fix is coming shortly.

@alexrj
Owner

Fixed!

@alexrj alexrj closed this
@funbart funbart referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@funbart funbart referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@funbart funbart referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@funbart funbart referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@funbart funbart referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@funbart funbart referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@Lightn

I am still seeing this issue in a specific situation.

Using a build from 34e0472 I am seeing a problem with this model:
http://bukobot.com/_media/power_supply_plate_with_fan_guard.stl.zip

But only in the follow scenario:
Default settings, except
Layer height = 0.2
First layer height = 0.3
Object rotated, seemingly at any orientation

So this seems related to #357.
Hole

Also, this unexpected bridging at layer 25 is the only thing on that layer, which leaves a gap.

@funbart funbart referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@funbart funbart referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@funbart funbart referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.