Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Commits on Jul 14, 2014
  1. @aonashi

    fixed a bug when using should_not be_a_migration

    aonashi authored committed
  2. @strzibny
  3. Merge pull request #30 from d4rky-pl/master

    authored
    Compatilibilty with Rails 4 (but tests are failing for rspec 2.x)
    
    Thx @d4rky-pl
Commits on Jul 13, 2014
  1. @d4rky-pl

    Add rails_helper to tests.

    d4rky-pl authored
    Fixes "Don't know how to build task 'test:prepare'" error
  2. @d4rky-pl
Commits on Jul 11, 2014
  1. @d4rky-pl
Commits on Apr 7, 2014
  1. v1.0.0

    authored
  2. travis ignores ruby 1.8.7

    authored
    Ammeter works with 1.8.7 but travis fails because rails 4 does not.
Commits on Mar 28, 2014
  1. able to test against different versions of rspec by setting environme…

    authored
    …nt var: RSPEC_VERSION
    
    Passing against HEAD, 2.99 & 2.14
    Fails on 3.0.0.beta2 (but head is > than that so might be ok for now)
Commits on Mar 25, 2014
Commits on Mar 24, 2014
  1. Fix for ruby 1.9.3

    authored
    Change .match to =~ as suggested by @cupakromer in 5e7ec35#commitcomment-5770325
Commits on Mar 23, 2014
  1. Merge pull request #25 from alindeman/file_exist

    authored
    Fixes deprecated use of File.exists?
Commits on Mar 22, 2014
  1. @alindeman
  2. allow ruby 1.9.3 to fail on travis. Timeout issue but tests pass loca…

    authored
    …lly so seems safe-ish to allow failure
  3. Depends on RSpec >= 3.0

    authored
    Ammeter tests use git version of rspec gems since 3.0 is not yet released.
    
    TODO: when rspec3 is released change the dependencies to ">=3.0"
Commits on Mar 21, 2014
  1. Updates for latest rspec (heading towards rspec3)

    authored
    * rspec removed "describes" and replaced with "described_class"
    * changes to ammeter's specs so they run with the latest rspec
Commits on Jun 6, 2013
  1. Merge pull request #20 from pabloh/release_version_0.2.9

    authored
    Release version 0.2.9
  2. @pabloh

    Prepare release 0.2.9

    pabloh authored
Something went wrong with that request. Please try again.