New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

icalBuddy not working in Yosemite #6

Closed
AmaruCoder opened this Issue Oct 18, 2014 · 3 comments

Comments

Projects
None yet
3 participants
@AmaruCoder

AmaruCoder commented Oct 18, 2014

I upgraded OS X to Yosemite, and now I get the following error message when I try to run icalBuddy:

2014-10-18 12:03:05.666 icalBuddy[46273:103577] Error loading /System/Library/PrivateFrameworks/CalendarFoundation.framework/CalendarFoundation: dlopen(/System/Library/PrivateFrameworks/CalendarFoundation.framework/CalendarFoundation, 265): no suitable image found. Did find:
/System/Library/PrivateFrameworks/CalendarFoundation.framework/CalendarFoundation: mach-o, but wrong architecture

@ali-rantakari

This comment has been minimized.

Owner

ali-rantakari commented Nov 12, 2014

This is because your icalBuddy installation is an i386 binary, and in Yosemite CalendarFoundation seems to only exist for the x86_64 architecture.

You can fix this by reinstalling icalBuddy from Homebrew:

rm /usr/local/bin/icalBuddy
rm /usr/local/share/man/man1/icalBuddy*
brew install ical-buddy
@AmaruCoder

This comment has been minimized.

AmaruCoder commented Feb 24, 2015

Thank you. This solved my issue.

@arthurguillemot

This comment has been minimized.

arthurguillemot commented Oct 17, 2015

Hi !

Is there an other way to do it ? I don't want to uninstall macports...

Thanks !

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment