Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Use MySQL 5.5 for MySQL extension. #786

Merged
merged 1 commit into from Mar 20, 2018
Merged

Use MySQL 5.5 for MySQL extension. #786

merged 1 commit into from Mar 20, 2018

Conversation

@psychonic
Copy link
Member

@psychonic psychonic commented Mar 19, 2018

@peace-maker Your wildest dream come true.

@Bara
Copy link
Contributor

@Bara Bara commented Mar 20, 2018

With which version comes this?

@asherkin
Copy link
Member

@asherkin asherkin commented Mar 20, 2018

Uh, none, it hasn’t been merged yet.

@psychonic
Copy link
Member Author

@psychonic psychonic commented Mar 20, 2018

On our own buildslaves, we'll be using 5.5.54 on Windows, 5.5.58 on Linux, and 5.5.40 on Mac.

Intentionally not going higher, even in the 5.5 series, to not introduce extra dependencies.

@Bara
Copy link
Contributor

@Bara Bara commented Mar 20, 2018

Okay good to know, but i mean with which sourcemod version (1.10 or for 1.9 too?). 😖

@psychonic
Copy link
Member Author

@psychonic psychonic commented Mar 20, 2018

Undetermined as of yet.

@psychonic psychonic merged commit 4637cf9 into master Mar 20, 2018
2 checks passed
@Bara
Copy link
Contributor

@Bara Bara commented Mar 20, 2018

but isn't the version for linux 5.6?
https://github.com/alliedmodders/sourcemod/blob/33c74944ff112b92829cc9006e0231384e139b10/tools/checkout-deps.sh#L55
https://github.com/alliedmodders/sourcemod/blob/33c74944ff112b92829cc9006e0231384e139b10/tools/checkout-deps.sh#L66

@psychonic
Copy link
Member Author

@psychonic psychonic commented Mar 20, 2018

No. We don't use checkout-deps in the official builds. The MYSQL55 env var on the slave points to mysql-5.5.58-linux-glibc2.12-i686.

I didn't bother updating checkout-deps for it since it was already at a newer version than we build now (itself a newer one than we were building against before).

Doing self-compiles against 5.6 is fine. We're just keeping the lower one on official builds to not increase the GLIBC version requirement.

@Headline Headline deleted the mysql-5.5 branch Jul 31, 2018
Headline added a commit to sneak-it/sourcemod that referenced this issue Sep 22, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

3 participants