Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Dependency Issue with Debian Buster #1629

Open
Gill-Bates opened this issue Dec 9, 2019 · 2 comments
Open

Dependency Issue with Debian Buster #1629

Gill-Bates opened this issue Dec 9, 2019 · 2 comments

Comments

@Gill-Bates
Copy link

@Gill-Bates Gill-Bates commented Dec 9, 2019

On Debian Buster, libssl1.1 is installed

apt install libssl1.1 Reading package lists... Done Building dependency tree Reading state information... Done libssl1.1 is already the newest version (1.1.1d-0+deb10u2)

But GoAccess requieres an older version and terminates the installation

The following packages have unmet dependencies: goaccess : Depends: libssl1.0.2 (>= 1.0.2) but it is not installable E: Unable to correct problems, you have held broken packages.

Does anyone have any idea how I can persuade GoAccess 1.3 to accept the current version?

@szepeviktor

This comment has been minimized.

Copy link
Contributor

@szepeviktor szepeviktor commented Jan 10, 2020

Same as #1365

@szepeviktor

This comment has been minimized.

Copy link
Contributor

@szepeviktor szepeviktor commented Jan 10, 2020

Does anyone have any idea how I can persuade GoAccess 1.3 to accept the current version?

wget -nv -O /tmp/libssl1.0.2_amd64.deb \
    "http://security.debian.org/debian-security/pool/updates/main/o/openssl1.0/libssl1.0.2_1.0.2u-1~deb9u1_amd64.deb"
dpkg -i /tmp/libssl1.0.2_amd64.deb
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.