Can't get Rails to work from Git #3

Open
timClicks opened this Issue May 22, 2009 · 5 comments

Comments

Projects
None yet
6 participants

Hi there -

I get the following error, do you have any suggestions to configure the app once it's been cloned from the git?

$ rake db:migrate
(in /home/tim/Development/learning/railsform/complex-form-examples)
rake aborted!
no such file to load -- /home/tim/Development/learning/railsform/complex-form-examples/config/../vendor/rails/railties/lib/initializer
/home/tim/Development/learning/railsform/complex-form-examples/Rakefile:4
(See full trace by running task with --trace)

$ script/server
./script/../config/boot.rb:45:in require': no such file to load -- ./script/../config/../vendor/rails/railties/lib/initializer (LoadError) from ./script/../config/boot.rb:45:inload_initializer'
from ./script/../config/boot.rb:38:in run' from ./script/../config/boot.rb:11:inboot!'
from ./script/../config/boot.rb:109
from script/server:2:in `require'
from script/server:2

taktran commented Jun 8, 2009

I got it working by removing the vendor/rails folder (it's empty anyway), and adding a log folder.

(also had to comment out the RAILS_GEM_VERSION line in the environment.rb file so that it'd use my current 2.3.2 version of rails, but you may not need to do this)

Rails is included as a sub module. Run "git submodule init", "git submodule update"

plukevdh commented Dec 9, 2009

can you add vendor/rails to .gitignore and add an empty log dir to the project to solve this issue?

"git submodule init", "git submodule update"

This worked perfect for me. Thanks.

turadg commented Jan 26, 2011

Would be nice if that were in the README.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment