Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Can't get Rails to work from Git #3

Open
timClicks opened this Issue · 5 comments

6 participants

@timClicks

Hi there -

I get the following error, do you have any suggestions to configure the app once it's been cloned from the git?

$ rake db:migrate
(in /home/tim/Development/learning/railsform/complex-form-examples)
rake aborted!
no such file to load -- /home/tim/Development/learning/railsform/complex-form-examples/config/../vendor/rails/railties/lib/initializer
/home/tim/Development/learning/railsform/complex-form-examples/Rakefile:4
(See full trace by running task with --trace)

$ script/server
./script/../config/boot.rb:45:in require': no such file to load -- ./script/../config/../vendor/rails/railties/lib/initializer (LoadError)
from ./script/../config/boot.rb:45:in
load_initializer'
from ./script/../config/boot.rb:38:in run'
from ./script/../config/boot.rb:11:in
boot!'
from ./script/../config/boot.rb:109
from script/server:2:in `require'
from script/server:2

@taktran

I got it working by removing the vendor/rails folder (it's empty anyway), and adding a log folder.

(also had to comment out the RAILS_GEM_VERSION line in the environment.rb file so that it'd use my current 2.3.2 version of rails, but you may not need to do this)

@annaswims

Rails is included as a sub module. Run "git submodule init", "git submodule update"

@plukevdh

can you add vendor/rails to .gitignore and add an empty log dir to the project to solve this issue?

@pglombardo

"git submodule init", "git submodule update"

This worked perfect for me. Thanks.

@turadg

Would be nice if that were in the README.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.