Permalink
Browse files

Set the dependency for data_objects to be equal to the package version

* Standardized rubygems gem() method usage to make find/replace easier
  in the future
  • Loading branch information...
1 parent bbdd871 commit 0fa0d987bbf0d326d21b9bcc0a0b19d88dd5f57d Dan Kubb committed May 27, 2008
Showing with 4 additions and 4 deletions.
  1. +1 −1 Rakefile
  2. +2 −2 script/performance.rb
  3. +1 −1 script/profile.rb
View
@@ -119,7 +119,7 @@ gem_spec = Gem::Specification.new do |s|
s.require_path = "lib"
s.requirements << "none"
- s.add_dependency("data_objects", ">=0.9.0")
+ s.add_dependency("data_objects", "=#{s.version}")
s.add_dependency("english", ">=0.2.0")
s.add_dependency("rspec", ">=1.1.3")
s.add_dependency("addressable", ">=1.0.4")
View
@@ -5,10 +5,10 @@
require 'benchmark'
require 'rubygems'
-gem 'faker', '>= 0.3.1'
+gem 'faker', '>=0.3.1'
require 'faker'
-gem 'activerecord', '>= 2.0.2'
+gem 'activerecord', '>=2.0.2'
require 'active_record'
socket_file = Pathname.glob(%w[
View
@@ -4,7 +4,7 @@
require 'rubygems'
-gem 'ruby-prof', '>= 0.6.0'
+gem 'ruby-prof', '>=0.6.0'
require 'ruby-prof'
OUTPUT = DataMapper.root / 'profile_results.txt'

0 comments on commit 0fa0d98

Please sign in to comment.