Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Version bump to 1.0.0.rc1

  • Loading branch information...
commit 8bb04debb9ab4689e5abbf171fdfae291c1c16a9 1 parent e2d7805
@dkubb dkubb authored
Showing with 6 additions and 14 deletions.
  1. +1 −3 Gemfile
  2. +1 −1  VERSION
  3. +3 −9 dm-core.gemspec
  4. +1 −1  lib/dm-core/version.rb
View
4 Gemfile
@@ -71,7 +71,7 @@
source 'http://rubygems.org'
DATAMAPPER = 'git://github.com/datamapper'
-
+DM_VERSION = '~> 1.0.0.rc1'
group :runtime do # Runtime dependencies (as in the gemspec)
@@ -106,8 +106,6 @@ end
group :datamapper do # We need this because we want to pin these dependencies to their git master sources
- DM_VERSION = '~> 0.10.3'
-
gem 'dm-core', DM_VERSION, :path => File.dirname(__FILE__) # Make ourself available to the adapters
adapters = ENV['ADAPTER'] || ENV['ADAPTERS']
View
2  VERSION
@@ -1 +1 @@
-0.0.0.rc1
+1.0.0.rc1
View
12 dm-core.gemspec
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = %q{dm-core}
- s.version = "0.10.3"
+ s.version = "1.0.0.rc1"
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["Dan Kubb"]
- s.date = %q{2010-05-10}
+ s.date = %q{2010-05-19}
s.description = %q{Faster, Better, Simpler.}
s.email = %q{dan.kubb@gmail.com}
s.extra_rdoc_files = [
@@ -313,23 +313,17 @@ Gem::Specification.new do |s|
s.add_runtime_dependency(%q<extlib>, ["~> 0.9.14"])
s.add_runtime_dependency(%q<addressable>, ["~> 2.1"])
s.add_development_dependency(%q<rspec>, ["~> 1.3"])
- s.add_development_dependency(%q<yard>, ["~> 0.5"])
- s.add_development_dependency(%q<rcov>, ["~> 0.9.7"])
s.add_development_dependency(%q<jeweler>, ["~> 1.4"])
else
s.add_dependency(%q<extlib>, ["~> 0.9.14"])
s.add_dependency(%q<addressable>, ["~> 2.1"])
s.add_dependency(%q<rspec>, ["~> 1.3"])
- s.add_dependency(%q<yard>, ["~> 0.5"])
- s.add_dependency(%q<rcov>, ["~> 0.9.7"])
s.add_dependency(%q<jeweler>, ["~> 1.4"])
end
else
s.add_dependency(%q<extlib>, ["~> 0.9.14"])
s.add_dependency(%q<addressable>, ["~> 2.1"])
s.add_dependency(%q<rspec>, ["~> 1.3"])
- s.add_dependency(%q<yard>, ["~> 0.5"])
- s.add_dependency(%q<rcov>, ["~> 0.9.7"])
s.add_dependency(%q<jeweler>, ["~> 1.4"])
end
end
View
2  lib/dm-core/version.rb
@@ -1,3 +1,3 @@
module DataMapper
- VERSION = '0.10.3'.freeze
+ VERSION = '1.0.0.rc1'.freeze
end
Please sign in to comment.
Something went wrong with that request. Please try again.