New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Conflict problems when use 2.4.2 #1741

Open
prsolucoes opened this Issue Nov 23, 2017 · 4 comments

Comments

Projects
None yet
3 participants
@prsolucoes

prsolucoes commented Nov 23, 2017

Issue type:

[ ] Feature request
[X] Bug report
[ ] Documentation

Environment:

  • AdminLTE Version: 2.4.2
  • Operating System: osx
  • Browser (Version): latest

Description:

When i use in my composer version 2.3.11, it install without problems, but when i try use the latest version (2.4.2), i got conflict problems:


  Problem 1
    - bower-asset/bootstrap-timepicker v0.5.2 requires bower-asset/jquery >=2.0.0,<3.0.0 -> satisfiable by bower-asset/jquery[2.2.4, 2.2.3, 2.2.2, 2.2.1, 2.2.0, 2.1.4, 2.1.3, 2.1.2, 2.1.1, 2.1.1-RC2, 2.1.1-RC1, 2.1.1-beta1, 2.1.0, 2.1.0-RC1, 2.1.0-beta3, 2.1.0-beta2, 2.1.0-beta1, 2.0.3, 2.0.2, 2.0.1, 2.0.0, 2.0.0-beta3, 2.0.0-beta2, 2.0.0-beta1].
    - Can only install one of: bower-asset/jquery[2.2.4, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.2.3, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.2.2, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.2.1, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.2.0, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.1.4, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.1.3, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.1.2, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.1.1, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.1.1-RC2, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.1.1-RC1, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.1.1-beta1, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.1.0, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.1.0-RC1, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.1.0-beta3, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.1.0-beta2, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.1.0-beta1, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.0.3, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.0.2, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.0.1, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.0.0, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.0.0-beta3, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.0.0-beta2, 3.2.1].
    - Can only install one of: bower-asset/jquery[2.0.0-beta1, 3.2.1].
    - bower-asset/admin-lte v2.4.2 requires bower-asset/jquery >=3.2.1,<4.0.0 -> satisfiable by bower-asset/jquery[3.2.1].
    - bower-asset/admin-lte v2.4.2 requires bower-asset/bootstrap-timepicker >=0.5.2,<0.6.0 -> satisfiable by bower-asset/bootstrap-timepicker[v0.5.2].
    - Installation request for bower-asset/admin-lte 2.4.2 -> satisfiable by bower-asset/admin-lte[v2.4.2].

Can anyone help me?

file: composer.json

{
	"name": "yii2-app-advanced",
	"description": "Yii 2 Advanced App Template",
	"keywords": [
		"yii2",
		"framework",
		"base",
		"advanced"
	],
	"homepage": "http://www.yiiframework.com/",
	"type": "project",
	"license": "MIT",
	"support": {
		"source": "https://github.com/prsolucoes/yii2-app-advanced"
	},
	"minimum-stability": "stable",
	"require": {
		"php": ">=5.4.0",
		"yiisoft/yii2": "2.0.13.1",
		"yiisoft/yii2-bootstrap": "2.0.7",
		"yiisoft/yii2-swiftmailer": "2.1.0",
		"yiisoft/yii2-jui": "2.0.6",
		"bower-asset/admin-lte": "2.3.11",
		"bower-asset/font-awesome": "4.7.0",
		"bower-asset/html5shiv": "3.7.3",
		"bower-asset/jquery-slimscroll": "1.3.8",
		"bower-asset/js-cookie": "2.2.0",
		"kartik-v/yii2-grid": "3.1.7",
		"kartik-v/yii2-export": "1.2.8",
		"trntv/yii2-file-kit": "1.2.1",
		"intervention/image": "2.4.1",
		"vova07/yii2-imperavi-widget": "1.3.1",
		"kartik-v/yii2-widget-datepicker": "1.4.3",
		"kartik-v/yii2-datecontrol": "1.9.6",
		"drmonty/ekko-lightbox": "5.3.0"
	},
	"require-dev": {
		"yiisoft/yii2-debug": "2.0.12",
		"yiisoft/yii2-gii": "2.0.5",
		"yiisoft/yii2-faker": "2.0.3",
		"codeception/base": "2.3.6",
		"codeception/verify": "1.0.0"
	},
	"config": {
		"process-timeout": 1800,
		"fxp-asset": {
			"installer-paths": {
				"npm-asset-library": "vendor/npm",
				"bower-asset-library": "vendor/bower"
			}
		}
	},
	"repositories": [
		{
			"type": "composer",
			"url": "https://asset-packagist.org"
		}
	]
}
@enzothea

This comment has been minimized.

enzothea commented Jan 29, 2018

same problem

@almasaeed2010

This comment has been minimized.

Owner

almasaeed2010 commented Feb 4, 2018

Would adding this line in AdminLTE's composer.json require section fix the problem?

require: {
  "bower-asset/jquery": ">=1.9.* <4.0.0"
}

If so, I'll add and push a new version.

@prsolucoes

This comment has been minimized.

prsolucoes commented Feb 6, 2018

If i use your line in my composer.json, i got:

[UnexpectedValueException]                                                  
 Could not parse version constraint >=1.9.*: Invalid version string "1.9.*"  
@prsolucoes

This comment has been minimized.

prsolucoes commented Feb 6, 2018

In my composer.json im using:

{
	"name": "yii2-app-advanced",
	"description": "Yii 2 Advanced App Template",
	"keywords": [
		"yii2",
		"framework",
		"base",
		"advanced"
	],
	"homepage": "http://www.yiiframework.com/",
	"type": "project",
	"license": "MIT",
	"support": {
		"source": "https://github.com/prsolucoes/yii2-app-advanced"
	},
	"minimum-stability": "stable",
	"require": {
		"php": ">=5.4.0",
		"yiisoft/yii2": "2.0.13.1",
		"yiisoft/yii2-bootstrap": "2.0.7",
		"yiisoft/yii2-swiftmailer": "2.1.0",
		"yiisoft/yii2-jui": "2.0.7",
		"bower-asset/admin-lte": "2.4.3",
		"bower-asset/font-awesome": "4.7.0",
		"bower-asset/html5shiv": "3.7.3",
		"bower-asset/jquery-slimscroll": "1.3.8",
		"bower-asset/js-cookie": "2.2.0",
		"kartik-v/yii2-grid": "3.1.7",
		"kartik-v/yii2-export": "1.2.8",
		"trntv/yii2-file-kit": "1.3.0",
		"intervention/image": "2.4.1",
		"vova07/yii2-imperavi-widget": "2.0.2",
		"kartik-v/yii2-widget-datepicker": "1.4.3",
		"kartik-v/yii2-datecontrol": "1.9.6",
		"drmonty/ekko-lightbox": "5.3.0",
		"ausi/slug-generator": "1.0.0"
	},
	"require-dev": {
		"yiisoft/yii2-debug": "2.0.13",
		"yiisoft/yii2-gii": "2.0.6",
		"yiisoft/yii2-faker": "2.0.3",
		"codeception/base": "2.3.8",
		"codeception/verify": "1.0.0"
	},
	"config": {
		"process-timeout": 1800,
		"fxp-asset": {
			"installer-paths": {
				"npm-asset-library": "vendor/npm",
				"bower-asset-library": "vendor/bower"
			}
		}
	},
	"repositories": [
		{
			"type": "composer",
			"url": "https://asset-packagist.org"
		}
	]
}

But im getting:

  Problem 1
    - The requested package bower-asset/admin-lte 2.4.3 exists as bower-asset/admin-lte[v2.4.2, v2.4.1, v2.4.0, v2.4.0-RC1, v2.4.0-beta1, v2.4.0-alpha1, v2.3.11, v2.3.10, v2.3.9, v2.3.8, v2.3.7, v2.3.6, v2.3.5, v2.3.4, v2.3.3, v2.3.2, v2.3.1, v2.3.0, v2.2.1, v2.2.0, v2.1.2, 2.1.1, 2.1.0, v2.1.0-beta1, v2.1.0-alpha1, v2.0.5, v2.0.4, v2.0.3, v2.0.2, v2.0.1, v2.0.0, 1.3.1, 1.3.0, 1.2.1-patch1, v1.2.1, 1.2, 1.1, 1.0, 0.1, dev-issue-668, dev-master, dev-v3-dev] but these are rejected by your constraint.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment