Module name 'shCore' has not been loaded yet for context: _ #528

Closed
mindctrl opened this Issue Apr 29, 2012 · 2 comments

Projects

None yet

3 participants

@mindctrl

I'm seeing a conflict with Aloha in scribu's Front-end Editor plugin for WordPress and the SyntaxHighlighter Evolved plugin, when using Firefox.

The Firebug error console gives me the following error on the Front-end Editor aloha.js line 80:

Error: Module name 'shCore' has not been loaded yet for context: _
http://requirejs.org/docs/errors.html#notloaded
var e = new Error(msg + '\nhttp://requirejs.org/docs/errors.html#' + id);

aloha.js error

It prevents the SyntaxHighlighter from working too.
The SyntaxHighlighter error I'm getting is:
SyntaxHighlighter
Can't find brush for: php

SyntaxHighlighter error

My setup:
Front-end Editor version 2.2.1
WP version 3.3.2
SyntaxHighlighter Evolved version 3.1.3
Firefox 12 and 14 nightly (doesn't happen in latest Chrome or Safari)

I opened an issue on scribu's repo, and he confirmed it and said I should report it upstream to you guys.
scribu/wp-front-end-editor#71

@scribu
scribu commented Apr 29, 2012

For clarity, the library in question is https://github.com/alexgorbatchev/SyntaxHighlighter

Also, Aloha version is 0.20.6.

@scribu
scribu commented Apr 30, 2012

Actually, I can reproduce using Aloha 0.20.10 as well.

@evo42 evo42 closed this Sep 26, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment