Skip to content
This repository

guides gem broken? #741

Closed
wimleers opened this Issue October 02, 2012 · 6 comments

3 participants

Wim Leers Rene Kapusta Andreas Perhab
Wim Leers

After a lot of misery (holy shit, never before has gem been so slow!), I got the guides gem installed ($ sudo gem install guides --verbose --no-ri --no-rdoc). But now:

wim.leers at wimleers-acquia in ~/Work/Aloha-Editor/doc/guides on dev*
$ guides preview
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require': /Library/Ruby/Gems/1.8/gems/guides-0.7.2/lib/guides/indexer.rb:49: invalid regular expression; there's no previous pattern, to which '{' would define cardinality at 1: /{{(.*?)}}/ (SyntaxError)
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
    from /Library/Ruby/Gems/1.8/gems/guides-0.7.2/lib/guides/generator.rb:56
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
    from /Library/Ruby/Gems/1.8/gems/guides-0.7.2/lib/guides.rb:7
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
    from /Library/Ruby/Gems/1.8/gems/guides-0.7.2/bin/guides:3
    from /usr/bin/guides:19:in `load'
    from /usr/bin/guides:19

Any ideas? For now, I'm sticking to TextMate's Textile preview functionality.

This is on OS X 10.7.

Rene Kapusta
Collaborator

Aaaaah... don't talk about the guides gem -- I've had also huge troubles with this nice piece of software...

When I remember right I upgraded to ruby 1.9.x with homebrew

Wim Leers

Heh …

The world is standardizing on Markdown. Markdown would be better. But I guess it's a pain to convert :(

Wim Leers

Please see my comment in #742.

Andreas Perhab

I'm still getting this issue for the "barcamp" branch. what do i have to do? merge something?

Rene Kapusta
Collaborator
evo42 commented June 06, 2013

do you have problems running "gem install guides" or "guides preview"? it's more or less just necessary for writing new guides...

you can access the rendered guides online: http://aloha-editor.org/guides/

Andreas Perhab

i wanted to updated them and preview my changes before commiting, so i used guides preview and got the exact same message as @wimleers

Rene Kapusta evo42 closed this October 17, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.