Permalink
Browse files

update build instructions

  • Loading branch information...
1 parent 7f6a75e commit 4b1e24b15773f103bc37c595d6b28b49623dd1bf @alperakcan committed Dec 8, 2016
Showing with 7 additions and 5 deletions.
  1. +5 −3 README.md
  2. +2 −2 configure.ac
View
@@ -28,12 +28,14 @@ Build from source depends on:
* autoconf
* automake
* libtool
-* fuse-dev
-* e2fsprogs-dev
+* libfuse-dev
+* e2fsprogs
+* comerr-dev
+* e2fslibs-dev
```shell
$ apt-get install m4 autoconf automake libtool
-$ apt-get install libfuse-dev e2fslibs-dev
+$ apt-get install libfuse-dev e2fsprogs comerr-dev e2fslibs-dev
$ ./autogen.sh
$ ./configure
View
@@ -142,8 +142,8 @@ AC_CHECK_FUNCS([ \
# Checks for libraries
AC_SEARCH_LIBS([sem_post], [pthread], [], [AC_MSG_ERROR([Can't find pthreads, please install it])])
AC_SEARCH_LIBS([fuse_main], [osxfuse fuse], [], [AC_MSG_ERROR([Can't find libfuse, please install it])])
-AC_SEARCH_LIBS([com_err], [com_err], [], [AC_MSG_ERROR([Can't find e2progs, please install it])])
-AC_SEARCH_LIBS([ext2fs_open], [ext2fs], [], [AC_MSG_ERROR([Can't find e2progs, please install it])])
+AC_SEARCH_LIBS([com_err], [com_err], [], [AC_MSG_ERROR([Can't find comerr, please install it])])
+AC_SEARCH_LIBS([ext2fs_open], [ext2fs], [], [AC_MSG_ERROR([Can't find e2fslibs, please install it])])
AC_MSG_CHECKING([if FUSE on this system is too new for us])
AC_EGREP_CPP([fuse_version_yes], [

0 comments on commit 4b1e24b

Please sign in to comment.