Permalink
Browse files

Upgrade mocha and specify minitest dependency

  • Loading branch information...
1 parent e33283f commit 60f502dd8e7e39dddff320a781f0a091bc11b57d @msievers msievers committed Oct 24, 2013
Showing with 14 additions and 8 deletions.
  1. +2 −1 Gemfile
  2. +4 −2 Gemfile.lock
  3. +6 −3 iso-639.gemspec
  4. +2 −2 test/helper.rb
View
@@ -6,7 +6,8 @@ source "http://rubygems.org"
# Add dependencies to develop your gem here.
# Include everything needed to run rake, tests, features, etc.
group :development, :test do
- gem "mocha", ">= 0"
+ gem "minitest", "~> 4.7.5"
+ gem "mocha", "~> 0.14.0"
gem "rdoc", "~> 3.12"
gem "shoulda", ">= 0"
gem "rake"
View
@@ -7,7 +7,8 @@ GEM
i18n (0.6.1)
json (1.7.5)
metaclass (0.0.1)
- mocha (0.12.7)
+ minitest (4.7.5)
+ mocha (0.14.0)
metaclass (~> 0.0.1)
multi_json (1.3.6)
rake (0.9.2.2)
@@ -24,7 +25,8 @@ PLATFORMS
ruby
DEPENDENCIES
- mocha
+ minitest (~> 4.7.5)
+ mocha (~> 0.14.0)
rake
rdoc (~> 3.12)
shoulda
View
@@ -38,16 +38,19 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<mocha>, [">= 0"])
+ s.add_development_dependency(%q<minitest>, ["~> 4.7.5"])
+ s.add_development_dependency(%q<mocha>, ["~> 0.14.0"])
s.add_development_dependency(%q<rdoc>, ["~> 3.12"])
s.add_development_dependency(%q<shoulda>, [">= 0"])
else
- s.add_dependency(%q<mocha>, [">= 0"])
+ s.add_dependency(%q<minitest>, ["~> 4.7.5"])
+ s.add_dependency(%q<mocha>, ["~> 0.14.0"])
s.add_dependency(%q<rdoc>, ["~> 3.12"])
s.add_dependency(%q<shoulda>, [">= 0"])
end
else
- s.add_dependency(%q<mocha>, [">= 0"])
+ s.add_dependency(%q<minitest>, ["~> 4.7.5"])
+ s.add_dependency(%q<mocha>, ["~> 0.14.0"])
s.add_dependency(%q<rdoc>, ["~> 3.12"])
s.add_dependency(%q<shoulda>, [">= 0"])
end
View
@@ -9,11 +9,11 @@
end
require 'test/unit'
require 'shoulda'
-require 'mocha'
+require 'mocha/setup'
$LOAD_PATH.unshift(File.join(File.dirname(__FILE__), '..', 'lib'))
$LOAD_PATH.unshift(File.dirname(__FILE__))
require 'iso-639'
class Test::Unit::TestCase
-end
+end

0 comments on commit 60f502d

Please sign in to comment.