Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Updating Rakefile, test helper, gemspec; adding Gemfile.

  • Loading branch information...
commit 850439ce2b5c3ddb6622d868753e5b205092e04f 1 parent 43a9de8
@alphabetum authored
View
13 Gemfile
@@ -0,0 +1,13 @@
+source "http://rubygems.org"
+# Add dependencies required to use your gem here.
+# Example:
+# gem "activesupport", ">= 2.3.5"
+
+# Add dependencies to develop your gem here.
+# Include everything needed to run rake, tests, features, etc.
+group :development, :test do
+ gem "jeweler", "~> 1.8.4"
+ gem "mocha", ">= 0"
+ gem "rdoc", "~> 3.12"
+ gem "shoulda", ">= 0"
+end
View
36 Gemfile.lock
@@ -0,0 +1,36 @@
+GEM
+ remote: http://rubygems.org/
+ specs:
+ activesupport (3.2.8)
+ i18n (~> 0.6)
+ multi_json (~> 1.0)
+ git (1.2.5)
+ i18n (0.6.1)
+ jeweler (1.8.4)
+ bundler (~> 1.0)
+ git (>= 1.2.5)
+ rake
+ rdoc
+ json (1.7.5)
+ metaclass (0.0.1)
+ mocha (0.12.7)
+ metaclass (~> 0.0.1)
+ multi_json (1.3.6)
+ rake (0.9.2.2)
+ rdoc (3.12)
+ json (~> 1.4)
+ shoulda (3.3.2)
+ shoulda-context (~> 1.0.1)
+ shoulda-matchers (~> 1.4.1)
+ shoulda-context (1.0.1)
+ shoulda-matchers (1.4.1)
+ activesupport (>= 3.0.0)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ jeweler (~> 1.8.4)
+ mocha
+ rdoc (~> 3.12)
+ shoulda
View
59 Rakefile
@@ -1,21 +1,29 @@
+# encoding: utf-8
+
require 'rubygems'
+require 'bundler'
+begin
+ Bundler.setup(:default, :development)
+rescue Bundler::BundlerError => e
+ $stderr.puts e.message
+ $stderr.puts "Run `bundle install` to install missing gems"
+ exit e.status_code
+end
require 'rake'
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gem|
- gem.name = "iso-639"
- gem.summary = %Q{ISO 639-1 and ISO 639-2 language code entries and convenience methods}
- gem.description = %Q{ISO 639-1 and ISO 639-2 language code entries and convenience methods}
- gem.email = "hi@williammelody.com"
- gem.homepage = "http://github.com/alphabetum/iso-639"
- gem.authors = ["William Melody"]
- gem.add_development_dependency "thoughtbot-shoulda"
- # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
- end
-rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: sudo gem install jeweler"
+require 'jeweler'
+Jeweler::Tasks.new do |gem|
+ # gem is a Gem::Specification... see http://docs.rubygems.org/read/chapter/20 for more options
+ gem.name = "iso-639"
+ gem.homepage = "http://github.com/alphabetum/pandoc-ruby"
+ gem.license = "MIT"
+ gem.summary = %Q{ISO 639-1 and ISO 639-2 language code entries and convenience methods}
+ gem.description = %Q{ISO 639-1 and ISO 639-2 language code entries and convenience methods}
+ gem.email = "hi@williammelody.com"
+ gem.authors = ["William Melody"]
+ # dependencies defined in Gemfile
end
+Jeweler::RubygemsDotOrgTasks.new
require 'rake/testtask'
Rake::TestTask.new(:test) do |test|
@@ -24,30 +32,11 @@ Rake::TestTask.new(:test) do |test|
test.verbose = true
end
-begin
- require 'rcov/rcovtask'
- Rcov::RcovTask.new do |test|
- test.libs << 'test'
- test.pattern = 'test/**/test_*.rb'
- test.verbose = true
- end
-rescue LoadError
- task :rcov do
- abort "RCov is not available. In order to run rcov, you must: sudo gem install spicycode-rcov"
- end
-end
-
-task :test => :check_dependencies
-
task :default => :test
-require 'rake/rdoctask'
+require 'rdoc/task'
Rake::RDocTask.new do |rdoc|
- if File.exist?('VERSION')
- version = File.read('VERSION')
- else
- version = ""
- end
+ version = File.exist?('VERSION') ? File.read('VERSION') : ""
rdoc.rdoc_dir = 'rdoc'
rdoc.title = "ISO-639 #{version}"
View
61 iso-639.gemspec
@@ -1,54 +1,59 @@
# Generated by jeweler
# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
+# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
- s.name = %q{iso-639}
+ s.name = "iso-639"
s.version = "0.0.3"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["William Melody"]
- s.date = %q{2010-03-29}
- s.description = %q{ISO 639-1 and ISO 639-2 language code entries and convenience methods}
- s.email = %q{hi@williammelody.com}
+ s.date = "2012-11-01"
+ s.description = "ISO 639-1 and ISO 639-2 language code entries and convenience methods"
+ s.email = "hi@williammelody.com"
s.extra_rdoc_files = [
"LICENSE",
- "README.md"
+ "README.markdown"
]
s.files = [
".document",
- ".gitignore",
- "LICENSE",
- "README.md",
- "Rakefile",
- "VERSION",
- "iso-639.gemspec",
- "lib/iso-639.rb",
- "test/test_ISO_639.rb",
- "test/test_helper.rb"
+ "Gemfile",
+ "Gemfile.lock",
+ "LICENSE",
+ "README.markdown",
+ "Rakefile",
+ "VERSION",
+ "iso-639.gemspec",
+ "lib/iso-639.rb",
+ "test/helper.rb",
+ "test/test_ISO_639.rb"
]
- s.homepage = %q{http://github.com/alphabetum/iso-639}
- s.rdoc_options = ["--charset=UTF-8"]
+ s.homepage = "http://github.com/alphabetum/pandoc-ruby"
+ s.licenses = ["MIT"]
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.6}
- s.summary = %q{ISO 639-1 and ISO 639-2 language code entries and convenience methods}
- s.test_files = [
- "test/test_helper.rb",
- "test/test_ISO_639.rb"
- ]
+ s.rubygems_version = "1.8.24"
+ s.summary = "ISO 639-1 and ISO 639-2 language code entries and convenience methods"
if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
- if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<thoughtbot-shoulda>, [">= 0"])
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_development_dependency(%q<jeweler>, ["~> 1.8.4"])
+ s.add_development_dependency(%q<mocha>, [">= 0"])
+ s.add_development_dependency(%q<rdoc>, ["~> 3.12"])
+ s.add_development_dependency(%q<shoulda>, [">= 0"])
else
- s.add_dependency(%q<thoughtbot-shoulda>, [">= 0"])
+ s.add_dependency(%q<jeweler>, ["~> 1.8.4"])
+ s.add_dependency(%q<mocha>, [">= 0"])
+ s.add_dependency(%q<rdoc>, ["~> 3.12"])
+ s.add_dependency(%q<shoulda>, [">= 0"])
end
else
- s.add_dependency(%q<thoughtbot-shoulda>, [">= 0"])
+ s.add_dependency(%q<jeweler>, ["~> 1.8.4"])
+ s.add_dependency(%q<mocha>, [">= 0"])
+ s.add_dependency(%q<rdoc>, ["~> 3.12"])
+ s.add_dependency(%q<shoulda>, [">= 0"])
end
end
View
19 test/helper.rb
@@ -0,0 +1,19 @@
+require 'rubygems'
+require 'bundler'
+begin
+ Bundler.setup(:default, :development)
+rescue Bundler::BundlerError => e
+ $stderr.puts e.message
+ $stderr.puts "Run `bundle install` to install missing gems"
+ exit e.status_code
+end
+require 'test/unit'
+require 'shoulda'
+require 'mocha'
+
+$LOAD_PATH.unshift(File.join(File.dirname(__FILE__), '..', 'lib'))
+$LOAD_PATH.unshift(File.dirname(__FILE__))
+require 'iso-639'
+
+class Test::Unit::TestCase
+end
View
2  test/test_ISO_639.rb
@@ -1,4 +1,4 @@
-require 'test_helper'
+require 'helper'
class TestISO639 < Test::Unit::TestCase
View
10 test/test_helper.rb
@@ -1,10 +0,0 @@
-require 'rubygems'
-require 'test/unit'
-require 'shoulda'
-
-$LOAD_PATH.unshift(File.join(File.dirname(__FILE__), '..', 'lib'))
-$LOAD_PATH.unshift(File.dirname(__FILE__))
-require 'iso-639'
-
-class Test::Unit::TestCase
-end
Please sign in to comment.
Something went wrong with that request. Please try again.