Skip to content
This repository
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 46 lines (38 sloc) 1.462 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45
# -*- encoding: utf-8 -*-

lib = File.expand_path('../lib/', __FILE__)
$:.unshift lib unless $:.include?(lib)

require 'gds-sso/version'

Gem::Specification.new do |s|
  s.name = "gds-sso"
  s.version = GDS::SSO::VERSION
  s.platform = Gem::Platform::RUBY
  s.authors = ["Matt Patterson", "James Stewart"]
  s.email = ["matt@constituentparts.com", "james.stewart@digital.cabinet-office.gov.uk"]
  s.homepage = "https://github.com/alphagov/gds-sso"
  s.summary = %q{Client for GDS' OAuth 2-based SSO}
  s.description = %q{Client for GDS' OAuth 2-based SSO}

  s.rubyforge_project = "gds-sso"

  s.files = Dir[
    'app/**/*',
    'config/**/*',
    'lib/**/*',
    'README.md',
    'Gemfile',
    'Rakefile'
  ]
  s.test_files = Dir['test/**/*', 'spec/**/*']
  s.executables = []
  s.require_paths = ["lib"]

  s.add_dependency 'rails', '>= 3.0.0'
  s.add_dependency 'warden', '~> 1.2'
  s.add_dependency 'omniauth-gds', '0.0.3'
  s.add_dependency 'rack-accept', '~> 0.4.4'

  s.add_development_dependency 'rake', '~> 0.9.2'
  s.add_development_dependency 'mocha', '~> 0.9.0'
  s.add_development_dependency 'capybara', '~> 1.1.2'
  s.add_development_dependency 'rspec-rails', '~> 2.9.0'
  s.add_development_dependency 'capybara-mechanize', '~> 0.3.0'
  s.add_development_dependency 'combustion', '~> 0.3.2'
  s.add_development_dependency 'gem_publisher', '~> 1.0.0'
  s.add_development_dependency 'thor', '0.14.6'
end
Something went wrong with that request. Please try again.