Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix wraith when running against prod/staging from within VM #262

Merged
merged 1 commit into from Feb 28, 2017
Merged

Conversation

@fofr
Copy link
Contributor

@fofr fofr commented Feb 28, 2017

I'm not sure why this works.

We were seeing errors when trying to run the wraith tests from the VM:

Error with page https://www.gov.uk/government/case-studies/doing-business-in-spain.es

Add phantomjs option:

phantomjs_options: --ignore-ssl-errors=true --ssl-protocol=tlsv1
  • Use TLS v1 when requesting https://www.gov.uk/… from within the VM (all other versions reported errors)
  • Ignore SSL errors when accessing staging (production works fine with just TLS, but staging would fail)

PhantomJS depends on the system OpenSSL library.
http://phantomjs.org/api/command-line.html
Default is SSLv3

* Use TLS v1 when requesting https://www.gov.uk/… from within the VM
* Ignore SSL errors when accessing staging
* Stops "Error with page" problems

PhantomJS depends on the system OpenSSL library.
http://phantomjs.org/api/command-line.html
Default is SSLv3
@boffbowsh boffbowsh temporarily deployed to government-frontend-pr-262 Feb 28, 2017 Inactive
@fofr fofr merged commit 3e50306 into master Feb 28, 2017
2 checks passed
2 checks passed
continuous-integration/jenkins/branch This commit looks good
Details
security/snyk No new vulnerabilities
Details
@fofr fofr deleted the wraith-settings branch Feb 28, 2017
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

3 participants
You can’t perform that action at this time.