Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Only run CI build on instances with Mongodb 2.4 #976

Merged
merged 1 commit into from Apr 20, 2017
Commits on Apr 20, 2017
  1. Only run CI build on instances with Mongodb 2.4

    chrislo committed Apr 20, 2017
    This commit ensures that the build runs on nodes with Mongodb 2.4
    installed which should fix #898.
    
    Some of the CI 'agent' nodes on the Jenkins server run a more recent
    version of mongodb. By experimenting with rebuilding on Jenkins we've
    noticed that when this application's build runs on `ci-agent-4`, which
    is configured[1] to run mongodb 3.2 it fails[2], when it runs on
    `ci-agent-1` through `ci-agent-3` it seems to pass.
    
    Fixes: #898
    
    [1] https://github.com/alphagov/govuk-puppet/blob/master/hieradata/common.yaml#L639-L654
    [2] #898 (comment)
You can’t perform that action at this time.