Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

community/ocaml: update pkgrel for binutils update #12008

Closed
wants to merge 1 commit into from

Conversation

@XVilka
Copy link

XVilka commented Oct 28, 2019

The package requires rebuilding to match the upgrade of binutils

Fixing this bug: https://gitlab.alpinelinux.org/alpine/aports/issues/10888:

ERROR: unsatisfiable constraints:
  so:libbfd-2.32.so (missing):
    required by: ocaml-4.08.1-r0[so:libbfd-2.32.so]
@Cogitri

This comment has been minimized.

Copy link
Contributor

Cogitri commented Oct 28, 2019

It already correctly finds libbfd as dep, you just need to rebuild ocaml (and you rebuilding the package is what actually fixed it, not adding the binutils-dev dependency)

@XVilka

This comment has been minimized.

Copy link
Author

XVilka commented Oct 29, 2019

It uses binutils-dev as a built time dependency, not a runtime, but seems it requires it at runtime stage too. So my change should be fine. Also, why upgrade of binutils didn't trigger rebuild of ocaml package? I think it's because of the missing runtime dependency.

@XVilka XVilka force-pushed the XVilka:patch-1 branch from 14548f0 to 0ebdbb4 Oct 29, 2019
@Cogitri

This comment has been minimized.

Copy link
Contributor

Cogitri commented Oct 29, 2019

No, it's simply because someone forgot to bump the pkgrel :)

@XVilka

This comment has been minimized.

Copy link
Author

XVilka commented Oct 29, 2019

Ok, what should be done then to fix the existing 4.08.1 release? Or to merge the 4.09.0? Because I see no error with 4.09.0 and it is not merged yet.

@XVilka XVilka force-pushed the XVilka:patch-1 branch from 0ebdbb4 to 3922838 Oct 31, 2019
@XVilka XVilka changed the title community/ocaml: runtime dependency from libbfd.so community/ocaml: update pkgrel for binutils update Oct 31, 2019
@russkel

This comment has been minimized.

Copy link
Contributor

russkel commented Nov 1, 2019

No point bumping when there is a new version available. Something like this is preferable: #11591

@XVilka XVilka closed this Nov 1, 2019
Triage automation moved this from To Do to Done Nov 1, 2019
@XVilka XVilka deleted the XVilka:patch-1 branch Nov 1, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
3 participants
You can’t perform that action at this time.