Permalink
Browse files

Removed Jeweler, use Bundler

  • Loading branch information...
1 parent 242848c commit a3293a51f894100837912ec66ffa4b150dda1e13 @alsemyonov committed May 11, 2011
Showing with 34 additions and 131 deletions.
  1. +3 −0 Gemfile
  2. +6 −28 Rakefile
  3. +22 −103 espresso.gemspec
  4. +3 −0 lib/espresso/version.rb
View
@@ -0,0 +1,3 @@
+source "http://rubygems.org"
+
+gemspec
View
@@ -1,27 +1,5 @@
-require 'rubygems'
-require 'rake'
-
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gem|
- gem.name = 'espresso'
- gem.summary = %Q{Rails extender to simplify rails development}
- gem.description = %Q{Useful templates for controller and model functions}
- gem.email = 'rotuka@tokak.ru'
- gem.homepage = 'http://github.com/krasivotokak/espresso'
- gem.authors = ['Alexander Semyonov']
- gem.add_dependency('activesupport', '~> 2.3.5')
- gem.add_dependency('activerecord', '~> 2.3.5')
- gem.add_dependency('actionpack', '~> 2.3.5')
- gem.add_dependency('inherited_resources', '~> 1.0.5')
- gem.add_development_dependency('shoulda')
- gem.add_development_dependency('redgreen')
- # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
- end
- Jeweler::GemcutterTasks.new
-rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: sudo gem install jeweler"
-end
+require 'bundler'
+Bundler::GemHelper.install_tasks
require 'rake/testtask'
Rake::TestTask.new(:test) do |test|
@@ -72,7 +50,8 @@ task :default => :test
begin
require 'yard'
- YARD::Rake::YardocTask.new do |yard|
+ desc 'Generate documentation'
+ YARD::Rake::YardocTask.new(:doc) do |yard|
yard.options << '--no-private'
end
rescue LoadError
@@ -81,8 +60,7 @@ rescue LoadError
end
end
-desc 'Generate documentation'
task :doc => :yard
-desc "Bump patch version and release to github and gemcutter"
-task :bump => %w(version:bump:patch release gemcutter:release install)
+desc "Release to github and rubygems, install"
+task :bump => %w(release install)
View
@@ -1,110 +1,29 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
# -*- encoding: utf-8 -*-
+$:.push File.expand_path('../lib', __FILE__)
+require 'espresso/version'
Gem::Specification.new do |s|
- s.name = %q{espresso}
- s.version = "0.2.1"
-
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Alexander Semyonov"]
- s.date = %q{2010-03-29}
+ s.name = %q{espresso}
+ s.version = Espresso::VERSION
+ s.platform = Gem::Platform::RUBY
+ s.authors = ['Alexander Semyonov']
+ s.email = ['al@semyonov.us']
+ s.homepage = 'http://github.com/alsemyonov/espresso'
+ s.summary = %q{Rails extender to simplify rails development}
s.description = %q{Useful templates for controller and model functions}
- s.email = %q{rotuka@tokak.ru}
- s.extra_rdoc_files = [
- "LICENSE",
- "README.rdoc"
- ]
- s.files = [
- ".gitignore",
- "LICENSE",
- "README.rdoc",
- "Rakefile",
- "VERSION",
- "espresso.gemspec",
- "init.rb",
- "lib/espresso.rb",
- "lib/espresso/collection.rb",
- "lib/espresso/collection/searchlogic.rb",
- "lib/espresso/collection/will_paginate.rb",
- "lib/espresso/concern.rb",
- "lib/espresso/controller.rb",
- "lib/espresso/controller/inherited_resources.rb",
- "lib/espresso/deprecated.rb",
- "lib/espresso/deprecated/resources.rb",
- "lib/espresso/extensions/action_controller.rb",
- "lib/espresso/extensions/action_view.rb",
- "lib/espresso/extensions/active_record.rb",
- "lib/espresso/extensions/all.rb",
- "lib/espresso/extensions/haml.rb",
- "lib/espresso/extensions/has_scope.rb",
- "lib/espresso/extensions/inherited_resources.rb",
- "lib/espresso/extensions/searchlogic.rb",
- "lib/espresso/extensions/will_paginate.rb",
- "lib/espresso/model.rb",
- "lib/espresso/model/inherited_resources.rb",
- "lib/espresso/view.rb",
- "lib/espresso/view/form_builder.rb",
- "lib/espresso/view/has_scope.rb",
- "lib/espresso/view/inherited_resources.rb",
- "lib/espresso/view/searchlogic.rb",
- "lib/espresso/view/will_paginate.rb",
- "test/espresso_collection_test.rb",
- "test/espresso_controller_test.rb",
- "test/espresso_extensions_haml_test.rb",
- "test/espresso_model_test.rb",
- "test/espresso_test.rb",
- "test/espresso_view_has_scope_test.rb",
- "test/espresso_view_test.rb",
- "test/espresso_view_will_paginate_test.rb",
- "test/example_model.rb",
- "test/test_helper.rb"
- ]
- s.homepage = %q{http://github.com/krasivotokak/espresso}
- s.rdoc_options = ["--charset=UTF-8"]
- s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.6}
- s.summary = %q{Rails extender to simplify rails development}
- s.test_files = [
- "test/espresso_extensions_haml_test.rb",
- "test/example_model.rb",
- "test/espresso_collection_test.rb",
- "test/espresso_model_test.rb",
- "test/espresso_view_test.rb",
- "test/espresso_test.rb",
- "test/test_helper.rb",
- "test/espresso_controller_test.rb",
- "test/espresso_view_has_scope_test.rb",
- "test/espresso_view_will_paginate_test.rb"
- ]
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 3
+ s.rubyforge_project = 'espresso'
- if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activesupport>, ["~> 2.3.5"])
- s.add_runtime_dependency(%q<activerecord>, ["~> 2.3.5"])
- s.add_runtime_dependency(%q<actionpack>, ["~> 2.3.5"])
- s.add_runtime_dependency(%q<inherited_resources>, ["~> 1.0.5"])
- s.add_development_dependency(%q<shoulda>, [">= 0"])
- s.add_development_dependency(%q<redgreen>, [">= 0"])
- else
- s.add_dependency(%q<activesupport>, ["~> 2.3.5"])
- s.add_dependency(%q<activerecord>, ["~> 2.3.5"])
- s.add_dependency(%q<actionpack>, ["~> 2.3.5"])
- s.add_dependency(%q<inherited_resources>, ["~> 1.0.5"])
- s.add_dependency(%q<shoulda>, [">= 0"])
- s.add_dependency(%q<redgreen>, [">= 0"])
- end
- else
- s.add_dependency(%q<activesupport>, ["~> 2.3.5"])
- s.add_dependency(%q<activerecord>, ["~> 2.3.5"])
- s.add_dependency(%q<actionpack>, ["~> 2.3.5"])
- s.add_dependency(%q<inherited_resources>, ["~> 1.0.5"])
- s.add_dependency(%q<shoulda>, [">= 0"])
- s.add_dependency(%q<redgreen>, [">= 0"])
- end
-end
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.require_paths = ['lib']
+ s.add_runtime_dependency('activesupport', '~> 3.0.7')
+ s.add_runtime_dependency('activerecord', '~> 3.0.7')
+ s.add_runtime_dependency('actionpack', '~> 3.0.7')
+ s.add_runtime_dependency('inherited_resources', '~> 1.2.2')
+
+ s.add_development_dependency('shoulda', '>= 0')
+ s.add_development_dependency('redgreen', '>= 0')
+end
View
@@ -0,0 +1,3 @@
+module Espresso
+ VERSION = '0.2.1'
+end

0 comments on commit a3293a5

Please sign in to comment.