Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Not all packages are present in the extra-alucryd repository #88

Closed
ilya-fedin opened this issue Oct 27, 2018 · 10 comments

Comments

Projects
None yet
5 participants
@ilya-fedin
Copy link

commented Oct 27, 2018

 ilya@arch  ~  LANG=C sudo pacman -S pantheon
:: There are 19 members in group pantheon:
:: Repository community
   1) elementary-icon-theme  2) granite  3) pantheon-files  4) pantheon-music
   5) pantheon-terminal  6) pantheon-videos
:: Repository extra-alucryd
   7) capnet-assist  8) cerbere  9) contractor  10) elementary-wallpapers
   11) gtk-theme-elementary  12) lightdm-pantheon-greeter  13) pantheon-applications-menu
   14) pantheon-calendar  15) switchboard  16) switchboard-plug-printers
   17) switchboard-plug-user-accounts  18) wingpanel  19) wingpanel-indicator-session

Enter a selection (default=all): 
resolving dependencies...
warning: cannot resolve "libgala.so=0-64", a dependency of "wingpanel"
warning: cannot resolve "libwingpanel-2.0.so=0-64", a dependency of "lightdm-pantheon-greeter"
warning: cannot resolve "libgala.so=0-64", a dependency of "wingpanel"
warning: cannot resolve "libwingpanel-2.0.so=0-64", a dependency of "pantheon-applications-menu"
warning: cannot resolve "libgala.so=0-64", a dependency of "wingpanel"
warning: cannot resolve "libgala.so=0-64", a dependency of "wingpanel"
warning: cannot resolve "libwingpanel-2.0.so=0-64", a dependency of "wingpanel-indicator-session"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      lightdm-pantheon-greeter  pantheon-applications-menu  wingpanel
      wingpanel-indicator-session

:: Do you want to skip the above packages for this upgrade? [y/N] 
@thinkiny

This comment has been minimized.

Copy link

commented Oct 28, 2018

+1

@alucryd

This comment has been minimized.

Copy link
Owner

commented Oct 29, 2018

Feel free to patch gala to work with the latest GNOME, then all packages will be in there ;)

@adam900710

This comment has been minimized.

Copy link

commented Oct 29, 2018

BTW, where is pantheon-session package? Is it merged with some other package?

@ilya-fedin

This comment has been minimized.

Copy link
Author

commented Oct 29, 2018

Feel free to patch gala to work with the latest GNOME, then all packages will be in there ;)

Why not provide the old GNOME in the repository?

@ilya-fedin

This comment has been minimized.

Copy link
Author

commented Oct 29, 2018

@alucryd I made a package with mutter 3.28, installed it and built gala-git, it works!
mutter328.tar.gz

@alucryd

This comment has been minimized.

Copy link
Owner

commented Oct 29, 2018

Thanks, but Arch Linux is about encouraging upstream to support the bleeding edge, not be content with old deprecated versions. I'm sure upstream will work on that soon now that Juno has been released.

@ilya-fedin

This comment has been minimized.

Copy link
Author

commented Oct 31, 2018

IMHO, functionality is more important.

@alucryd

This comment has been minimized.

Copy link
Owner

commented Oct 31, 2018

If I had already pushed gala in the official redositories, I would 100% agree. I would even have learned vala, fixed this myself, and made a pull request.

However upstream still hasn't deemed gala stable enough to make a release, and because of that I can't push half of the pantheon packages in [community], and frankly I doubt I ever will be able to.

I initially planned to bring the whole pantheon in [community] when I first applied to be a TU, now we're several years later, and we still don't have a gala release.

I and others have tried to contact upstream about this lack of release, among other things but to no avail. I guess this is my way of protesting. By not having a functional gala, I hope that arch users will take some of the pressure upstream and have them finally come forward.

@Phraqzy

This comment has been minimized.

Copy link

commented Dec 17, 2018

Even compiling gala, granite and wingpanel from source, it persists with the same error

@alucryd

This comment has been minimized.

Copy link
Owner

commented Jan 6, 2019

For better or worse, I made a package for libmutter2...

@alucryd alucryd closed this Jan 6, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.