Permalink
Browse files

test against different rails versions

  • Loading branch information...
1 parent 25705f2 commit f302ee0faafec60dc5d2f0d6c7ddbd61c30f7c9e @nashby nashby committed Feb 26, 2012
Showing with 28 additions and 11 deletions.
  1. +6 −2 .travis.yml
  2. +6 −2 Gemfile
  3. +0 −7 active_decorator.gemspec
  4. +8 −0 gemfiles/Gemfile-rails.3.0.x
  5. +8 −0 gemfiles/Gemfile-rails.3.1.x
View
@@ -1,6 +1,10 @@
+language: ruby
+script: bundle exec rake spec
rvm:
- 1.8.7
- 1.9.3
- ruby-head
-
-script: bundle exec rake spec
+gemfile:
+ - gemfiles/Gemfile-rails.3.0.x
+ - gemfiles/Gemfile-rails.3.1.x
+ - Gemfile
View
@@ -1,4 +1,8 @@
-source "http://rubygems.org"
+source :rubygems
-# Specify your gem's dependencies in active_decorator.gemspec
gemspec
+
+gem 'rails', '~> 3.2.0'
+gem 'rspec-rails'
+gem 'capybara'
+gem 'sqlite3'
View
@@ -17,11 +17,4 @@ Gem::Specification.new do |s|
s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
-
- # specify any dependencies here; for example:
- s.add_development_dependency 'rails'
- s.add_development_dependency 'rspec-rails'
- s.add_development_dependency 'capybara'
- s.add_development_dependency 'sqlite3'
- # s.add_runtime_dependency "rest-client"
end
@@ -0,0 +1,8 @@
+source :rubygems
+
+gem 'active_decorator', :path => '..'
+
+gem 'rails', '~> 3.0.0'
+gem 'rspec-rails'
+gem 'capybara'
+gem 'sqlite3'
@@ -0,0 +1,8 @@
+source :rubygems
+
+gem 'active_decorator', :path => '..'
+
+gem 'rails', '~> 3.1.0'
+gem 'rspec-rails'
+gem 'capybara'
+gem 'sqlite3'

0 comments on commit f302ee0

Please sign in to comment.