Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Commits on May 24, 2015
  1. @antstorm
Commits on Apr 10, 2015
  1. @zzak

    Mongoid 4.0.0 was released

    zzak authored
Commits on Dec 31, 2014
  1. @yuki24
  2. @yuki24
Commits on Dec 21, 2014
Commits on Dec 20, 2014
  1. Test against AR 4.2

    authored
Commits on Dec 16, 2014
  1. @yuki24
Commits on Dec 15, 2014
  1. @yuki24

    Test against Rails 4.2 RC3

    yuki24 authored
Commits on Nov 30, 2014
  1. @yuki24

    Test against Rails 4.2.rc1

    yuki24 authored
  2. @yuki24

    Remove support for mongoid 2.4

    yuki24 authored
    Because it's over 2-years old while 3.0/3.1 are less than that.
  3. @yuki24

    Revert "Drop support for Sinatra 1.3, only support Sinatra 1.4.x"

    yuki24 authored
    This reverts commit 08013cb. It's too
    early to drop it.
    
    Conflicts:
    	Rakefile
  4. @yuki24

    Revert "Remove support for mongoid 2.4 and 3.x"

    yuki24 authored
    This reverts commit 1d45e8e. It's too
    early to drop them.
Commits on Nov 23, 2014
  1. @zzak @yuki24

    Drop support for Sinatra 1.3, only support Sinatra 1.4.x

    zzak authored yuki24 committed
  2. @zzak @yuki24

    Remove support for mongoid 2.4 and 3.x

    zzak authored yuki24 committed
    Conflicts:
    	.travis.yml
  3. @zzak @yuki24

    Drop support for MongoMapper.

    zzak authored yuki24 committed
    This extension will be unsupported in Kaminari 1.x
    
    If you'd like to support it, please let us know by opening a ticket on
    https://github.com/amatsuda/kaminari/issues/new
    
    Conflicts:
    	.travis.yml
    	README.rdoc
    	spec/fake_app/mongo_mapper/config.rb
Commits on Nov 22, 2014
  1. @yuki24

    Drop ActiveRecord 3.0/3.1 support

    yuki24 authored
    But 0.16.x will still have support for them.
  2. @yuki24

    Drop DataMapper support

    yuki24 authored
    it looks like DataMapper 1.2 is no longer maintained:
    
      * https://groups.google.com/forum/#!topic/datamapper/iTqd6IGxXpA
      * https://groups.google.com/forum/#!msg/datamapper/UCHC5TF6I0M/HamsbyNxuVAJ
    
    0.16.x will still have support for it, but not in 1.0.0.
  3. @yuki24

    DM 12 still need Rails 3.2...

    yuki24 authored
Commits on Aug 26, 2014
  1. @zzak

    Add 4.2.0.beta1 to tested Rails versions [ci skip]

    zzak authored
    Skip tests for now, we can run them on next change.
Commits on Jun 3, 2014
Commits on May 29, 2014
  1. @yuki24

    Tweak gemfiles and tavis.yml

    yuki24 authored
Commits on May 22, 2014
  1. @yuki24
Commits on May 15, 2014
  1. @yuki24
  2. @yuki24
Commits on May 9, 2014
Commits on May 8, 2014
  1. @yuki24
  2. @yuki24
Commits on Apr 20, 2014
  1. @yuki24

    Remove :rbx in favor of 55d316f

    yuki24 authored
  2. @yuki24
  3. @yuki24

    Update gemfile for ActiveRecord ~> 4.1.0

    yuki24 authored
    It's already released.
Commits on Apr 10, 2014
  1. @yuki24
Commits on Mar 9, 2014
  1. @yuki24

    Do not include railties and rspec-rails gem [ci skip]

    yuki24 authored
    They are unneeded if Sinatra is used.
Something went wrong with that request. Please try again.