Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Commits on Dec 2, 2014
  1. @cesarandreu
Commits on Nov 30, 2014
  1. @yuki24
  2. @yuki24

    Test against Rails 4.2.rc1

    yuki24 authored
  3. @yuki24

    Remove support for mongoid 2.4

    yuki24 authored
    Because it's over 2-years old while 3.0/3.1 are less than that.
  4. @yuki24

    Allow jruby to fail on travis

    yuki24 authored
  5. @yuki24

    Revert "Drop support for Sinatra 1.3, only support Sinatra 1.4.x"

    yuki24 authored
    This reverts commit 08013cb. It's too
    early to drop it.
    
    Conflicts:
    	Rakefile
  6. @yuki24

    Revert "Remove support for mongoid 2.4 and 3.x"

    yuki24 authored
    This reverts commit 1d45e8e. It's too
    early to drop them.
Commits on Nov 23, 2014
  1. @yuki24

    Test against JRuby 9000

    yuki24 authored
  2. @yuki24
  3. @yuki24

    Do not allow AR edge to fail any more

    yuki24 authored
    It's stable enough now.
  4. @yuki24

    Remove old rake tasks

    yuki24 authored
  5. @zzak @yuki24

    Drop support for Sinatra 1.3, only support Sinatra 1.4.x

    zzak authored yuki24 committed
  6. @zzak @yuki24

    Remove support for mongoid 2.4 and 3.x

    zzak authored yuki24 committed
    Conflicts:
    	.travis.yml
  7. @zzak @yuki24

    Drop support for MongoMapper.

    zzak authored yuki24 committed
    This extension will be unsupported in Kaminari 1.x
    
    If you'd like to support it, please let us know by opening a ticket on
    https://github.com/amatsuda/kaminari/issues/new
    
    Conflicts:
    	.travis.yml
    	README.rdoc
    	spec/fake_app/mongo_mapper/config.rb
Commits on Nov 22, 2014
  1. @yuki24
  2. @yuki24

    Fix the test suite for mongoid 40

    yuki24 authored
    It didn't run due to:
    
      moped-2.0.2/lib/moped/cluster.rb:254:in `with_primary':
        Could not connect to a primary node for replica set #<Moped::Cluster @seeds=[<Moped::Node resolved_address="127.0.1.1:27017">]>
        (Moped::Errors::ConnectionFailure)
  3. @yuki24

    Drop ActiveRecord 3.0/3.1 support

    yuki24 authored
    But 0.16.x will still have support for them.
  4. @yuki24

    Drop DataMapper support

    yuki24 authored
    it looks like DataMapper 1.2 is no longer maintained:
    
      * https://groups.google.com/forum/#!topic/datamapper/iTqd6IGxXpA
      * https://groups.google.com/forum/#!msg/datamapper/UCHC5TF6I0M/HamsbyNxuVAJ
    
    0.16.x will still have support for it, but not in 1.0.0.
  5. @yuki24

    DM 12 still need Rails 3.2...

    yuki24 authored
  6. @yuki24
  7. @yuki24
  8. @yuki24
  9. @yuki24
  10. @yuki24

    Be a bit more DRY in Rakefile

    yuki24 authored
Commits on Nov 21, 2014
  1. @yuki24

    Merge pull request #625 from joshk/patch-1

    yuki24 authored
    Use the new build env on Travis
Commits on Nov 20, 2014
  1. @joshk

    Use the new build env on Travis

    joshk authored
    faster better stronger
  2. @yuki24

    Only generate template files when doing rails g kaminari:views ...

    yuki24 authored
    This basically reverts 12822c9.
    
    closes #623.
  3. @yuki24

    Merge pull request #622 from maxprokopiev/fix-no-such-theme-case

    yuki24 authored
    Use class method '.themes' in ViewGenerator#copy_or_fetch
Commits on Nov 11, 2014
  1. @maxprokopiev
Commits on Nov 6, 2014
  1. @yuki24
  2. @yuki24
  3. @klebershimabuku @yuki24

    Using old ruby hash syntax

    klebershimabuku authored yuki24 committed
  4. @klebershimabuku @yuki24

    Fix :num_pages options to keep backwards-compatible

    klebershimabuku authored yuki24 committed
Commits on Nov 5, 2014
  1. @yuki24
Commits on Sep 21, 2014
  1. Merge pull request #603 from jomo/patch-1

    authored
    Fix wrong code in README
Something went wrong with that request. Please try again.