Use Rails.env instead of ENV["RAILS_ENV"] #53

Closed
svoynow opened this Issue Sep 13, 2011 · 3 comments

Projects

None yet

2 participants

@svoynow
svoynow commented Sep 13, 2011

No description provided.

@svoynow
svoynow commented Sep 13, 2011

it looks like support for ENV["RAILS_ENV"] was removed in rails 3.1. It's always nil now, which means that skip_verify_env is broken.

@svoynow
svoynow commented Sep 13, 2011

Actually, this looks a little more complicated than that, as Rails.env isn't (necessarily) available there. One solution would be to write a generator to create a recaptcha initializer that passes Rails.env into the configuration.

@ambethia
Owner

Auto-closing old issues, consider re-opening with a pull request if needed.

@ambethia ambethia closed this Feb 22, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment