Permalink
Browse files

jeweler is only a development dependency, it was listed as runtime de…

…pendency
  • Loading branch information...
1 parent faadeaa commit c6a31f525fb1791e4e876f3e0ebe87292b4f1185 @amfranz committed Nov 30, 2010
Showing with 7 additions and 11 deletions.
  1. +2 −2 Gemfile
  2. +0 −1 Gemfile.lock
  3. +5 −8 capistrano_database_yml.gemspec
View
@@ -1,4 +1,4 @@
source "http://rubygems.org"
-gem "bundler", "~> 1.0.0"
-gem "jeweler", "~> 1.5.1"
+gem "jeweler", "~> 1.5.1", :group => :development
+
View
@@ -12,5 +12,4 @@ PLATFORMS
ruby
DEPENDENCIES
- bundler (~> 1.0.0)
jeweler (~> 1.5.1)
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Michael Franz Aigner", "Simone Carletti"]
- s.date = %q{2010-11-29}
+ s.date = %q{2010-11-30}
s.description = %q{Provides a couple of tasks for creating the database.yml configuration file dynamically when deploy:setup is run.}
s.email = %q{amfranz@gmail.com}
s.extra_rdoc_files = [
@@ -41,18 +41,15 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_runtime_dependency(%q<jeweler>, ["~> 1.5.1"])
- s.add_runtime_dependency(%q<capistrano>, ["> 2.0"])
+ s.add_development_dependency(%q<jeweler>, ["~> 1.5.1"])
+ s.add_runtime_dependency(%q<capistrano>, ["~> 2.0"])
else
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
s.add_dependency(%q<jeweler>, ["~> 1.5.1"])
- s.add_dependency(%q<capistrano>, ["> 2.0"])
+ s.add_dependency(%q<capistrano>, ["~> 2.0"])
end
else
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
s.add_dependency(%q<jeweler>, ["~> 1.5.1"])
- s.add_dependency(%q<capistrano>, ["> 2.0"])
+ s.add_dependency(%q<capistrano>, ["~> 2.0"])
end
end

0 comments on commit c6a31f5

Please sign in to comment.