Skip to content
Browse files

new file: ChangeLog

	new file:   Manifest
	new file:   files/decimal-separator.patch
	new file:   files/googleearth-mimetypes.xml
	new file:   files/mime-magic.patch
	new file:   googleearth-6.2.1.6014-r1.ebuild
	new file:   googleearth-6.2.1.6014.ebuild
	new file:   metadata.xml
  • Loading branch information...
1 parent 1908939 commit b026ef1494b9152586081b8b1334dd8d7b57f09a @amielke committed May 2, 2012
View
445 sci-geosciences/googleearth/ChangeLog
@@ -0,0 +1,445 @@
+# ChangeLog for sci-geosciences/googleearth
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/googleearth/ChangeLog,v 1.30 2012/03/10 07:50:46 caster Exp $
+
+ 09 Mar 2012; Vlastimil Babka <caster@gentoo.org>
+ googleearth-6.2.1.6014-r1.ebuild:
+ Due to problems with QA variables, use RESTRICT=binchecks per zmedico's
+ advice.
+
+ 09 Mar 2012; Vlastimil Babka <caster@gentoo.org>
+ googleearth-6.2.1.6014-r1.ebuild:
+ Restore QA_DT_HASH variable, thanks to Oschtan, bug #401297.
+
+*googleearth-6.2.1.6014-r1 (02 Mar 2012)
+
+ 02 Mar 2012; Vlastimil Babka <caster@gentoo.org>
+ +googleearth-6.2.1.6014-r1.ebuild:
+ Correct exec path in desktop file, bug #406629 by 'jospezial'.
+
+*googleearth-6.2.1.6014 (01 Mar 2012)
+
+ 01 Mar 2012; Vlastimil Babka <caster@gentoo.org>
+ +googleearth-6.2.1.6014.ebuild, +files/googleearth-mimetypes.xml:
+ Version bump, bug #401297. Icon and elog improvements thanks to Oschtan.
+ Decimal separator bug appears to be solved upstream, removing the locale
+ patch. Reopen bug #262780 if it still occurs.
+
+ 05 Feb 2012; Mike Frysinger <vapier@gentoo.org>
+ googleearth-5.1.3535.3218-r1.ebuild, googleearth-5.2.1.1588.ebuild,
+ googleearth-6.0.2.2074.ebuild, googleearth-6.0.3.2197.ebuild:
+ Move to new unpacker eclass for unpack_makeself.
+
+ 13 Nov 2011; Mike Frysinger <vapier@gentoo.org>
+ googleearth-5.1.3535.3218-r1.ebuild, googleearth-5.2.1.1588.ebuild,
+ googleearth-6.0.2.2074.ebuild, googleearth-6.0.3.2197.ebuild:
+ Convert gcc[-nocxx] to gcc[cxx].
+
+*googleearth-6.0.3.2197 (24 May 2011)
+
+ 24 May 2011; Vlastimil Babka <caster@gentoo.org>
+ googleearth-6.0.2.2074.ebuild, +googleearth-6.0.3.2197.ebuild:
+ Version bump, bug #368405.
+
+ 22 Apr 2011; Vlastimil Babka <caster@gentoo.org>
+ -googleearth-6.0.1.2032_beta.ebuild:
+ Remove the no longer available beta.
+
+ 03 Apr 2011; Samuli Suominen <ssuominen@gentoo.org>
+ googleearth-6.0.2.2074.ebuild:
+ Disable "QA Notice: Files built without respecting LDFLAGS have been
+ detected" with QA_DT_HASH variable because this package is prebuilt.
+
+*googleearth-6.0.2.2074 (02 Apr 2011)
+
+ 02 Apr 2011; <caster@gentoo.org> +googleearth-6.0.2.2074.ebuild:
+ Version bump, bug #361273. The bundled libGLU.so.1 is no longer removed in
+ hope to improve stability and performance (see bug #354281).
+
+*googleearth-6.0.1.2032_beta (31 Jan 2011)
+
+ 31 Jan 2011; Vlastimil Babka <caster@gentoo.org>
+ googleearth-5.1.3535.3218-r1.ebuild, googleearth-5.2.1.1588.ebuild,
+ +googleearth-6.0.1.2032_beta.ebuild:
+ Version bump, fixes bug #348911. Thanks to Nathan Phillip Brink
+ <ohnobinki@ohnopublishing.net> for suggesting patchelf to work around missing
+ lsb symlinks. Update SRC_URI for 5.2.1. Mark 5.1 as fetch restricted as the
+ distfile is gone.
+
+ 13 Sep 2010; Vlastimil Babka <caster@gentoo.org>
+ -googleearth-5.2.1.1547_beta.ebuild, googleearth-5.2.1.1588.ebuild:
+ Remove the beta. Add pkg_nofetch() with information about upstream
+ distfile (mis)handling that new portage will display in case of distfile
+ checksum failure.
+
+*googleearth-5.2.1.1588 (08 Sep 2010)
+
+ 08 Sep 2010; Vlastimil Babka <caster@gentoo.org>
+ -googleearth-5.2.1.1329_beta.ebuild, +googleearth-5.2.1.1588.ebuild:
+ Version bump, fixes bug #336331.
+
+*googleearth-5.2.1.1547_beta (22 Aug 2010)
+
+ 22 Aug 2010; Vlastimil Babka <caster@gentoo.org>
+ +googleearth-5.2.1.1547_beta.ebuild:
+ Version bump, fixes bug #333487.
+
+ 03 Aug 2010; Vlastimil Babka <caster@gentoo.org>
+ -googleearth-5.1.3533.1731-r1.ebuild, googleearth-5.2.1.1329_beta.ebuild:
+ Remove the unfetchable version; more info in 5.2.1 postinst messages.
+
+ 20 Jun 2010; Christian Faulhammer <fauli@gentoo.org>
+ googleearth-5.1.3535.3218-r1.ebuild:
+ stable x86, bug 320065
+
+ 20 Jun 2010; Vlastimil Babka <caster@gentoo.org>
+ googleearth-5.1.3533.1731-r1.ebuild:
+ Make 5.1.3533.1731-r1 RESTRICT=fetch due to distfile no longer available,
+ with explanation.
+
+*googleearth-5.2.1.1329_beta (15 Jun 2010)
+
+ 15 Jun 2010; Vlastimil Babka <caster@gentoo.org>
+ +googleearth-5.2.1.1329_beta.ebuild:
+ Version bump. Enables qt-bundled flag by default due to crashes on
+ startup.
+
+ 15 Jun 2010; Vlastimil Babka <caster@gentoo.org>
+ -googleearth-4.2.205.5730.ebuild, -googleearth-4.3.7284.3916.ebuild,
+ -googleearth-5.0.11733.9347.ebuild, -googleearth-5.1.3535.3218.ebuild,
+ googleearth-5.1.3535.3218-r1.ebuild:
+ Update SRC_URI of 5.1.3535.3218-r1 to what is now hopefully a stable URL
+ of a final 5.1 release. Remove old versions.
+
+ 14 Jun 2010; Christoph Mende <angelos@gentoo.org>
+ googleearth-5.1.3535.3218-r1.ebuild:
+ Stable on amd64 wrt bug #320065
+
+*googleearth-5.1.3535.3218-r1 (07 Jun 2010)
+
+ 07 Jun 2010; Vlastimil Babka <caster@gentoo.org>
+ +googleearth-5.1.3535.3218-r1.ebuild:
+ Revbump to fix lib unbundling, broken when changing the unpack logic.
+ Thanks to Simone Scanzoni in bug #212373.
+
+ 22 May 2010; Torsten Veller <tove@gentoo.org> metadata.xml:
+ Remove genstef from metadata.xml (#66339)
+
+ 21 May 2010; Vlastimil Babka <caster@gentoo.org>
+ googleearth-5.1.3535.3218.ebuild:
+ Unpack the unpacked tarballs in src_unpack using unpack. Should fix bug
+ #320395. Apply patch in src_prepare.
+
+ 20 May 2010; Vlastimil Babka <caster@gentoo.org>
+ googleearth-5.1.3535.3218.ebuild:
+ Change back to unpack_makeself.
+
+ 19 May 2010; Vlastimil Babka <caster@gentoo.org>
+ googleearth-5.1.3535.3218.ebuild, files/decimal-separator.patch,
+ metadata.xml:
+ Unset LC_ALL along with setting LC_NUMERIC in the startup script to
+ prevent breaking coordinates in stored kml files, bug #262780. Add
+ mdns-bundled USE flag for using bundled library instead of
+ sys-auth/nss-mdns with dependencies, bug #320371. Use the unpack script
+ instead of unpack_makeself to avoid problems with pbzip2, bug #320313.
+ Clean up LICENSE declaration. Note that googleearth license was added in
+ the @EULA list and you need to unmask it by ACCEPT_LICENSE in make.conf if
+ you agree with it.
+
+ 16 May 2010; Vlastimil Babka <caster@gentoo.org>
+ googleearth-5.1.3535.3218.ebuild:
+ Add nss-mdns dep on x86 instead of bundled library.
+
+*googleearth-5.1.3535.3218 (16 May 2010)
+
+ 16 May 2010; Vlastimil Babka <caster@gentoo.org>
+ +googleearth-5.1.3535.3218.ebuild:
+ Version bump, bug #320065. Progress on lib unbundling thanks to tommy, bug
+ #212373.
+
+ 26 Apr 2010; Markus Meier <maekke@gentoo.org>
+ googleearth-5.1.3533.1731-r1.ebuild:
+ amd64/x86 stable, bug #307535
+
+ 26 Mar 2010; Dror Levin <spatz@gentoo.org>
+ googleearth-4.2.205.5730.ebuild, googleearth-4.3.7284.3916.ebuild,
+ googleearth-5.0.11733.9347.ebuild, googleearth-5.1.3533.1731-r1.ebuild:
+ Convert font deps to virtual/ttf-fonts wrt bug 282754.
+
+ 16 Mar 2010; Vlastimil Babka <caster@gentoo.org>
+ +googleearth-4.2.205.5730.ebuild, +googleearth-4.3.7284.3916.ebuild,
+ +googleearth-5.0.11733.9347.ebuild, +googleearth-5.1.3533.1731-r1.ebuild,
+ +files/decimal-separator.patch, +files/mime-magic.patch, +metadata.xml:
+ Package move from x11-misc/googleearth.
+
+ 19 Feb 2010; Vlastimil Babka <caster@gentoo.org>
+ -googleearth-5.1.3509.4636_beta.ebuild, -googleearth-5.1.3533.1731.ebuild,
+ googleearth-5.1.3533.1731-r1.ebuild:
+ Fix bug #303789 properly by depending on a fixed version of emul qtlibs.
+
+ 19 Feb 2010; Vlastimil Babka <caster@gentoo.org>
+ googleearth-5.1.3533.1731-r1.ebuild:
+ Add dependency on qt-core also for amd64 - workaround for bug #303789
+ until #305825 is solved.
+
+ 11 Feb 2010; Ulrich Mueller <ulm@gentoo.org>
+ googleearth-4.2.205.5730.ebuild, googleearth-4.3.7284.3916.ebuild,
+ googleearth-5.0.11733.9347.ebuild, googleearth-5.1.3509.4636_beta.ebuild,
+ googleearth-5.1.3533.1731.ebuild, googleearth-5.1.3533.1731-r1.ebuild:
+ Replace license X11 by MIT, bug 298556.
+
+ 31 Jan 2010; Vlastimil Babka <caster@gentoo.org>
+ googleearth-5.1.3533.1731-r1.ebuild, metadata.xml:
+ Add qt-bundled USE flag. If disabled (default), remove bundled Qt4
+ libraries and depend on system ones. Should fix font problems mentioned in
+ bugs #262780 and #252419. Unbundling libs tracked in #212373.
+
+ 22 Nov 2009; Vlastimil Babka <caster@gentoo.org>
+ googleearth-5.1.3533.1731-r1.ebuild:
+ Add dejavu font alternative as suggested in bug #262780.
+
+*googleearth-5.1.3533.1731-r1 (22 Nov 2009)
+
+ 22 Nov 2009; Vlastimil Babka <caster@gentoo.org>
+ +googleearth-5.1.3533.1731-r1.ebuild, +files/decimal-separator.patch:
+ Revbump with patch to prevent locales with comma decimal separator from
+ killing the saved places. Thanks to András <cucaracha@loco.hu> in bug
+ #262780.
+
+*googleearth-5.1.3533.1731 (18 Nov 2009)
+
+ 18 Nov 2009; Vlastimil Babka <caster@gentoo.org>
+ +googleearth-5.1.3533.1731.ebuild:
+ Version bump.
+
+ 07 Oct 2009; Vlastimil Babka <caster@gentoo.org>
+ googleearth-5.0.11733.9347.ebuild:
+ Found a stable (?) link for 5.0
+
+ 07 Oct 2009; Vlastimil Babka <caster@gentoo.org>
+ googleearth-5.1.3509.4636_beta.ebuild:
+ Depend on gcc-4.2+ and check that it's active in pkg_setup, ewarn
+ otherwise.
+
+*googleearth-5.1.3509.4636_beta (03 Oct 2009)
+
+ 03 Oct 2009; Vlastimil Babka <caster@gentoo.org>
+ -googleearth-5.1.3506.3999_beta.ebuild,
+ +googleearth-5.1.3509.4636_beta.ebuild:
+ Version bump, bug #287385.
+
+*googleearth-5.1.3506.3999_beta (11 Sep 2009)
+
+ 11 Sep 2009; Vlastimil Babka <caster@gentoo.org>
+ +googleearth-5.1.3506.3999_beta.ebuild:
+ Version bump. Fixes bug #284466 and uses QA_DT_HASH, bug #275140.
+
+ 22 Jun 2009; Vlastimil Babka <caster@gentoo.org>
+ googleearth-5.0.11733.9347.ebuild, metadata.xml:
+ Add missing deps, bug #274581. Move sed from unpack to src_prepare. Make
+ myself maintainer.
+
+ 26 May 2009; Jeroen Roovers <jer@gentoo.org>
+ -googleearth-5.0.11337.1968_beta.ebuild,
+ -googleearth-5.0.11729.1014.ebuild:
+ Remove versions with conflicting SRC_URIs.
+
+*googleearth-5.0.11733.9347 (26 May 2009)
+
+ 26 May 2009; Jeroen Roovers <jer@gentoo.org>
+ +googleearth-5.0.11733.9347.ebuild:
+ Version bump.
+
+*googleearth-5.0.11729.1014 (29 Apr 2009)
+
+ 29 Apr 2009; Vlastimil Babka <caster@gentoo.org>
+ +googleearth-5.0.11729.1014.ebuild:
+ Version bump, bug #267814. Use QA_TEXTRELS to suppres warnings, bug
+ #265171.
+
+*googleearth-5.0.11337.1968_beta (08 Feb 2009)
+
+ 08 Feb 2009; Vlastimil Babka <caster@gentoo.org>
+ +googleearth-5.0.11337.1968_beta.ebuild:
+ Version bump, bug #257533.
+
+ 06 Feb 2009; Vlastimil Babka <caster@gentoo.org>
+ googleearth-4.3.7284.3916.ebuild:
+ Update SRC_URI to the new upstream location, as the old link now points to
+ a 5.0 beta - bug #256267. Yay for upstream-versioned distfile, the SRC_URI
+ arrow is not needed anymore, but kept it so people don't download again.
+
+ 27 Sep 2008; Vlastimil Babka <caster@gentoo.org>
+ googleearth-4.3.7284.3916.ebuild:
+ Use EAPI=2 and SRC_URI arrow in 4.3 to put version in the distfile's
+ filename. So that all versions cane have own Manifest entry. Fixes bug
+ #236771.
+
+*googleearth-4.2.205.5730 (10 Aug 2008)
+
+ 10 Aug 2008; Stephanie Lockwood-Childs <wormo@gentoo.org>
+ +googleearth-4.2.205.5730.ebuild, googleearth-4.3.7284.3916.ebuild:
+ Introduce partially revisioned SRC_URI recommended by Daniel Wallace
+ in bug #221105, so now 4.2 ebuild can be available in parallel with 4.3
+
+ 09 Aug 2008; Stephanie Lockwood-Childs <wormo@gentoo.org>
+ googleearth-4.3.7284.3916.ebuild:
+ Add libXinerama dependency reported by Toralf Förster (bug #222489)
+
+*googleearth-4.3.7284.3916 (09 Aug 2008)
+
+ 09 Aug 2008; Stephanie Lockwood-Childs <wormo@gentoo.org>
+ -googleearth-4.2.205.5730.ebuild, +googleearth-4.3.7284.3916.ebuild:
+ Need another version bump since the old version has been overwritten
+ by a newer one again
+
+ 08 May 2008; Jeff Gardner <je_fro@gentoo.org> ChangeLog:
+ Digest for bug #219387a
+
+ 22 Dec 2007; Stefan Schweizer <genstef@gentoo.org>
+ -googleearth-4.2.198.2451.ebuild, +googleearth-4.2.205.5730.ebuild:
+ version bump thanks Toralf Förster <toralf.foerster@gmx.de> in bug 203027
+
+ 29 Nov 2007; <welp@gentoo.org> files/digest-googleearth-4.2.198.2451,
+ Manifest:
+ Fix digest
+
+*googleearth-4.2.198.2451 (13 Oct 2007)
+
+ 13 Oct 2007; Stefan Schweizer <genstef@gentoo.org> -googleearth-4.ebuild,
+ +googleearth-4.2.198.2451.ebuild:
+ Use full version number for betelgeuse in bug 191140
+
+*googleearth-4.ebuild (29 Aug 2007)
+
+ 29 Aug 2007; Stefan Schweizer <genstef@gentoo.org> googleearth-4.ebuild:
+ Version bump, only uri change and redigesting possible because upstream does
+ not change tarball names, bug 189827
+
+ 31 Jul 2007; Doug Goldstein <cardoe@gentoo.org> googleearth-4.ebuild:
+ nvidia-legacy-drivers has merged with nvidia-drivers
+
+ 17 Jul 2007; Stefan Schweizer <genstef@gentoo.org>
+ files/digest-googleearth-4, Manifest:
+ redigest
+
+ 23 May 2007; Stefan Schweizer <genstef@gentoo.org> googleearth-4.ebuild:
+ Bump md5 sum for the new version and fix sandbox violations with those. Much
+ thanks to Michael Lelli <baby.lueshi@gmail.com> in bug 177972 and bug 177984
+
+ 15 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
+ add <herd>no-herd</herd>
+
+ 14 Apr 2007; <welp@gentoo.org> googleearth-4.ebuild:
+ Stable on amd64 wrt bug 174605
+
+ 09 Mar 2007; Samuli Suominen <drac@gentoo.org> googleearth-4.ebuild:
+ Stop using virtual/x11.
+
+ 02 Mar 2007; Christian Faulhammer <opfer@gentoo.org> googleearth-4.ebuild:
+ stable x86; bug 168929
+
+ 10 Feb 2007; <genstef@gentoo.org> googleearth-4.ebuild:
+ remove .desktop redundancy thanks to jakub in bug 162775
+
+ 03 Feb 2007; Jason Wever <weeve@gentoo.org> files/digest-googleearth-4,
+ Manifest:
+ Another digest fix as the file appears to have changed upstream.
+
+ 18 Jan 2007; Raúl Porcel <armin76@gentoo.org> googleearth-4.ebuild:
+ Revert the ati/nvidia changes, as SRC_URI doesn't work. Request by jakub,
+ blame him
+
+*googleearth-4 (12 Jan 2007)
+
+ 12 Jan 2007; Charlie Shepherd <masterdriverz@gentoo.org>
+ -googleearth-4_beta.ebuild, +googleearth-4.ebuild:
+ Bump to googleearth-4; fixes bug 160849
+
+ 08 Jan 2007; <genstef@gentoo.org> googleearth-4_beta.ebuild:
+ Fix troubles with newer ati drivers thanks to anarchy in bug 158701
+
+ 27 Dec 2006; Daniel Black <dragonheart@gentoo.org>
+ files/digest-googleearth-4_beta, Manifest:
+ digest fix bug #158606 and SnowRaptor notification on #gentoo-dev-help
+
+ 02 Nov 2006; Stefan Schweizer <genstef@gentoo.org>
+ files/digest-googleearth-4_beta, Manifest:
+ New digest 4.0.2091 -> 4.0.2413 - this is annoying, google should provide
+ versioned downloads
+
+ 05 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ googleearth-4_beta.ebuild:
+ Removing references to media-video/nvidia-glx since it is no longer in the
+ tree.
+
+ 15 Sep 2006; Stefan Schweizer <genstef@gentoo.org> ChangeLog:
+ digest fix
+
+ 14 Sep 2006; Stefan Schweizer <genstef@gentoo.org>
+ googleearth-4_beta.ebuild:
+ depend on <x11-drivers/ati-drivers-8.28.8 for amd64 because it breaks on
+ runtime, thanks to Thomas Skyt <thomas@sofagang.dk> and Ulf
+ <fly-a-lot@web.de> in bug 147309
+
+ 30 Aug 2006; Stefan Schweizer <genstef@gentoo.org>
+ googleearth-4_beta.ebuild:
+ Workaround xdg-utils problems thanks to Rick Harris
+ <rickfharris@yahoo.com.au>, Lukas Barth <tinloaf@goerresonline.de> and Olaf
+ Freyer <aaron@cs.tu-berlin.de> in bug 144670
+
+ 08 Aug 2006; Stefan Schweizer <genstef@gentoo.org> ChangeLog:
+ redigest, bug 142920
+
+ 24 Jul 2006; Stefan Schweizer <genstef@gentoo.org> files/mime-magic.patch:
+ improved patch to work with kml 2.1 thanks to Ed Catmur again
+
+ 23 Jul 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/mime-magic.patch, googleearth-4_beta.ebuild:
+ Add some magic to the googleearth mime file to improve handling in gnome,
+ thanks to Ed Catmur <ed@catmur.co.uk> in bug 141371
+
+ 19 Jul 2006; Stefan Schweizer <genstef@gentoo.org>
+ googleearth-4_beta.ebuild:
+ No more execstack, thanks to Sascha Geschwandtner <s.geschwandtner@gmx.de>
+ in bug 141003
+
+ 18 Jul 2006; Stefan Schweizer <genstef@gentoo.org> ChangeLog:
+ redigest, bug 139544
+
+ 16 Jul 2006; Stefan Schweizer <genstef@gentoo.org> ChangeLog:
+ redigest, bug 139544
+
+ 08 Jul 2006; Stefan Schweizer <genstef@gentoo.org> ChangeLog:
+ redigest thanks to Marcel Campello Ferreira <marcel.o.bacharel@gmail.com>,
+ Rabbe Fogelholm <rabbe@gentoo.se>, Jakub Moc <jakub@gentoo.org> and Mike
+ <BluexSteel@gmail.com> in bug 139544
+
+ 07 Jul 2006; Kristopher Kersey <augustus@gentoo.org>
+ googleearth-4_beta.ebuild:
+ Added RDEPEND for new x11-drivers/nvidia-drivers or
+ x11-drivers/nvidia-legacy-drivers.
+
+ 22 Jun 2006; Stefan Schweizer <genstef@gentoo.org>
+ googleearth-4_beta.ebuild:
+ correct permissions thanks to mrsteven <mrsteven@gmx.de> in bug 137524
+
+ 13 Jun 2006; Stefan Schweizer <genstef@gentoo.org>
+ googleearth-4_beta.ebuild:
+ unset environment variable that could break the installation, thanks to zzam
+ in #gentoo-bugs
+
+ 13 Jun 2006; Stefan Schweizer <genstef@gentoo.org>
+ googleearth-4_beta.ebuild:
+ Ignore QA checks and RESTRICT=strip, thanks to Jon Hood
+ <squinky86@gentoo.org> and Jakub Moc <jakub@gentoo.org> in bug 136610 and
+ use google scripts for the .desktop files, no revbump
+
+ 13 Jun 2006; Olivier Crête <tester@gentoo.org> googleearth-4_beta.ebuild:
+ Added ~amd64 keyword and deps, fixed digest
+
+ 13 Jun 2006; Stefan Schweizer <genstef@gentoo.org> ChangeLog:
+ New Google Earth ebuild for bug 136584, thanks to Natanael Copa
+ <natanael.copa@gmail.com> for opening the bug and Tristan Heaven
+ <tristanheaven@gmail.com> for the ebuild.
+
View
9 sci-geosciences/googleearth/Manifest
@@ -0,0 +1,9 @@
+AUX decimal-separator.patch 324 RMD160 88c5c41517d4195a1f6ad03f58762021fe9ff255 SHA1 82b6920a3ac9ffd4481fe31f60bc72e22e0d4093 SHA256 5c1ffe3cb7b7328245d92c627f8b8d963a9a2aab67c70b5387b151f78b04c051
+AUX googleearth-mimetypes.xml 638 RMD160 2af02c7144488d0364d883659644281f5671e57b SHA1 b80e6e2d4f0be664cf4678d9ad92a74a58ce0b2e SHA256 71e57a7370dc2c0eb6b85e2bbb5282ed7a7542e58f849a20282b1627cef9b2b9
+AUX mime-magic.patch 572 RMD160 e49ddaf43ca7de3cfabf08754f4f4d21864a3489 SHA1 e6689a0f970cfc677749e1ee3aeeaa3b8f5605fc SHA256 302bfab0aa2edd09a2a83f7040de4dcc09998e822555b85242e2e8cb05fb3a12
+DIST GoogleEarthLinux-6.2.1.6014_amd64.deb 25609162 RMD160 0ad2ced1c0647cc047b8547c7c46c68f311ea1e8 SHA1 fa1f410eaf94a14c8e47594dc0618b0bf7cfb8bb SHA256 a67021ed74fd1821ba0a63e141320ca0bcd78ab618dd368629e500d208d12525
+DIST GoogleEarthLnux-6.2.1.6014_i386.deb 25620810 RMD160 8548ff1caca350625362fdd7a711e8b1129b0703 SHA1 4f860b4b0ee36e97a93a97895821ad18e8ca7a1e SHA256 e309ce1493dec6abc742037b1e6822b08771827db59ee7e5d5da56cb40c92111
+EBUILD googleearth-6.2.1.6014-r1.ebuild 5259 RMD160 926a92facca66c6fd5bb6aa1272030f3de2f8449 SHA1 3db15fa195e4c92c2be54c8a47d821e315a0f047 SHA256 8711193cbb28d0777cce75bd4eda4bff5e5d7de456dc23bb022d6e18b053c841
+EBUILD googleearth-6.2.1.6014.ebuild 6226 RMD160 ff7bd4e678f3b0c0f14022b320823a7662f0abce SHA1 ad291e80c4034a674ca7e533f30d84713430909e SHA256 e06a93941eddcef20de40e11610f95681c5b2a86dc6cd0d0194ef68668467e57
+MISC ChangeLog 17439 RMD160 28d33aeedfccb84b1eb1a3c99d942e5c2636095b SHA1 fa4c412706e5934cf4e05a81c4c27131ffccfcb9 SHA256 9b16c5b19041eee10560899465099176563dd6eebd8264e041c4f7371c4e5b58
+MISC metadata.xml 592 RMD160 293f66d3138e8538252d9c542d1548305be543d7 SHA1 9c6cfc1f4066fb84dd77bc109651dc6526080ad7 SHA256 aeb2f5a091efa0e2325a89bf8501ca993ce235cb47847f3a95be339efb01bbb8
View
11 sci-geosciences/googleearth/files/decimal-separator.patch
@@ -0,0 +1,11 @@
+--- googleearth.orig 2009-10-18 15:46:03.000000000 +0200
++++ googleearth 2009-10-18 15:45:39.000000000 +0200
+@@ -41,6 +41,8 @@
+
+ LD_LIBRARY_PATH=.:${GOOGLEEARTH_DATA_PATH}:${LD_LIBRARY_PATH}
+ export LD_LIBRARY_PATH
++export LC_NUMERIC=C
++unset LC_ALL
+
+ # Let's boogie!
+ if [ -x "${GOOGLEEARTH_DATA_PATH}/googleearth-bin" ]
View
21 sci-geosciences/googleearth/files/googleearth-mimetypes.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0"?>
+<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="application/vnd.google-earth.kml+xml">
+ <comment>Keyhole Markup Language data</comment>
+ <glob pattern="*.kml"/>
+ </mime-type>
+
+ <mime-type type="application/vnd.google-earth.kmz">
+ <comment>Keyhole Markup Language archive</comment>
+ <glob pattern="*.kmz"/>
+ </mime-type>
+
+ <mime-type type="application/keyhole">
+ <comment>Keyhole Markup Language data</comment>
+ </mime-type>
+
+ <mime-type type="application/earthviewer">
+ <comment>Keyhole Markup Language data</comment>
+ </mime-type>
+</mime-info>
+
View
12 sci-geosciences/googleearth/files/mime-magic.patch
@@ -0,0 +1,12 @@
+--- usr/share/mime/packages/googleearth-mimetypes.xml 2006-07-22 10:13:03.000000000 +0100
++++ usr/share/mime/packages/googleearth-mimetypes.xml 2006-07-22 10:41:14.584945382 +0100
+@@ -2,6 +2,9 @@
+ <mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="application/vnd.google-earth.kml+xml">
+ <comment>Keyhole Markup Language data</comment>
++ <magic priority="60">
++ <match value="&lt;kml xmlns=&quot;http://earth.google.com/kml/" type="string" offset="0:64"/>
++ </magic>
+ <glob pattern="*.kml"/>
+ </mime-type>
+
View
158 sci-geosciences/googleearth/googleearth-6.2.1.6014-r1.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/googleearth/googleearth-6.2.1.6014-r1.ebuild,v 1.3 2012/03/10 07:50:46 caster Exp $
+
+EAPI="4"
+
+inherit eutils unpacker fdo-mime versionator toolchain-funcs
+
+DESCRIPTION="A 3D interface to the planet"
+HOMEPAGE="http://earth.google.com/"
+# no upstream versioning, version determined from help/about
+# incorrect digest means upstream bumped and thus needs version bump
+SRC_URI="x86? ( http://dl.google.com/dl/earth/client/current/google-earth-stable_current_i386.deb
+ -> GoogleEarthLnux-${PV}_i386.deb )
+ amd64? ( http://dl.google.com/dl/earth/client/current/google-earth-stable_current_amd64.deb
+ -> GoogleEarthLinux-${PV}_amd64.deb ) "
+LICENSE="googleearth GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="binchecks mirror strip"
+IUSE="mdns-bundled +qt-bundled"
+
+GCC_NEEDED="4.2"
+
+RDEPEND="|| ( >=sys-devel/gcc-${GCC_NEEDED}[cxx] >=sys-devel/gcc-${GCC_NEEDED}[-nocxx] )
+ x86? (
+ media-libs/fontconfig
+ media-libs/freetype
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ sys-libs/zlib
+ dev-libs/glib:2
+ !qt-bundled? (
+ >=x11-libs/qt-core-4.5.3
+ >=x11-libs/qt-gui-4.5.3
+ >=x11-libs/qt-webkit-4.5.3
+ )
+ net-misc/curl
+ sci-libs/gdal
+ !mdns-bundled? ( sys-auth/nss-mdns )
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-xlibs-20081109
+ >=app-emulation/emul-linux-x86-baselibs-20081109
+ app-emulation/emul-linux-x86-opengl
+ !qt-bundled? (
+ >=app-emulation/emul-linux-x86-qtlibs-20091231-r1
+ )
+ )
+ virtual/ttf-fonts"
+
+DEPEND="dev-util/patchelf"
+
+S="${WORKDIR}/opt/google/earth/free"
+
+pkg_nofetch() {
+ einfo "Wrong checksum or file size means that Google silently replaced the distfile with a newer version."
+ einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
+ einfo "Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for googleearth first!)."
+ einfo "By redigesting the file yourself, you will install a different version than the ebuild says, untested!"
+}
+
+pkg_setup() {
+ GCC_VER="$(gcc-version)"
+ if ! version_is_at_least ${GCC_NEEDED} ${GCC_VER}; then
+ ewarn "${PN} needs libraries from gcc-${GCC_NEEDED} or higher to run"
+ ewarn "Your active gcc version is only ${GCC_VER}"
+ ewarn "Please consult the GCC upgrade guide to set a higher version:"
+ ewarn "http://www.gentoo.org/doc/en/gcc-upgrading.xml"
+ fi
+}
+
+src_unpack() {
+ # default src_unpack fails with deb2targz installed, also this unpacks the data.tar.lzma as well
+ unpack_deb ${A}
+
+ cd opt/google/earth/free || die
+
+ if ! use qt-bundled; then
+ rm -v libQt{Core,Gui,Network,WebKit}.so.4 qt.conf || die
+ rm -frv plugins/imageformats || die
+ fi
+ rm -v libcurl.so.4 || die
+ if ! use mdns-bundled; then
+ rm -v libnss_mdns4_minimal.so.2 || die
+ fi
+
+ if use x86; then
+ # no 32 bit libs for gdal
+ rm -v libgdal.so.1 || die
+ fi
+}
+
+src_prepare() {
+ # bug #262780 is hopefully now solved upstream
+# epatch "${FILESDIR}/decimal-separator.patch"
+
+ # we have no ld-lsb.so.3 symlink
+ # thanks to Nathan Phillip Brink <ohnobinki@ohnopublishing.net> for suggesting patchelf
+ patchelf --set-interpreter /lib/ld-linux.so.2 ${PN}-bin || die "patchelf failed"
+}
+
+src_install() {
+ make_wrapper ${PN} ./${PN} /opt/${PN} . || die "make_wrapper failed"
+
+ # install binaries and remove them
+ binaries="${PN} ${PN}-bin *.so *.so.*"
+ exeinto /opt/${PN}
+ doexe ${binaries} || die
+ rm ${binaries}
+
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}/${PN}-mimetypes.xml" || die
+ sed "s#/opt/google/earth/free/google-earth#/opt/${PN}/${PN}#" -i google-earth.desktop || die
+ domenu google-earth.desktop
+ for size in 16 22 24 32 48 64 128 256 ; do
+ insinto /usr/share/icons/hicolor/${size}x${size}/apps
+ newins product_logo_${size}.png google-earth.png
+ done
+ rm -rf product_logo_* xdg-mime xdg-settings google-earth google-earth.desktop || die
+
+ # just copy everything that's left
+ cp -pPR * "${D}"/opt/${PN} || die
+
+ # some files are executable and shouldn't
+ fperms -R a-x,a+X /opt/googleearth/resources
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
+ elog "The qt-bundled flag is now enabled by default due to crashes on startup with system Qt."
+ elog "Testing and reporting outcome with/without the flag is welcome (bug #319813)."
+ elog "If it crashes in both cases, disabling tips is reported to help (bug #354281):"
+ elog ""
+ elog "When you get a crash starting Google Earth, try adding a file ~./config/Google/GoogleEarthPlus.conf"
+ elog "the following options:"
+ elog "lastTip = 4"
+ elog "enableTips = false"
+ elog ""
+ elog "In addition, the use of free video drivers may be problems associated with using the Mesa"
+ elog "library. In this case, Google Earth 6x likely only works with the Gallium3D variant."
+ elog "To select the 32bit graphic library use the command:"
+ elog " eselect mesa list"
+ elog "For example, for Radeon R300 (x86):"
+ elog " eselect mesa set r300 2"
+ elog "For Intel Q33 (amd64):"
+ elog " eselect mesa set 32bit i965 2"
+ elog "You may need to restart X afterwards"
+}
View
189 sci-geosciences/googleearth/googleearth-6.2.1.6014.ebuild
@@ -0,0 +1,189 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/googleearth/googleearth-6.2.1.6014.ebuild,v 1.1 2012/03/01 23:07:28 caster Exp $
+
+EAPI="4"
+
+inherit eutils unpacker fdo-mime versionator toolchain-funcs
+
+DESCRIPTION="A 3D interface to the planet"
+HOMEPAGE="http://earth.google.com/"
+# no upstream versioning, version determined from help/about
+# incorrect digest means upstream bumped and thus needs version bump
+SRC_URI="x86? ( http://dl.google.com/dl/earth/client/current/google-earth-stable_current_i386.deb
+ -> GoogleEarthLnux-${PV}_i386.deb )
+ amd64? ( http://dl.google.com/dl/earth/client/current/google-earth-stable_current_amd64.deb
+ -> GoogleEarthLinux-${PV}_amd64.deb ) "
+LICENSE="googleearth GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror strip"
+IUSE="mdns-bundled +qt-bundled"
+
+GCC_NEEDED="4.2"
+
+RDEPEND="|| ( >=sys-devel/gcc-${GCC_NEEDED}[cxx] >=sys-devel/gcc-${GCC_NEEDED}[-nocxx] )
+ x86? (
+ media-libs/fontconfig
+ media-libs/freetype
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ sys-libs/zlib
+ dev-libs/glib:2
+ !qt-bundled? (
+ >=x11-libs/qt-core-4.5.3
+ >=x11-libs/qt-gui-4.5.3
+ >=x11-libs/qt-webkit-4.5.3
+ )
+ net-misc/curl
+ sci-libs/gdal
+ !mdns-bundled? ( sys-auth/nss-mdns )
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-xlibs-20081109
+ >=app-emulation/emul-linux-x86-baselibs-20081109
+ app-emulation/emul-linux-x86-opengl
+ !qt-bundled? (
+ >=app-emulation/emul-linux-x86-qtlibs-20091231-r1
+ )
+ )
+ virtual/ttf-fonts"
+
+DEPEND="dev-util/patchelf"
+
+S="${WORKDIR}/opt/google/earth/free"
+
+pkg_nofetch() {
+ einfo "Wrong checksum or file size means that Google silently replaced the distfile with a newer version."
+ einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
+ einfo "Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for googleearth first!)."
+ einfo "By redigesting the file yourself, you will install a different version than the ebuild says, untested!"
+}
+
+QA_TEXTRELS="opt/googleearth/plugins/imageformats/libqjpeg.so
+opt/googleearth/libQtGui.so.4
+opt/googleearth/libwebbrowser.so
+opt/googleearth/libviewsync.so
+opt/googleearth/libspatial.so
+opt/googleearth/libsgutil.so
+opt/googleearth/libsearch.so
+opt/googleearth/libsearchmodule.so
+opt/googleearth/librender.so
+opt/googleearth/libnavigate.so
+opt/googleearth/libmoduleframework.so
+opt/googleearth/libmeasure.so
+opt/googleearth/liblayer.so
+opt/googleearth/libinput_plugin.so
+opt/googleearth/libIGGfx.so
+opt/googleearth/libgps.so
+opt/googleearth/libgooglesearch.so
+opt/googleearth/libgoogleearth_free.so
+opt/googleearth/libgoogleapi.so
+opt/googleearth/libgeobaseutils.so
+opt/googleearth/libgdata.so
+opt/googleearth/libflightsim.so
+opt/googleearth/libevll.so
+opt/googleearth/libcommon_webbrowser.so
+opt/googleearth/libcommon.so
+opt/googleearth/libcommon_platform.so
+opt/googleearth/libcollada.so
+opt/googleearth/libbasicingest.so
+opt/googleearth/libbase.so
+opt/googleearth/libauth.so"
+
+pkg_setup() {
+ GCC_VER="$(gcc-version)"
+ if ! version_is_at_least ${GCC_NEEDED} ${GCC_VER}; then
+ ewarn "${PN} needs libraries from gcc-${GCC_NEEDED} or higher to run"
+ ewarn "Your active gcc version is only ${GCC_VER}"
+ ewarn "Please consult the GCC upgrade guide to set a higher version:"
+ ewarn "http://www.gentoo.org/doc/en/gcc-upgrading.xml"
+ fi
+}
+
+src_unpack() {
+ # default src_unpack fails with deb2targz installed, also this unpacks the data.tar.lzma as well
+ unpack_deb ${A}
+
+ cd opt/google/earth/free || die
+
+ if ! use qt-bundled; then
+ rm -v libQt{Core,Gui,Network,WebKit}.so.4 qt.conf || die
+ rm -frv plugins/imageformats || die
+ fi
+ rm -v libcurl.so.4 || die
+ if ! use mdns-bundled; then
+ rm -v libnss_mdns4_minimal.so.2 || die
+ fi
+
+ if use x86; then
+ # no 32 bit libs for gdal
+ rm -v libgdal.so.1 || die
+ fi
+}
+
+src_prepare() {
+ # bug #262780 is hopefully now solved upstream
+# epatch "${FILESDIR}/decimal-separator.patch"
+
+ # we have no ld-lsb.so.3 symlink
+ # thanks to Nathan Phillip Brink <ohnobinki@ohnopublishing.net> for suggesting patchelf
+ patchelf --set-interpreter /lib/ld-linux.so.2 ${PN}-bin || die "patchelf failed"
+}
+
+src_install() {
+ make_wrapper ${PN} ./${PN} /opt/${PN} . || die "make_wrapper failed"
+
+ # install binaries and remove them
+ binaries="${PN} ${PN}-bin *.so *.so.*"
+ exeinto /opt/${PN}
+ doexe ${binaries} || die
+ rm ${binaries}
+
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}/${PN}-mimetypes.xml" || die
+ sed "s#/opt/google/earth/free/google-earth/#/opt/${PN}/${PN}#" -i google-earth.desktop || die
+ domenu google-earth.desktop
+ for size in 16 22 24 32 48 64 128 256 ; do
+ insinto /usr/share/icons/hicolor/${size}x${size}/apps
+ newins product_logo_${size}.png google-earth.png
+ done
+ rm -rf product_logo_* xdg-mime xdg-settings google-earth google-earth.desktop || die
+
+ # just copy everything that's left
+ cp -pPR * "${D}"/opt/${PN} || die
+
+ # some files are executable and shouldn't
+ fperms -R a-x,a+X /opt/googleearth/resources
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
+ elog "The qt-bundled flag is now enabled by default due to crashes on startup with system Qt."
+ elog "Testing and reporting outcome with/without the flag is welcome (bug #319813)."
+ elog "If it crashes in both cases, disabling tips is reported to help (bug #354281):"
+ elog ""
+ elog "When you get a crash starting Google Earth, try adding a file ~./config/Google/GoogleEarthPlus.conf"
+ elog "the following options:"
+ elog "lastTip = 4"
+ elog "enableTips = false"
+ elog ""
+ elog "In addition, the use of free video drivers may be problems associated with using the Mesa"
+ elog "library. In this case, Google Earth 6x likely only works with the Gallium3D variant."
+ elog "To select the 32bit graphic library use the command:"
+ elog " eselect mesa list"
+ elog "For example, for Radeon R300 (x86):"
+ elog " eselect mesa set r300 2"
+ elog "For Intel Q33 (amd64):"
+ elog " eselect mesa set 32bit i965 2"
+ elog "You may need to restart X afterwards"
+}
View
13 sci-geosciences/googleearth/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>caster@gentoo.org</email>
+ <name>Vlastimil Babka</name>
+ <description>Assign bugs to me for now</description>
+ </maintainer>
+ <use>
+ <flag name="qt-bundled">Use bundled Qt4 libraries instead of system ones. Recommended only for troubleshooting.</flag>
+ <flag name="mdns-bundled">Use bundled nss-mdns library instead of depending on sys-auth/nss-mdns. Enable this if you want to avoid the deptree.</flag>
+ </use>
+</pkgmetadata>

0 comments on commit b026ef1

Please sign in to comment.
Something went wrong with that request. Please try again.