Skip to content
Permalink
Browse files

add php 7.4 to travis

  • Loading branch information
lachlan-00 committed Dec 12, 2019
1 parent e360c78 commit 3944157281baa9be0c482bc3e029db7cce4c4b2b
Showing with 6 additions and 4 deletions.
  1. +2 −1 .travis.yml
  2. +3 −3 docs/CHANGELOG.md
  3. +1 −0 lib/init-tiny.php
@@ -3,7 +3,8 @@ sudo: false
php:
- 7.1
- 7.3

- 7.4

before_install:
- export PATH="$PATH:$HOME/.composer/vendor/bin"
- composer global require friendsofphp/php-cs-fixer:~2.15.0
@@ -6,15 +6,15 @@
* Api::playlist - filter mandatory
* Api::playlist_edit - filter mandatory. name and type now optional
* Api::user - Extend return values to include more user fields
* Api - Do not limit smartlists based on item count
* Api/Databse - Add last_count for search table to speed up access in API
* Api - Do not limit smartlists based on item count (return everything you can access)
* Api/Database - Add last_count for search table to speed up access in API
* Playlist::create - Return duplicate playlist ID instead of creating a new one
* Artist::check - Remove MBID from Various Artist objects
* Fix Api relating to playlist access
* Fix Song::update_song for label
* Fix comparison bugs found during static type testing
* Fix enable/disable song ajax
* Translation update from Transifex
* December translation update from Transifex
* Add playlist into main search page. (Songs, Albums, Artists, Playlists, Videos)
* Typo in login page HTTP_REFERER
* Roll back mysql8 workarounds. (Orace MySQL supported on php7.4+ only)
@@ -25,6 +25,7 @@
// Do a check for PHP5.4 because nothing will work without it
if (version_compare(phpversion(), '7.1.0', '<')) {
echo T_("Ampache requires PHP version >= 7.1");
throw new \RuntimeException(T_("Ampache requires PHP version >= 7.1"));

return false;
}

0 comments on commit 3944157

Please sign in to comment.
You can’t perform that action at this time.