New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Problem with amp-iframe #1410

Closed
prolibre opened this Issue Sep 7, 2018 · 3 comments

Comments

Projects
None yet
2 participants
@prolibre

prolibre commented Sep 7, 2018

Hello,

I have an error in the google console for a few pages because of this piece of code in my html :

<iframe style="min-height: 400px;" src="https://www.geoportail.gouv.fr/embed/visu.html?c=3.9735668054865076,43.90558192721261&z=15&l0=GEOLOGY.GEOLOGY::EXTERNAL:OGC:EXTERNALWMS(1)&permalink=yes" width="100%" height="auto" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" sandbox="allow-forms allow-scripts allow-same-origin" allowfullscreen="allowfullscreen"></iframe>

that becomes in my amp page:

<amp-iframe height="400" frameborder="0" sandbox="allow-forms allow-scripts allow-same-origin" allowfullscreen="" layout="fixed-height"><div placeholder="" class="amp-wp-iframe-placeholder"></div></amp-iframe>

As the does not have a src it does not work :-(

Thank you very much for your work!

Anthony

@westonruter westonruter self-assigned this Sep 7, 2018

@westonruter westonruter added this to the v1.0 milestone Sep 7, 2018

@westonruter

This comment has been minimized.

Member

westonruter commented Sep 7, 2018

I can reproduce the issue. The src is getting stripped out by the validator. I'll investigate.

@westonruter

This comment has been minimized.

Member

westonruter commented Sep 7, 2018

@prolibre A quick workaround is to replace , in your URL with %2C.

@prolibre

This comment has been minimized.

prolibre commented Sep 8, 2018

thanks @westonruter. Have a nive day.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment