Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix inability to move link element due to assigned parent #1322

Merged
merged 1 commit into from Aug 6, 2018

Conversation

Projects
None yet
2 participants
@westonruter
Copy link
Member

westonruter commented Aug 6, 2018

I was adding some more preload links to the head and I noticed some of them stopped showing up. In looking at the log I found:

PHP Warning: DOMNode::insertBefore(): Couldn't add newnode as the previous sibling of refnode

In JS you can freely move nodes around the tree without removing them first. In PHP (libxml) it seems it requires that they be removed from the DOM before re-inserting them. While I was doing this in other places in the ensure_required_markup method, I neglected to do it fully here.

@westonruter westonruter added this to the v1.0 milestone Aug 6, 2018

@westonruter westonruter requested a review from hellofromtonya Aug 6, 2018

@hellofromtonya hellofromtonya merged commit 9bd2a05 into develop Aug 6, 2018

2 checks passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
continuous-integration/travis-ci/push The Travis CI build passed
Details

@westonruter westonruter deleted the fix/link-node-movement branch Sep 6, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.