Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bento: Errant bent statement breaks component #35741

Closed
swissspidy opened this issue Aug 19, 2021 · 0 comments · Fixed by #35766
Closed

Bento: Errant bent statement breaks component #35741

swissspidy opened this issue Aug 19, 2021 · 0 comments · Fixed by #35766

Comments

@swissspidy
Copy link
Contributor

Description

Eager to test the new enhancement in #35446, I updated the @ampproject/amp-base-carousel npm package to the latest version (1.2108190446.0) only to find out that it's now totally broken.

Both the Preact and the React components have bent on their first line, causing ReferenceError: bent is not defined errors when trying to use them.

For reference, here are the first 7 lines of component-react.max.js:

bent
var __create = Object.create;
var __defProp = Object.defineProperty;
var __getOwnPropDesc = Object.getOwnPropertyDescriptor;
var __getOwnPropNames = Object.getOwnPropertyNames;
var __getProtoOf = Object.getPrototypeOf;
var __hasOwnProp = Object.prototype.hasOwnProperty;

And some screenshots:

Screenshot 2021-08-19 at 18 36 37
Screenshot 2021-08-19 at 18 36 54

Reproduction Steps

Install @ampproject/amp-base-carousel and try to use the React or Preact component in an application.

Relevant Logs

ReferenceError: bent is not defined

Browser(s) Affected

No response

OS(s) Affected

No response

Device(s) Affected

No response

AMP Version Affected

2108190446000

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
Bento
  
Done
Development

Successfully merging a pull request may close this issue.

2 participants