Skip to content
A lightweight, feature-rich, easy-to-use and nice-looking BitTorrent Client developed by golang, angular 7, and electron.
Branch: master
Clone or download
Latest commit 483b2f5 May 11, 2019

README.md

ANT Downloader

Build Status Stable Version License: MPL 2.0

English | 中文

ANT Downloader is a BitTorrent Client developed by golang, angular 7, and electron. ANT aims to be a lightweight, feature-rich, easy-to-use and nice-looking client.

If you like this application, please consider give a star for this project.

Why should you consider ANT Downloader:

  • a BitTorrent client for all platforms
  • a BitTorrent client with aesthetic appearance
  • a BitTorrent client with low resource occupancy, total size of installation package for windows is only about 40M.
  • a BitTorrent client with rich set of functions including:
    • support for IPV4 and IPV6 settings
    • support for torrent file and magnet link
    • support for playing video while downloading
  • a easy-to-use BitTorrent client. ANT Downloader will take care of most settings needed for a BitTorrent client, including:
    • Reduce time to analyse magnet link by using itorrents
    • Update best tracker servers from trackerslist
    • ...

Considering features in following version:

  • Download and steam selected file (Current version will download all files in one torrent and only steam the biggest file.)
  • Support different UI themes
  • Support more download methods like ed2k, webTorrent
  • Control ANT Downloader from remote machine.

TODO List

  • Add support for network speed limit
  • Add support for maximum number of download task

Architecture:

Preview:

  • Add torrent download task

  • Playing video while downloading

Get Started

You can download packaged binary file directly from Release

You can also build project with one of following cmd, and it depends on your system:

npm run electron:linux
npm run electron:windows
npm run electron:mac

More npm usage is described in package.json, make sure your system has following dependences

  • node >= 11.0.x
  • golang >= 1.10.x

Special thanks

Contact me

You can send emails to luolongjuna@gmail.com.

You can’t perform that action at this time.