Find file
Fetching contributors…
Cannot retrieve contributors at this time
44 lines (39 sloc) 1.5 KB
require 'rubygems'
require 'bundler'
begin
Bundler.setup(:default, :development)
rescue Bundler::BundlerError => e
$stderr.puts e.message
$stderr.puts "Run `bundle install` to install missing gems"
exit e.status_code
end
require 'rake'
require 'jeweler'
Jeweler::Tasks.new do |gem|
# gem is a Gem::Specification... see http://docs.rubygems.org/read/chapter/20 for more options
gem.name = "validates_overlap"
gem.homepage = "http://github.com/robinbortlik/validates_overlap"
gem.license = "MIT"
gem.summary = "This gem helps validate records with time overlap."
gem.description = "It can be useful when you you are developing some app where you will work with meetings, events etc."
gem.email = "robinbortlik@gmail.com"
gem.authors = ["Robin Bortlik"]
# Include your dependencies below. Runtime dependencies are required when using your gem,
# and development dependencies are only needed for development (ie running rake tasks, tests, etc)
gem.add_runtime_dependency 'rails', '>= 3.0.0'
gem.add_development_dependency 'rspec-rails'
gem.add_development_dependency 'factory_girl_rails'
end
Jeweler::RubygemsDotOrgTasks.new
require 'rspec/core'
require 'rspec/core/rake_task'
RSpec::Core::RakeTask.new(:spec)
task :default => :spec
require 'rake/rdoctask'
Rake::RDocTask.new do |rdoc|
version = File.exist?('VERSION') ? File.read('VERSION') : ""
rdoc.rdoc_dir = 'rdoc'
rdoc.title = "validates_overlap #{version}"
rdoc.rdoc_files.include('README*')
rdoc.rdoc_files.include('lib/**/*.rb')
end