New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unable to run on Mac OSX 10.x #2

Open
dustinromey opened this Issue Aug 10, 2014 · 9 comments

Comments

Projects
None yet
4 participants
@dustinromey

dustinromey commented Aug 10, 2014

Tried versions 2.1.7 and 2.1.6 downloaded from Sourceforge. Below is the Console output for Admin4:

8/10/14 6:42:46.000 AM kernel[0]: hfs: mounted Admin4 on device disk1s1
8/10/14 6:42:46.173 AM mds[60]: (Normal) Volume: volume:0x7f891aa44400 ********** Bootstrapped Creating a default store:1 SpotLoc:(null) SpotVerLoc:(null) occlude:0 /Volumes/Admin4
8/10/14 6:42:52.519 AM CoreServicesUIAgent[14210]: Saving rejection record:
Rejected URL=file:///Volumes/Admin4/Admin4.app/
App URL=file:///Volumes/Admin4/Admin4.app/
8/10/14 6:42:52.522 AM com.apple.launchd.peruser.501[277]: ([0x0-0x486486].org.admin4[14226]) Exited: Killed: 9
8/10/14 6:43:06.627 AM Admin4[14229]: Traceback (most recent call last):
8/10/14 6:43:06.627 AM Admin4[14229]: File "/Volumes/Admin4/Admin4.app/Contents/Resources/boot.py", line 117, in
8/10/14 6:43:06.627 AM Admin4[14229]: _run()
8/10/14 6:43:06.627 AM Admin4[14229]: File "/Volumes/Admin4/Admin4.app/Contents/Resources/boot.py", line 108, in _run
8/10/14 6:43:06.628 AM Admin4[14229]: exec(compile(source, path, 'exec'), globals(), globals())
8/10/14 6:43:06.628 AM Admin4[14229]: File "/Volumes/Admin4/Admin4.app/Contents/Resources/admin4.py", line 15, in
8/10/14 6:43:06.628 AM Admin4[14229]: main.main(sys.argv)
8/10/14 6:43:06.628 AM Admin4[14229]: File "/Volumes/Admin4/Admin4.app/Contents/Resources/main.py", line 274, in main
8/10/14 6:43:06.628 AM Admin4[14229]: opts, args = getopt.getopt(argv[1:], "m:n:", ["modules=", "name="])
8/10/14 6:43:06.628 AM Admin4[14229]: File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/getopt.py", line 90, in getopt
8/10/14 6:43:06.628 AM Admin4[14229]: opts, args = do_shorts(opts, args[0][1:], shortopts, args[1:])
8/10/14 6:43:06.629 AM Admin4[14229]: File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/getopt.py", line 190, in do_shorts
8/10/14 6:43:06.629 AM Admin4[14229]: if short_has_arg(opt, shortopts):
8/10/14 6:43:06.629 AM Admin4[14229]: File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/getopt.py", line 206, in short_has_arg
8/10/14 6:43:06.629 AM Admin4[14229]: raise GetoptError('option -%s not recognized' % opt, opt)
8/10/14 6:43:06.629 AM Admin4[14229]: getopt.GetoptError: option -p not recognized
8/10/14 6:43:06.695 AM Admin4[14229]: Admin4 Error
8/10/14 6:43:06.696 AM Admin4[14229]: 2014-08-10 06:43:06.694 Admin4[14229:707] Admin4 Error
8/10/14 6:43:09.550 AM com.apple.launchd.peruser.501[277]: ([0x0-0x487487].org.admin4[14229]) Exited with code: 255
8/10/14 6:44:09.379 AM Admin4[14261]: Traceback (most recent call last):
8/10/14 6:44:09.379 AM Admin4[14261]: File "/Applications/Admin4.app/Contents/Resources/boot.py", line 117, in
8/10/14 6:44:09.379 AM Admin4[14261]: _run()
8/10/14 6:44:09.380 AM Admin4[14261]: File "/Applications/Admin4.app/Contents/Resources/boot.py", line 108, in _run
8/10/14 6:44:09.380 AM Admin4[14261]: exec(compile(source, path, 'exec'), globals(), globals())
8/10/14 6:44:09.380 AM Admin4[14261]: File "/Applications/Admin4.app/Contents/Resources/admin4.py", line 15, in
8/10/14 6:44:09.380 AM Admin4[14261]: main.main(sys.argv)
8/10/14 6:44:09.380 AM Admin4[14261]: File "/Applications/Admin4.app/Contents/Resources/main.py", line 274, in main
8/10/14 6:44:09.380 AM Admin4[14261]: opts, args = getopt.getopt(argv[1:], "m:n:", ["modules=", "name="])
8/10/14 6:44:09.381 AM Admin4[14261]: File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/getopt.py", line 90, in getopt
8/10/14 6:44:09.381 AM Admin4[14261]: opts, args = do_shorts(opts, args[0][1:], shortopts, args[1:])
8/10/14 6:44:09.381 AM Admin4[14261]: File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/getopt.py", line 190, in do_shorts
8/10/14 6:44:09.381 AM Admin4[14261]: if short_has_arg(opt, shortopts):
8/10/14 6:44:09.381 AM Admin4[14261]: File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/getopt.py", line 206, in short_has_arg
8/10/14 6:44:09.381 AM Admin4[14261]: raise GetoptError('option -%s not recognized' % opt, opt)
8/10/14 6:44:09.381 AM Admin4[14261]: getopt.GetoptError: option -p not recognized
8/10/14 6:44:09.447 AM Admin4[14261]: Admin4 Error
8/10/14 6:44:09.447 AM Admin4[14261]: 2014-08-10 06:44:09.446 Admin4[14261:707] Admin4 Error
8/10/14 6:44:11.198 AM com.apple.launchd.peruser.501[277]: ([0x0-0x489489].org.admin4[14261]) Exited with code: 255
8/10/14 6:44:48.000 AM kernel[0]: hfs: unmount initiated on Admin4 on device disk1s1
8/10/14 6:46:55.000 AM kernel[0]: hfs: mounted Admin4 on device disk1s1
8/10/14 6:46:55.114 AM mds[60]: (Normal) Volume: volume:0x7f891b9ef000 ********** Bootstrapped Creating a default store:1 SpotLoc:(null) SpotVerLoc:(null) occlude:0 /Volumes/Admin4
8/10/14 6:47:35.580 AM CoreServicesUIAgent[14369]: Saving rejection record:
Rejected URL=file:///Volumes/Admin4/Admin4.app/
App URL=file:///Volumes/Admin4/Admin4.app/
8/10/14 6:47:35.582 AM com.apple.launchd.peruser.501[277]: ([0x0-0x4ab4ab].org.admin4[14367]) Exited: Killed: 9
8/10/14 6:47:49.446 AM CoreServicesUIAgent[14369]: Saving rejection record:
Rejected URL=file:///Applications/Admin4.app/
App URL=file:///Applications/Admin4.app/
8/10/14 6:47:49.448 AM com.apple.launchd.peruser.501[277]: ([0x0-0x4ad4ad].org.admin4[14376]) Exited: Killed: 9
8/10/14 6:47:59.645 AM Admin4[14378]: Traceback (most recent call last):
8/10/14 6:47:59.645 AM Admin4[14378]: File "/Applications/Admin4.app/Contents/Resources/boot.py", line 117, in
8/10/14 6:47:59.645 AM Admin4[14378]: _run()
8/10/14 6:47:59.645 AM Admin4[14378]: File "/Applications/Admin4.app/Contents/Resources/boot.py", line 108, in _run
8/10/14 6:47:59.645 AM Admin4[14378]: exec(compile(source, path, 'exec'), globals(), globals())
8/10/14 6:47:59.646 AM Admin4[14378]: File "/Applications/Admin4.app/Contents/Resources/admin4.py", line 15, in
8/10/14 6:47:59.646 AM Admin4[14378]: main.main(sys.argv)
8/10/14 6:47:59.646 AM Admin4[14378]: File "/Applications/Admin4.app/Contents/Resources/main.py", line 274, in main
8/10/14 6:47:59.646 AM Admin4[14378]: opts, args = getopt.getopt(argv[1:], "m:n:", ["modules=", "name="])
8/10/14 6:47:59.646 AM Admin4[14378]: File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/getopt.py", line 90, in getopt
8/10/14 6:47:59.646 AM Admin4[14378]: opts, args = do_shorts(opts, args[0][1:], shortopts, args[1:])
8/10/14 6:47:59.647 AM Admin4[14378]: File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/getopt.py", line 190, in do_shorts
8/10/14 6:47:59.647 AM Admin4[14378]: if short_has_arg(opt, shortopts):
8/10/14 6:47:59.647 AM Admin4[14378]: File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/getopt.py", line 206, in short_has_arg
8/10/14 6:47:59.647 AM Admin4[14378]: raise GetoptError('option -%s not recognized' % opt, opt)
8/10/14 6:47:59.647 AM Admin4[14378]: getopt.GetoptError: option -p not recognized
8/10/14 6:47:59.712 AM Admin4[14378]: Admin4 Error
8/10/14 6:47:59.712 AM Admin4[14378]: 2014-08-10 06:47:59.711 Admin4[14378:707] Admin4 Error
8/10/14 6:48:03.142 AM com.apple.launchd.peruser.501[277]: ([0x0-0x4ae4ae].org.admin4[14378]) Exited with code: 255

@andreas-p

This comment has been minimized.

Show comment
Hide comment
@andreas-p

andreas-p Aug 10, 2014

Owner

Am 10.08.14 um 12:53 schrieb dustinromey:

Tried versions 2.1.7 and 2.1.6 downloaded from Sourceforge. Below is
the Console output for Admin4:

/8/10/14 6:43:06.629 AM Admin4[14229]: raise GetoptError('option -%s
not recognized' % opt, opt)
8/10/14 6:43:06.629 AM Admin4[14229]: getopt.GetoptError: option -p
not recognized/

Hm, apparently admin4 is called with the -p option, which is unknown. I
have no idea where this may come from. Maybe if called directly from the
DMG? Try dragging Admin4 to the programs folder first.

just tried running it from the 2.1.7 DMG, successfully. Seems there's
something interfering on your machine.

Regards,
Andreas

Owner

andreas-p commented Aug 10, 2014

Am 10.08.14 um 12:53 schrieb dustinromey:

Tried versions 2.1.7 and 2.1.6 downloaded from Sourceforge. Below is
the Console output for Admin4:

/8/10/14 6:43:06.629 AM Admin4[14229]: raise GetoptError('option -%s
not recognized' % opt, opt)
8/10/14 6:43:06.629 AM Admin4[14229]: getopt.GetoptError: option -p
not recognized/

Hm, apparently admin4 is called with the -p option, which is unknown. I
have no idea where this may come from. Maybe if called directly from the
DMG? Try dragging Admin4 to the programs folder first.

just tried running it from the 2.1.7 DMG, successfully. Seems there's
something interfering on your machine.

Regards,
Andreas

@dustinromey

This comment has been minimized.

Show comment
Hide comment
@dustinromey

dustinromey Aug 10, 2014

I did attempt to open from the dmg first, then from ~/Applications/.

I'll try looking around in ~/Library/AppSupport, delete what I can and give
it another shot.

On Sun, Aug 10, 2014 at 7:47 AM, andreas-p notifications@github.com wrote:

Am 10.08.14 um 12:53 schrieb dustinromey:

Tried versions 2.1.7 and 2.1.6 downloaded from Sourceforge. Below is
the Console output for Admin4:

/8/10/14 6:43:06.629 AM Admin4[14229]: raise GetoptError('option -%s
not recognized' % opt, opt)
8/10/14 6:43:06.629 AM Admin4[14229]: getopt.GetoptError: option -p
not recognized/

Hm, apparently admin4 is called with the -p option, which is unknown. I
have no idea where this may come from. Maybe if called directly from the
DMG? Try dragging Admin4 to the programs folder first.

just tried running it from the 2.1.7 DMG, successfully. Seems there's
something interfering on your machine.

Regards,
Andreas


Reply to this email directly or view it on GitHub
#2 (comment).

dustinromey commented Aug 10, 2014

I did attempt to open from the dmg first, then from ~/Applications/.

I'll try looking around in ~/Library/AppSupport, delete what I can and give
it another shot.

On Sun, Aug 10, 2014 at 7:47 AM, andreas-p notifications@github.com wrote:

Am 10.08.14 um 12:53 schrieb dustinromey:

Tried versions 2.1.7 and 2.1.6 downloaded from Sourceforge. Below is
the Console output for Admin4:

/8/10/14 6:43:06.629 AM Admin4[14229]: raise GetoptError('option -%s
not recognized' % opt, opt)
8/10/14 6:43:06.629 AM Admin4[14229]: getopt.GetoptError: option -p
not recognized/

Hm, apparently admin4 is called with the -p option, which is unknown. I
have no idea where this may come from. Maybe if called directly from the
DMG? Try dragging Admin4 to the programs folder first.

just tried running it from the 2.1.7 DMG, successfully. Seems there's
something interfering on your machine.

Regards,
Andreas


Reply to this email directly or view it on GitHub
#2 (comment).

@dustinromey

This comment has been minimized.

Show comment
Hide comment
@dustinromey

dustinromey Aug 10, 2014

Tried it. Same result.

On Sun, Aug 10, 2014 at 1:07 PM, Dustin Romey dustinromey@gmail.com wrote:

I did attempt to open from the dmg first, then from ~/Applications/.

I'll try looking around in ~/Library/AppSupport, delete what I can and
give it another shot.

On Sun, Aug 10, 2014 at 7:47 AM, andreas-p notifications@github.com
wrote:

Am 10.08.14 um 12:53 schrieb dustinromey:

Tried versions 2.1.7 and 2.1.6 downloaded from Sourceforge. Below is
the Console output for Admin4:

/8/10/14 6:43:06.629 AM Admin4[14229]: raise GetoptError('option -%s
not recognized' % opt, opt)
8/10/14 6:43:06.629 AM Admin4[14229]: getopt.GetoptError: option -p
not recognized/

Hm, apparently admin4 is called with the -p option, which is unknown. I
have no idea where this may come from. Maybe if called directly from the
DMG? Try dragging Admin4 to the programs folder first.

just tried running it from the 2.1.7 DMG, successfully. Seems there's
something interfering on your machine.

Regards,
Andreas


Reply to this email directly or view it on GitHub
#2 (comment).

dustinromey commented Aug 10, 2014

Tried it. Same result.

On Sun, Aug 10, 2014 at 1:07 PM, Dustin Romey dustinromey@gmail.com wrote:

I did attempt to open from the dmg first, then from ~/Applications/.

I'll try looking around in ~/Library/AppSupport, delete what I can and
give it another shot.

On Sun, Aug 10, 2014 at 7:47 AM, andreas-p notifications@github.com
wrote:

Am 10.08.14 um 12:53 schrieb dustinromey:

Tried versions 2.1.7 and 2.1.6 downloaded from Sourceforge. Below is
the Console output for Admin4:

/8/10/14 6:43:06.629 AM Admin4[14229]: raise GetoptError('option -%s
not recognized' % opt, opt)
8/10/14 6:43:06.629 AM Admin4[14229]: getopt.GetoptError: option -p
not recognized/

Hm, apparently admin4 is called with the -p option, which is unknown. I
have no idea where this may come from. Maybe if called directly from the
DMG? Try dragging Admin4 to the programs folder first.

just tried running it from the 2.1.7 DMG, successfully. Seems there's
something interfering on your machine.

Regards,
Andreas


Reply to this email directly or view it on GitHub
#2 (comment).

@andreas-p

This comment has been minimized.

Show comment
Hide comment
@andreas-p

andreas-p Aug 10, 2014

Owner

Am 10.08.14 um 19:32 schrieb dustinromey:

Tried it. Same result.

On Sun, Aug 10, 2014 at 1:07 PM, Dustin Romey dustinromey@gmail.com
wrote:

I did attempt to open from the dmg first, then from ~/Applications/.

I'll try looking around in ~/Library/AppSupport, delete what I can and
give it another shot.

On Sun, Aug 10, 2014 at 7:47 AM, andreas-p notifications@github.com
wrote:

Am 10.08.14 um 12:53 schrieb dustinromey:

Tried versions 2.1.7 and 2.1.6 downloaded from Sourceforge. Below is
the Console output for Admin4:

/8/10/14 6:43:06.629 AM Admin4[14229]: raise GetoptError('option -%s
not recognized' % opt, opt)
8/10/14 6:43:06.629 AM Admin4[14229]: getopt.GetoptError: option -p
not recognized/

Hm, apparently admin4 is called with the -p option, which is
unknown. I
have no idea where this may come from. Maybe if called directly
from the
DMG? Try dragging Admin4 to the programs folder first.

just tried running it from the 2.1.7 DMG, successfully. Seems there's
something interfering on your machine.

Googling around it seems that the "Saving rejection record: Rejected
URL=file:///Volumes/Admin4/Admin4.app/" is linked to some "mac
optimization" programs.

Try "show package contents", and click Admin4.app/Contents/MacOS/Admin4
directly.

There must be some OSX extension on your system that injects the -p
option unexpectedly when using the normal open.

Regards
Andreas

Owner

andreas-p commented Aug 10, 2014

Am 10.08.14 um 19:32 schrieb dustinromey:

Tried it. Same result.

On Sun, Aug 10, 2014 at 1:07 PM, Dustin Romey dustinromey@gmail.com
wrote:

I did attempt to open from the dmg first, then from ~/Applications/.

I'll try looking around in ~/Library/AppSupport, delete what I can and
give it another shot.

On Sun, Aug 10, 2014 at 7:47 AM, andreas-p notifications@github.com
wrote:

Am 10.08.14 um 12:53 schrieb dustinromey:

Tried versions 2.1.7 and 2.1.6 downloaded from Sourceforge. Below is
the Console output for Admin4:

/8/10/14 6:43:06.629 AM Admin4[14229]: raise GetoptError('option -%s
not recognized' % opt, opt)
8/10/14 6:43:06.629 AM Admin4[14229]: getopt.GetoptError: option -p
not recognized/

Hm, apparently admin4 is called with the -p option, which is
unknown. I
have no idea where this may come from. Maybe if called directly
from the
DMG? Try dragging Admin4 to the programs folder first.

just tried running it from the 2.1.7 DMG, successfully. Seems there's
something interfering on your machine.

Googling around it seems that the "Saving rejection record: Rejected
URL=file:///Volumes/Admin4/Admin4.app/" is linked to some "mac
optimization" programs.

Try "show package contents", and click Admin4.app/Contents/MacOS/Admin4
directly.

There must be some OSX extension on your system that injects the -p
option unexpectedly when using the normal open.

Regards
Andreas

@dustinromey

This comment has been minimized.

Show comment
Hide comment
@dustinromey

dustinromey Aug 10, 2014

Opening it once that way seems to allow me to open it as normal.

Thanks.

On Sun, Aug 10, 2014 at 1:46 PM, andreas-p notifications@github.com wrote:

Am 10.08.14 um 19:32 schrieb dustinromey:

Tried it. Same result.

On Sun, Aug 10, 2014 at 1:07 PM, Dustin Romey dustinromey@gmail.com
wrote:

I did attempt to open from the dmg first, then from ~/Applications/.

I'll try looking around in ~/Library/AppSupport, delete what I can and
give it another shot.

On Sun, Aug 10, 2014 at 7:47 AM, andreas-p notifications@github.com
wrote:

Am 10.08.14 um 12:53 schrieb dustinromey:

Tried versions 2.1.7 and 2.1.6 downloaded from Sourceforge. Below is
the Console output for Admin4:

/8/10/14 6:43:06.629 AM Admin4[14229]: raise GetoptError('option -%s
not recognized' % opt, opt)
8/10/14 6:43:06.629 AM Admin4[14229]: getopt.GetoptError: option -p
not recognized/

Hm, apparently admin4 is called with the -p option, which is
unknown. I
have no idea where this may come from. Maybe if called directly
from the
DMG? Try dragging Admin4 to the programs folder first.

just tried running it from the 2.1.7 DMG, successfully. Seems there's
something interfering on your machine.

Googling around it seems that the "Saving rejection record: Rejected
URL=file:///Volumes/Admin4/Admin4.app/" is linked to some "mac
optimization" programs.

Try "show package contents", and click Admin4.app/Contents/MacOS/Admin4
directly.

There must be some OSX extension on your system that injects the -p
option unexpectedly when using the normal open.

Regards

Andreas


Reply to this email directly or view it on GitHub
#2 (comment).

dustinromey commented Aug 10, 2014

Opening it once that way seems to allow me to open it as normal.

Thanks.

On Sun, Aug 10, 2014 at 1:46 PM, andreas-p notifications@github.com wrote:

Am 10.08.14 um 19:32 schrieb dustinromey:

Tried it. Same result.

On Sun, Aug 10, 2014 at 1:07 PM, Dustin Romey dustinromey@gmail.com
wrote:

I did attempt to open from the dmg first, then from ~/Applications/.

I'll try looking around in ~/Library/AppSupport, delete what I can and
give it another shot.

On Sun, Aug 10, 2014 at 7:47 AM, andreas-p notifications@github.com
wrote:

Am 10.08.14 um 12:53 schrieb dustinromey:

Tried versions 2.1.7 and 2.1.6 downloaded from Sourceforge. Below is
the Console output for Admin4:

/8/10/14 6:43:06.629 AM Admin4[14229]: raise GetoptError('option -%s
not recognized' % opt, opt)
8/10/14 6:43:06.629 AM Admin4[14229]: getopt.GetoptError: option -p
not recognized/

Hm, apparently admin4 is called with the -p option, which is
unknown. I
have no idea where this may come from. Maybe if called directly
from the
DMG? Try dragging Admin4 to the programs folder first.

just tried running it from the 2.1.7 DMG, successfully. Seems there's
something interfering on your machine.

Googling around it seems that the "Saving rejection record: Rejected
URL=file:///Volumes/Admin4/Admin4.app/" is linked to some "mac
optimization" programs.

Try "show package contents", and click Admin4.app/Contents/MacOS/Admin4
directly.

There must be some OSX extension on your system that injects the -p
option unexpectedly when using the normal open.

Regards

Andreas


Reply to this email directly or view it on GitHub
#2 (comment).

@eagleflo

This comment has been minimized.

Show comment
Hide comment
@eagleflo

eagleflo Nov 10, 2014

I had the same problem on OS X 10.10. Needed to manually open the binary from inside the package first, after that opening the .app normally started working as well.

eagleflo commented Nov 10, 2014

I had the same problem on OS X 10.10. Needed to manually open the binary from inside the package first, after that opening the .app normally started working as well.

@andreas-p

This comment has been minimized.

Show comment
Hide comment
@andreas-p

andreas-p Nov 10, 2014

Owner

Interesting, thanks for your feedback.

Are your security settings for app downloads restricted?
If anybody encounters this problem, I'd be interested to learn if
security is restricted on the failing machine, and if it helps to start
Admin4 the first time by right clicking on it, select "open" and accept
it to run.

In the next release, I'll be catching that -p option, maybe that helps.

Regards
Andreas

Am 10.11.14 um 17:04 schrieb Aku Kotkavuo:

I had the same problem on OS X 10.10. Needed to manually open the
binary from inside the package first, after that opening the .app
normally started working as well.

Owner

andreas-p commented Nov 10, 2014

Interesting, thanks for your feedback.

Are your security settings for app downloads restricted?
If anybody encounters this problem, I'd be interested to learn if
security is restricted on the failing machine, and if it helps to start
Admin4 the first time by right clicking on it, select "open" and accept
it to run.

In the next release, I'll be catching that -p option, maybe that helps.

Regards
Andreas

Am 10.11.14 um 17:04 schrieb Aku Kotkavuo:

I had the same problem on OS X 10.10. Needed to manually open the
binary from inside the package first, after that opening the .app
normally started working as well.

@myrandor

This comment has been minimized.

Show comment
Hide comment
@myrandor

myrandor Nov 14, 2014

It's failing to me too on OSX 10.8.5 using version 2.2.0. I tried to open both the App and the executable inside the container and got this error in the console. Note that downloaded app are not restricted in my settings.

2014-11-14 17:06:05,359 CoreServicesUIAgent[7735]: com.apple.message.domain: com.apple.usage.gatekeeper.open-unsafe-executable-type
com.apple.message.signature: com.apple.application-bundle
com.apple.message.signature2: LSRiskCategoryUnsafeExecutable

2014-11-14 17:06:05,370 syspolicyd[5261]: assessment denied for .app but overridden
com.apple.message.domain: com.apple.security.assessment.outcome2
com.apple.message.signature2: bundle:org.admin4
com.apple.message.signature3: .app
com.apple.message.signature5: 2.2.0
com.apple.message.signature4: 1
com.apple.message.signature: defeated:no usable signature

myrandor commented Nov 14, 2014

It's failing to me too on OSX 10.8.5 using version 2.2.0. I tried to open both the App and the executable inside the container and got this error in the console. Note that downloaded app are not restricted in my settings.

2014-11-14 17:06:05,359 CoreServicesUIAgent[7735]: com.apple.message.domain: com.apple.usage.gatekeeper.open-unsafe-executable-type
com.apple.message.signature: com.apple.application-bundle
com.apple.message.signature2: LSRiskCategoryUnsafeExecutable

2014-11-14 17:06:05,370 syspolicyd[5261]: assessment denied for .app but overridden
com.apple.message.domain: com.apple.security.assessment.outcome2
com.apple.message.signature2: bundle:org.admin4
com.apple.message.signature3: .app
com.apple.message.signature5: 2.2.0
com.apple.message.signature4: 1
com.apple.message.signature: defeated:no usable signature

@andreas-p

This comment has been minimized.

Show comment
Hide comment
@andreas-p

andreas-p Nov 15, 2014

Owner

On 11/14/14 23:08, myrandor wrote:

It's failing to me too on OSX 10.8.5. I tried to open both the App and
the executable inside the container and got this error in the console.
Note that downloaded app are not restricted in my settings.

2014-11-14 17:06:05,359 CoreServicesUIAgent[7735]:
com.apple.message.domain:
com.apple.usage.gatekeeper.open-unsafe-executable-type
com.apple.message.signature: com.apple.application-bundle
com.apple.message.signature2: LSRiskCategoryUnsafeExecutable

2014-11-14 17:06:05,370 syspolicyd[5261]: assessment denied for .app
but overridden
com.apple.message.domain: com.apple.security.assessment.outcome2
com.apple.message.signature2: bundle:org.admin4
com.apple.message.signature3: .app
com.apple.message.signature5: 2.2.0
com.apple.message.signature4: 1
com.apple.message.signature: defeated:no usable signature

Hm, could you elaborate a little where those messages come from: the
first starting Admin4 directly from the app icon, the second inside the
container?
"...overridden" would indicate to me that the missing signature was
ignored, so it should run for you now? If not, can you start the
executable from a command line?

Regards,
Andreas

Owner

andreas-p commented Nov 15, 2014

On 11/14/14 23:08, myrandor wrote:

It's failing to me too on OSX 10.8.5. I tried to open both the App and
the executable inside the container and got this error in the console.
Note that downloaded app are not restricted in my settings.

2014-11-14 17:06:05,359 CoreServicesUIAgent[7735]:
com.apple.message.domain:
com.apple.usage.gatekeeper.open-unsafe-executable-type
com.apple.message.signature: com.apple.application-bundle
com.apple.message.signature2: LSRiskCategoryUnsafeExecutable

2014-11-14 17:06:05,370 syspolicyd[5261]: assessment denied for .app
but overridden
com.apple.message.domain: com.apple.security.assessment.outcome2
com.apple.message.signature2: bundle:org.admin4
com.apple.message.signature3: .app
com.apple.message.signature5: 2.2.0
com.apple.message.signature4: 1
com.apple.message.signature: defeated:no usable signature

Hm, could you elaborate a little where those messages come from: the
first starting Admin4 directly from the app icon, the second inside the
container?
"...overridden" would indicate to me that the missing signature was
ignored, so it should run for you now? If not, can you start the
executable from a command line?

Regards,
Andreas

@andreas-p andreas-p changed the title from Unable to run on Mac 10.9.4 to Unable to run on Mac OSX 10.x Nov 15, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment