Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 38 lines (28 sloc) 0.771 kb
24a36e6 Matija Pretnar Added Andrej's support for GNU autoconf.
matijapretnar authored
1 AC_INIT(eff,3.0)
2 AC_CONFIG_AUX_DIR([build-aux])
3 AC_CONFIG_MACRO_DIR([build-aux])
4 AM_MAINTAINER_MODE
5 AM_INIT_AUTOMAKE([foreign no-dependencies])
6
7 AC_PROG_OCAML
8
9 if test "$OCAMLBUILD" = "no"; then
10 AC_MSG_ERROR([You must install OCaml with ocamlbuild utility])
11 fi
12
13 AC_CHECK_TOOL([OCAMLMENHIR],[menhir],[no])
14 if test "$OCAMLMENHIR" = "no"; then
15 AC_MSG_ERROR([You must install the Ocaml menhir parser generator])
16 fi
17
18 AC_CHECK_TOOLS([WRAPPER],[rlwrap ledit],[no])
19
20 AC_SUBST([WRAPPER])
21
22 if test "$WRAPPER" = "no"; then
23 AC_MSG_WARN([No line-editing wrapper found])
24 fi
25
26 if test "$OCAMLBEST" = "opt"; then
27 BUILDBEST=native
28 else
29 BUILDBEST=byte
30 fi
31
32 AC_SUBST([BUILDBEST])
33
7b8c115 Andrej Bauer Better autoconf setup, got rid of the shell wrapper.
authored
34 effdir="$datarootdir/eff/$PACKAGE_VERSION"
35 AC_SUBST([effdir])
36
24a36e6 Matija Pretnar Added Andrej's support for GNU autoconf.
matijapretnar authored
37 AC_CONFIG_FILES([Makefile])
38 AC_OUTPUT
Something went wrong with that request. Please try again.