Permalink
Commits on Mar 9, 2011
Commits on Mar 5, 2011
Commits on Feb 15, 2011
  1. Restore compatibility with SQLite < 3.6.16. This is especially useful…

    FooBarWidget authored and tenderlove committed Feb 14, 2011
    … for people who are stuck on slightly older systems like Debian 5.
Commits on Jan 16, 2011
  1. updating release date

    tenderlove committed Jan 16, 2011
  2. updating version

    tenderlove committed Jan 16, 2011
Commits on Jan 13, 2011
  1. updating changelog

    tenderlove committed Jan 13, 2011
  2. renaming to sqlite3 gem

    tenderlove committed Jan 13, 2011
Commits on Dec 22, 2010
Commits on Dec 2, 2010
  1. adding a synopsis

    tenderlove committed Dec 2, 2010
Commits on Nov 23, 2010
Commits on Oct 30, 2010
  1. updating manifest

    tenderlove committed Oct 30, 2010
  2. SQLite3::Database can now be open in readonly mode

    luislavena committed Oct 30, 2010
    Useful for not messing this up, but catch 22 for :memory: dbs ;-)
    
    Closes GH-14
  3. fixing RDoc warnings

    tenderlove committed Oct 30, 2010
Commits on Oct 24, 2010
  1. Add SQLite3::VERSION etc.

    nurse committed Oct 24, 2010
    Bundled extension library of Ruby has some constants.
    For example, zlib has following:
    * Zlib::VERSION is the version of the zlib wrapper.
    * Zlib::ZLIB_VERSION is the version of the linked zlib.
    
    So following constants are added to sqlite3-ruby:
    * SQLite3::VERSION is the version of sqlite3-ruby
    * SQLite3::SQLITE_VERSION is the version of linked sqlite3.
    * SQLite3::SQLITE_VERSION_NUMBER is the numeric version of linked sqlite3.
Commits on Sep 28, 2010
  1. goodbye ruby 1.8.6

    tenderlove committed Sep 28, 2010
Commits on Sep 27, 2010
Commits on Sep 25, 2010
  1. Add read-only access mode

    yoshimoto committed Sep 25, 2010
Commits on Aug 27, 2010
Commits on Aug 25, 2010
  1. adding change to api notes

    tenderlove committed Aug 25, 2010
Commits on Aug 12, 2010
  1. Add SQLite3::Backup.

    nurse authored and tenderlove committed Aug 4, 2010
    Add wrapper class (SQLite3::Backup) for Online Backup API.
    http://www.sqlite.org/backup.html
    
    This feature requires SQLite 3.6.11 or later.
Commits on Jul 15, 2010
Commits on Jul 10, 2010