Permalink
Browse files

Merge branch 'master' of github.com:andrewvc/dripdrop

  • Loading branch information...
2 parents bd85b4f + 063102d commit beea433af9cf6a952306e9bf228d3f7b2c69be3c @andrewvc committed Mar 2, 2011
Showing with 40 additions and 121 deletions.
  1. +3 −0 .gitignore
  2. +5 −0 Gemfile
  3. +5 −29 Rakefile
  4. +0 −1 VERSION
  5. +24 −91 dripdrop.gemspec
  6. +3 −0 lib/dripdrop/version.rb
View
@@ -26,3 +26,6 @@ pkg
## PROJECT::SPECIFIC
.rvmrc
+Gemfile.lock
+.bundle
+*.gem
View
@@ -0,0 +1,5 @@
+source "http://rubygems.org"
+
+# Specify your gem's dependencies in dripdrop.gemspec
+gemspec
+
View
@@ -1,40 +1,16 @@
-require 'rubygems'
-require 'rake'
-
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gem|
- gem.name = "dripdrop"
- gem.summary = %Q{Evented framework for ZeroMQ and EventMachine Apps.}
- gem.description = %Q{Evented framework for ZeroMQ and EventMachine Apps. }
- gem.email = "andrew@andrewvc.com"
- gem.homepage = "http://github.com/andrewvc/dripdrop"
- gem.authors = ["Andrew Cholakian"]
- gem.add_dependency('eventmachine', '>= 0.12.10')
- gem.add_dependency('em-websocket')
- gem.add_dependency('em-zeromq', '>= 0.2.0')
- gem.add_development_dependency('rspec', '>= 2.4.0')
- end
- Jeweler::GemcutterTasks.new
-rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
-end
-
-task :test => :check_dependencies
-
-task :default => :test
+require 'bundler'
+Bundler::GemHelper.install_tasks
require 'rake/rdoctask'
+require 'dripdrop/version'
Rake::RDocTask.new do |rdoc|
- version = File.exist?('VERSION') ? File.read('VERSION') : ""
-
rdoc.rdoc_dir = 'rdoc'
- rdoc.title = "dripdrop #{version}"
+ rdoc.title = "dripdrop #{DripDrop::VERSION}"
rdoc.rdoc_files.include('README*')
rdoc.rdoc_files.include('lib/**/*.rb')
end
require 'rspec/core/rake_task'
RSpec::Core::RakeTask.new(:spec) do |t|
end
-
+task :default => :spec
View
@@ -1 +0,0 @@
-0.10.0.beta2
View
@@ -1,104 +1,37 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "dripdrop/version"
Gem::Specification.new do |s|
- s.name = %q{dripdrop}
- s.version = "0.10.0.beta2"
-
- s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
- s.authors = ["Andrew Cholakian"]
- s.date = %q{2011-03-01}
- s.description = %q{Evented framework for ZeroMQ and EventMachine Apps. }
- s.email = %q{andrew@andrewvc.com}
+ s.name = "dripdrop"
+ s.version = DripDrop::VERSION
+ s.platform = RUBY_PLATFORM[/java/] || Gem::Platform::RUBY
+ s.authors = ["Andrew Cholakian"]
+ s.email = ["andrew@andrewvc.com"]
+ s.homepage = "https://github.com/andrewvc/dripdrop"
+ s.summary = %q{Evented framework for ZeroMQ and EventMachine Apps.}
+ s.description = %q{Evented framework for ZeroMQ and EventMachine Apps.}
s.extra_rdoc_files = [
"LICENSE",
"README.md"
]
- s.files = [
- ".document",
- "LICENSE",
- "README.md",
- "Rakefile",
- "VERSION",
- "dripdrop.gemspec",
- "example/agent_test.rb",
- "example/combined.rb",
- "example/complex/README",
- "example/complex/client.rb",
- "example/complex/server.rb",
- "example/complex/service.rb",
- "example/complex/websocket.rb",
- "example/http.rb",
- "example/pubsub.rb",
- "example/pushpull.rb",
- "example/subclass.rb",
- "example/xreq_xrep.rb",
- "js/dripdrop.html",
- "js/dripdrop.js",
- "js/qunit.css",
- "js/qunit.js",
- "lib/dripdrop.rb",
- "lib/dripdrop/agent.rb",
- "lib/dripdrop/handlers/base.rb",
- "lib/dripdrop/handlers/http_client.rb",
- "lib/dripdrop/handlers/http_server.rb",
- "lib/dripdrop/handlers/mongrel2.rb",
- "lib/dripdrop/handlers/websocket_server.rb",
- "lib/dripdrop/handlers/zeromq.rb",
- "lib/dripdrop/message.rb",
- "lib/dripdrop/node.rb",
- "lib/dripdrop/node/nodelet.rb",
- "spec/gimite-websocket.rb",
- "spec/message_spec.rb",
- "spec/node/http_spec.rb",
- "spec/node/nodelet_spec.rb",
- "spec/node/routing_spec.rb",
- "spec/node/websocket_spec.rb",
- "spec/node/zmq_m2_spec.rb",
- "spec/node/zmq_pushpull_spec.rb",
- "spec/node/zmq_xrepxreq_spec.rb",
- "spec/node_spec.rb",
- "spec/spec_helper.rb"
- ]
- s.homepage = %q{http://github.com/andrewvc/dripdrop}
- s.require_paths = ["lib"]
- s.rubygems_version = %q{1.5.3}
- s.summary = %q{Evented framework for ZeroMQ and EventMachine Apps.}
- s.test_files = [
- "spec/gimite-websocket.rb",
- "spec/message_spec.rb",
- "spec/node/http_spec.rb",
- "spec/node/nodelet_spec.rb",
- "spec/node/routing_spec.rb",
- "spec/node/websocket_spec.rb",
- "spec/node/zmq_m2_spec.rb",
- "spec/node/zmq_pushpull_spec.rb",
- "spec/node/zmq_xrepxreq_spec.rb",
- "spec/node_spec.rb",
- "spec/spec_helper.rb"
- ]
- if s.respond_to? :specification_version then
- s.specification_version = 3
+ s.rubyforge_project = "dripdrop"
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<eventmachine>, [">= 0.12.10"])
- s.add_runtime_dependency(%q<em-websocket>, [">= 0"])
- s.add_runtime_dependency(%q<em-zeromq>, [">= 0.2.0"])
- s.add_development_dependency(%q<rspec>, [">= 2.4.0"])
- else
- s.add_dependency(%q<eventmachine>, [">= 0.12.10"])
- s.add_dependency(%q<em-websocket>, [">= 0"])
- s.add_dependency(%q<em-zeromq>, [">= 0.2.0"])
- s.add_dependency(%q<rspec>, [">= 2.4.0"])
- end
+ s.add_dependency "eventmachine", ">= 0.12.10"
+ s.add_dependency "em-websocket", ">= 0"
+ s.add_dependency "em-zeromq", ">= 0.2.0"
+ if s.platform.to_s == "java"
+ s.add_dependency "json", ">= 1.5.1"
else
- s.add_dependency(%q<eventmachine>, [">= 0.12.10"])
- s.add_dependency(%q<em-websocket>, [">= 0"])
- s.add_dependency(%q<em-zeromq>, [">= 0.2.0"])
- s.add_dependency(%q<rspec>, [">= 2.4.0"])
+ s.add_dependency "yajl-ruby", ">= 0.8.1"
+ s.add_dependency "eventmachine_httpserver", ">= 0.2.1"
end
+ s.add_development_dependency "rspec", ">= 2.4.0"
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.require_paths = ["lib"]
end
View
@@ -0,0 +1,3 @@
+class DripDrop
+ VERSION = "0.10.0.beta2"
+end

0 comments on commit beea433

Please sign in to comment.