Skip to content


Subversion checkout URL

You can clone with
Download ZIP


require.paths removed from Node.js as of v0.6 #90

kf6kjg opened this Issue · 1 comment

1 participant


This results in the error:
Error: require.paths is removed. Use node_modules folders, or the NODE_PATH environment variable instead.
at Function.Module._compile.Object.defineProperty.get (module.js:386:11)
at Object. (/home/x/.node_libraries/nodemailer@0.3.20/index.js:4:21)
at Module._compile (module.js:449:26)
at Object.Module._extensions..js (module.js:467:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:362:17)
at require (module.js:378:17)
at Object. (/home/x/test.js:11:18)
at Module._compile (module.js:449:26)

Tested under node.js version v0.8.0-pre with npm version 1.1.30 (git commit bc73abe5a8736359ff69f75948baf61f0431c42c, Jun 23 20:03:00 2012 -0600)


And this, I just discovered, was because I still had a ~/.node_libraries folder installed from an earlier version of node.js and npm. Removing that old folder and re-calling npm install nodemailer corrected the issue.

@kf6kjg kf6kjg closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.