New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

External Application Button Icons #3

Open
cognifloyd opened this Issue Feb 13, 2017 · 8 comments

Comments

Projects
None yet
3 participants
@cognifloyd

cognifloyd commented Feb 13, 2017

I'm using the External Application Button extension in both Chrome and Chromium on linux.

In both cases, the icon in the context menu is always the External Application Button icon, not the 32x32 icon I selected (/usr/share/icons/hicolor/google-chrome.png or /usr/share/icons/hicolor/chromium-browser.png). I've tried deleting/recreating my context menu entries and editing existing ones. It always shows that there is an icon in the settings dialog until I close the settings page. Even when it shows the icon (and "Updated!") on the settings page, the External Application Button icon is still used instead of the png I selected.

I have not tried a button in the toolbar because I want to use this within some chrome apps where the toolbar is not visible.

@andy-portmen

This comment has been minimized.

Owner

andy-portmen commented Feb 14, 2017

Unfortunetly the context menu icons are not yet configurable. Chrome does not have an option to have a custom icon for context-menu items yet
https://developer.chrome.com/extensions/contextMenus#method-create

have not tried a button in the toolbar because I want to use this within some chrome apps where the toolbar is not visible.

Toolbar icon should work as expected

@cognifloyd

This comment has been minimized.

cognifloyd commented Feb 26, 2017

I filed a chromium feature request (well, I couldn't figure out how to file a feature request so it went in as a "defect from user" report).

@andy-portmen

This comment has been minimized.

Owner

andy-portmen commented Feb 26, 2017

Great! Let's see if we get any response there.

@cognifloyd

This comment has been minimized.

cognifloyd commented Feb 27, 2017

@j605

This comment has been minimized.

j605 commented Jul 28, 2017

I encountered this problem in firefox 550b12. Can you please revisit this issue.

@andy-portmen

This comment has been minimized.

Owner

andy-portmen commented Jul 29, 2017

@j605 this is a limitation of the API. Unless the API is enhanced to allow icon insertion there is no way to fix this issue.

@cognifloyd

This comment has been minimized.

cognifloyd commented Sep 24, 2017

How does "/use/bin/env bash" resolve this issue about icons?

@andy-portmen andy-portmen reopened this Sep 24, 2017

@andy-portmen

This comment has been minimized.

Owner

andy-portmen commented Sep 24, 2017

wrong issue number in the commit!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment